Windows PowerShell command on Get-command zpool
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man zpool

System Administration Commands zpool(1M)

NAME

zpool - configures ZFS storage pools

SYNOPSIS

zpool [-?]

zpool add [-fn] pool vdev ...

zpool attach [-f] pool device new_device

zpool clear [-F [-n]] pool [device]

zpool create [-fn] [-o property=value] ... [-O file-system-property=value]

... [-m mountpoint] [-R root] pool vdev ...

zpool destroy [-f] pool

zpool detach pool device

zpool export [-f] pool ...

zpool get "all" | property[,...] pool ...

zpool history [-il] [pool] ...

zpool import [-d dir] [-D]

zpool import [-o mntopts] [-o property=value] ... [-d dir | -c cachefile]

[-D] [-f] [-m] [-N] [-R root] [-F [-n]] -a

zpool import [-o mntopts] [-o property=value] ... [-d dir | -c cachefile]

[-D] [-f] [-m] [-R root] [-F [-n]] pool |id [newpool]

zpool iostat [-T d|u ] [-v] [pool] ... [interval[count]]

zpool list [-H] [-o property[,...]] [-T d|u ] [pool] ... [interval[count]]

SunOS 5.11 Last change: 20 Aug 2010 1

System Administration Commands zpool(1M)

zpool offline [-t] pool device ...

zpool online pool device ...

zpool remove pool device ...

zpool replace [-f] pool device [new_device]

zpool scrub [-s] pool ...

zpool set property=value pool

zpool split [-R altroot] [-n] [-o mntopts] [-o property=value] pool

newpool [device ...]

zpool status [-xv] [-T d|u ] [pool] ... [interval[count]]

zpool upgrade

zpool upgrade -v

zpool upgrade [-V version] -a | pool ...

DESCRIPTION

The zpool command configures ZFS storage pools. A storage

pool is a collection of devices that provides physical storage and data replication for ZFS datasets. All datasets within a storage pool share the same space. See zfs(1M) for information on managing datasets. Virtual Devices (vdevs) A "virtual device" describes a single device or a collection of devices organized according to certain performance and fault characteristics. The following virtual devices are supported: disk A block device, typically located under /dev/dsk. ZFS

SunOS 5.11 Last change: 20 Aug 2010 2

System Administration Commands zpool(1M)

can use individual slices or partitions, though the recommended mode of operation is to use whole disks. A disk can be specified by a full path, or it can be a shorthand name (the relative portion of the path under "/dev/dsk"). A whole disk can be specified by omitting the slice or partition designation. When given a whole disk, ZFS automatically labels the disk, if necessary. file A regular file. The use of files as a backing store is strongly discouraged. It is designed primarily for experimental purposes, as the fault tolerance of a file is only as good as the file system of which it is a part. A file must be specified by a full path. mirror A mirror of two or more devices. Data is replicated in an identical fashion across all components of a mirror. A mirror with N disks of size X can hold X bytes and can

withstand (N-1) devices failing before data integrity is

compromised. raidz raidz1 raidz2 raidz3

A variation on RAID-5 that allows for better distribu-

tion of parity and eliminates the "RAID-5 write hole"

(in which data and parity become inconsistent after a power loss). Data and parity is striped across all disks within a raidz group.

A raidz group can have single-, double- , or triple par-

ity, meaning that the raidz group can sustain one, two, or three failures, respectively, without losing any

data. The raidz1 vdev type specifies a single-parity

raidz group; the raidz2 vdev type specifies a double-

parity raidz group; and the raidz3 vdev type specifies a

triple-parity raidz group. The raidz vdev type is an

alias for raidz1. A raidz group with N disks of size X with P parity disks

can hold approximately (N-P)*X bytes and can withstand P

device(s) failing before data integrity is compromised. The minimum number of devices in a raidz group is one more than the number of parity disks. The recommended

SunOS 5.11 Last change: 20 Aug 2010 3

System Administration Commands zpool(1M)

number is between 3 and 9 to help increase performance. spare

A special pseudo-vdev which keeps track of available hot

spares for a pool. For more information, see the "Hot Spares" section. log

A separate-intent log device. If more than one log dev-

ice is specified, then writes are load-balanced between

devices. Log devices can be mirrored. However, raidz vdev types are not supported for the intent log. For more information, see the "Intent Log" section. cache A device used to cache storage pool data. A cache device cannot be configured as a mirror or raidz group. For more information, see the "Cache Devices" section.

Virtual devices cannot be nested, so a mirror or raidz vir-

tual device can only contain files or disks. Mirrors of mir-

rors (or other combinations) are not allowed. A pool can have any number of virtual devices at the top of

the configuration (known as "root vdevs"). Data is dynami-

cally distributed across all top-level devices to balance

data among devices. As new virtual devices are added, ZFS automatically places data on the newly available devices. Virtual devices are specified one at a time on the command line, separated by whitespace. The keywords "mirror" and "raidz" are used to distinguish where a group ends and another begins. For example, the following creates two root vdevs, each a mirror of two disks:

# zpool create mypool mirror c0t0d0 c0t1d0 mirror c1t0d0 c1t1d0

Device Failure and Recovery ZFS supports a rich set of mechanisms for handling device failure and data corruption. All metadata and data is

SunOS 5.11 Last change: 20 Aug 2010 4

System Administration Commands zpool(1M)

checksummed, and ZFS automatically repairs bad data from a good copy when corruption is detected. In order to take advantage of these features, a pool must make use of some form of redundancy, using either mirrored

or raidz groups. While ZFS supports running in a non-

redundant configuration, where each root vdev is simply a disk or file, this is strongly discouraged. A single case of

bit corruption can render some or all of your data unavail-

able. A pool's health status is described by one of three states: online, degraded, or faulted. An online pool has all devices operating normally. A degraded pool is one in which one or more devices have failed, but the data is still available

due to a redundant configuration. A faulted pool has cor-

rupted metadata, or one or more faulted devices, and insuf-

ficient replicas to continue functioning.

The health of the top-level vdev, such as mirror or raidz

device, is potentially impacted by the state of its associ-

ated vdevs, or component devices. A top-level vdev or com-

ponent device is in one of the following states: DEGRADED

One or more top-level vdevs is in the degraded state

because one or more component devices are offline. Suf-

ficient replicas exist to continue functioning. One or more component devices is in the degraded or faulted state, but sufficient replicas exist to continue functioning. The underlying conditions are as follows:

o The number of checksum errors exceeds accept-

able levels and the device is degraded as an indication that something may be wrong. ZFS continues to use the device as necessary.

o The number of I/O errors exceeds acceptable levels. The device could not be marked as faulted because there are insufficient replicas to continue functioning. FAULTED

One or more top-level vdevs is in the faulted state

because one or more component devices are offline.

SunOS 5.11 Last change: 20 Aug 2010 5

System Administration Commands zpool(1M)

Insufficient replicas exist to continue functioning. One or more component devices is in the faulted state, and insufficient replicas exist to continue functioning. The underlying conditions are as follows: o The device could be opened, but the contents did not match expected values.

o The number of I/O errors exceeds acceptable levels and the device is faulted to prevent further use of the device. OFFLINE

The device was explicitly taken offline by the "zpool

offline" command. ONLINE The device is online and functioning. REMOVED The device was physically removed while the system was

running. Device removal detection is hardware-dependent

and may not be supported on all platforms. UNAVAIL The device could not be opened. If a pool is imported when a device was unavailable, then the device will be identified by a unique identifier instead of its path since the path was never correct in the first place. If a device is removed and later reattached to the system, ZFS attempts to put the device online automatically. Device

attach detection is hardware-dependent and might not be sup-

ported on all platforms. Hot Spares ZFS allows devices to be associated with pools as "hot spares". These devices are not actively used in the pool, but when an active device fails, it is automatically replaced by a hot spare. To create a pool with hot spares, specify a "spare" vdev with any number of devices. For

SunOS 5.11 Last change: 20 Aug 2010 6

System Administration Commands zpool(1M)

example,

# zpool create pool mirror c0d0 c1d0 spare c2d0 c3d0

Spares can be shared across multiple pools, and can be added

with the "zpool add" command and removed with the "zpool

remove" command. Once a spare replacement is initiated, a new "spare" vdev is created within the configuration that will remain there until the original device is replaced. At this point, the hot spare becomes available again if another device fails. If a pool has a shared spare that is currently being used, the pool can not be exported since other pools may use this shared spare, which may lead to potential data corruption.

An in-progress spare replacement can be cancelled by detach-

ing the hot spare. If the original faulted device is

detached, then the hot spare assumes its place in the confi-

guration, and is removed from the spare list of all active pools. Spares cannot replace log devices. Intent Log The ZFS Intent Log (ZIL) satisfies POSIX requirements for synchronous transactions. For instance, databases often require their transactions to be on stable storage devices

when returning from a system call. NFS and other applica-

tions can also use fsync() to ensure data stability. By default, the intent log is allocated from blocks within the

main pool. However, it might be possible to get better per-

formance using separate intent log devices such as NVRAM or a dedicated disk. For example:

# zpool create pool c0d0 c1d0 log c2d0

Multiple log devices can also be specified, and they can be

mirrored. See the EXAMPLES section for an example of mirror-

ing multiple log devices.

SunOS 5.11 Last change: 20 Aug 2010 7

System Administration Commands zpool(1M)

Log devices can be added, replaced, attached, detached, and imported, and exported as part of the larger pool. Mirrored

log devices can be removed by specifying the top-level mir-

ror for the log. Cache Devices Devices can be added to a storage pool as "cache devices." These devices provide an additional layer of caching between

main memory and disk. For read-heavy workloads, where the

working set size is much larger than what can be cached in main memory, using cache devices allow much more of this working set to be served from low latency media. Using cache devices provides the greatest performance improvement for

random read-workloads of mostly static content.

To create a pool with cache devices, specify a "cache" vdev with any number of devices. For example:

# zpool create pool c0d0 c1d0 cache c2d0 c3d0

Cache devices cannot be mirrored or part of a raidz confi-

guration. If a read error is encountered on a cache device,

that read I/O is reissued to the original storage pool dev-

ice, which might be part of a mirrored or raidz configura-

tion. The content of the cache devices is considered volatile, as is the case with other system caches. Processes

Each imported pool has an associated process, named zpool-

poolname. The threads in this process are the pool's I/O

processing threads, which handle the compression, checksum-

ming, and other tasks for all I/O associated with the pool. This process exists to provides visibility into the CPU utilization of the system's storage pools. The existence of this process is an unstable interface. Properties Each pool has several properties associated with it. Some

properties are read-only statistics while others are confi-

gurable and change the behavior of the pool. The following

are read-only properties:

alloc Amount of storage space within the pool that has been

SunOS 5.11 Last change: 20 Aug 2010 8

System Administration Commands zpool(1M)

physically allocated. capacity Percentage of pool space used. This property can also be referred to by its shortened column name, "cap". dedupratio The deduplication ratio specified for a pool, expressed as a multiplier. This value is expressed as a single decimal number. For example, a dedupratio value of 1.76 indicates that 1.76 units of data were stored but only 1 unit of disk space was actually consumed. This property can also be referred to by its shortened column name, dedup. Deduplication can be enabled as follows:

# zfs set dedup=on pool/dataset

The default value is off. See zfs(1M) for a description of the deduplication feature. free Number of blocks within the pool that are not allocated. guid A unique identifier for the pool. health The current health of the pool. Health can be "ONLINE",

"DEGRADED", "FAULTED", " OFFLINE", "REMOVED", or "UNA-

VAIL". size Total size of the storage pool.

SunOS 5.11 Last change: 20 Aug 2010 9

System Administration Commands zpool(1M)

These space usage properties report actual physical space available to the storage pool. The physical space can be different from the total amount of space that any contained datasets can actually use. The amount of space used in a raidz configuration depends on the characteristics of the data being written. In addition, ZFS reserves some space for internal accounting that the zfs(1M) command takes into

account, but the zpool command does not. For non-full pools

of a reasonable size, these effects should be invisible. For small pools, or pools that are close to being completely full, these discrepancies may become more noticeable. The following property can be set at creation time and import time: altroot Alternate root directory. If set, this directory is prepended to any mount points within the pool. This can be used when examining an unknown pool where the mount points cannot be trusted, or in an alternate boot environment, where the typical paths are not valid. altroot is not a persistent property. It is valid only while the system is up. Setting altroot defaults to using cachefile=none, though this may be overridden using an explicit setting. The following property can be set at import time: readonly=on | off Controls whether the pool can be modified. When enabled, any synchronous data that exists only on the intent log

will not be accessible until the pool is re-imported in

read-write mode.

Using read-only imports has the following limitations:

o Attempts to set additional zpool-level proper-

ties during import are ignored. o All filesystem mounts are converted to include the ro mount option.

o Additional mount options can be set on a tem-

porary basis.

A pool that has been imported read-only can be restored

to read-write by exporting and reimporting it.

SunOS 5.11 Last change: 20 Aug 2010 10

System Administration Commands zpool(1M)

The following properties can be set at creation time and

import time, and later changed with the zpool set command:

autoexpand=on | off Controls automatic pool expansion when the underlying LUN is grown. If set to on, the pool will be resized according to the size of the expanded device. If the device is part of a mirror or raidz then all devices within that mirror/raidz group must be expanded before the new space is made available to the pool. The default behavior is off. This property can also be referred to by its shortened column name, expand. autoreplace=on | off Controls automatic device replacement. If set to "off",

device replacement must be initiated by the administra-

tor by using the "zpool replace" command. If set to

"on", any new device, found in the same physical loca-

tion as a device that previously belonged to the pool, is automatically formatted and replaced. The default behavior is "off". This property can also be referred to by its shortened column name, "replace". bootfs=pool/dataset Identifies the default bootable dataset for the root pool. This property is expected to be set mainly by the installation and upgrade programs. cachefile=path | none Controls the location of where the pool configuration is cached. Discovering all pools on system startup requires a cached copy of the configuration data that is stored on the root file system. All pools in this cache are automatically imported when the system boots. Some environments, such as install and clustering, need to cache this information in a different location so that

pools are not automatically imported. Setting this pro-

perty caches the pool configuration in a different loca-

tion that can later be imported with "zpool import -c".

Setting it to the special value "none" creates a tem-

porary pool that is never cached, and the special value '' (empty string) uses the default location. Multiple pools can share the same cache file. Because the kernel destroys and recreates this file when pools

SunOS 5.11 Last change: 20 Aug 2010 11

System Administration Commands zpool(1M)

are added and removed, care should be taken when attempting to access this file. When the last pool using a cachefile is exported or destroyed, the file is removed. dedupditto=number Sets a threshold for number of copies. If the reference

count for a deduplicated block goes above this thres-

hold, another ditto copy of the block is stored automat-

ically. The default value is 0. delegation=on | off

Controls whether a non-privileged user is granted access

based on the dataset permissions defined on the dataset. See zfs(1M) for more information on ZFS delegated administration. failmode=wait | continue | panic

Controls the system behavior in the event of catas-

trophic pool failure. This condition is typically a result of a loss of connectivity to the underlying storage device(s) or a failure of all devices within the pool. The behavior of such an event is determined as follows: wait

Blocks all I/O access to the pool until the device connectivity is recovered and the errors are cleared. A pool remains in the wait state until the device issue is resolved. This is the default behavior. continue

Returns EIO to any new write I/O requests but allows reads to any of the remaining healthy devices. Any write requests that have yet to be committed to disk would be blocked. panic Prints out a message to the console and generates a system crash dump.

SunOS 5.11 Last change: 20 Aug 2010 12

System Administration Commands zpool(1M)

listsnaps=on | off Controls whether information about snapshots associated with this pool is output when "zfs list" is run without

the -t option. The default value is "off".

version=version

The current on-disk version of the pool. This can be

increased, but never decreased. The preferred method of

updating pools is with the zpool upgrade command, though

this property can be used when a specific version is needed for backwards compatibility. This property can be any number between 1 and the current version reported by

zpool upgrade -v.

Subcommands All subcommands that modify state are logged persistently to the pool in their original form.

The zpool command provides subcommands to create and destroy

storage pools, add capacity to storage pools, and provide

information about the storage pools. The following subcom-

mands are supported:

zpool -?

Displays a help message.

zpool add [-fn] pool vdev ...

Adds the specified virtual devices to the given pool.

The vdev specification is described in the "Virtual Dev-

ices" section. The behavior of the -f option, and the

device checks performed are described in the "zpool

create" subcommand.

-f

Forces use of vdevs, even if they appear in use or specify a conflicting replication level. Not all devices can be overridden in this manner.

-n

Displays the configuration that would be used without actually adding the vdevs. The actual pool

SunOS 5.11 Last change: 20 Aug 2010 13

System Administration Commands zpool(1M)

creation can still fail due to insufficient privileges or device sharing. Do not add a disk that is currently configured as a

quorum device to a zpool. After a disk is in the pool,

that disk can then be configured as a quorum device.

zpool attach [-f] pool device new_device

Attaches new_device to an existing zpool device. The

existing device cannot be part of a raidz configuration.

If device is not currently part of a mirrored configura-

tion, device automatically transforms into a two-way

mirror of device and new_device. If device is part of a

two-way mirror, attaching new_device creates a three-way

mirror, and so on. In either case, new_device begins to

resilver immediately.

-f

Forces use of new_device, even if its appears to be

in use. Not all devices can be overridden in this manner.

zpool clear [-F [-n]] pool [device] ...

Clears device errors in a pool. If no arguments are specified, all device errors within the pool are cleared. If one or more devices is specified, only those errors associated with the specified device or devices are cleared.

-F

Initiates recovery mode for an unopenable pool. Attempts to discard the last few transactions in the

pool to return it to an openable state. Not all dam-

aged pools can be recovered by using this option. If successful, the data from the discarded transactions is irretrievably lost.

-n

Used in combination with the -F flag. Check whether

discarding transactions would make the pool open-

able, but do not actually discard any transactions.

SunOS 5.11 Last change: 20 Aug 2010 14

System Administration Commands zpool(1M)

zpool create [-fn] [-o property=value] ... [-O file-system-

property=value] ... [-m mountpoint] [-R root] pool vdev ...

Creates a new storage pool containing the virtual dev-

ices specified on the command line. The pool name must begin with a letter, and can only contain alphanumeric

characters as well as underscore ("_"), dash ("-"), and

period ("."). The pool names mirror, raidz, spare, and

log are reserved, as are names beginning with the pat-

tern c[0-9]. The vdev specification is described in the

"Virtual Devices" section. The command verifies that each device specified is

accessible and not currently in use by another subsys-

tem. There are some uses, such as being currently mounted, or specified as the dedicated dump device, that prevents a device from ever being used by ZFS. Other uses, such as having a preexisting UFS file system, can

be overridden with the -f option.

The command also checks that the replication strategy

for the pool is consistent. An attempt to combine redun-

dant and non-redundant storage in a single pool, or to

mix disks and files, results in an error unless -f is

specified. The use of differently sized devices within a single raidz or mirror group is also flagged as an error

unless -f is specified.

Unless the -R option is specified, the default mount

point is "/pool". The mount point must not exist or must be empty, or else the root dataset cannot be mounted.

This can be overridden with the -m option.

-f

Forces use of vdevs, even if they appear in use or specify a conflicting replication level. Not all devices can be overridden in this manner.

-n

Displays the configuration that would be used without actually creating the pool. The actual pool creation can still fail due to insufficient privileges or device sharing.

-o property=value [-o property=value] ...

Sets the given pool properties. See the "Properties" section for a list of valid properties that can be

SunOS 5.11 Last change: 20 Aug 2010 15

System Administration Commands zpool(1M)

set.

-O file-system-property=value

[-O file-system-property=value] ...

Sets the given file system properties in the root

file system of the pool. See the "Properties" sec-

tion of zfs(1M) for a list of valid properties that can be set.

-R root

Equivalent to "-o cachefile=none,altroot=root"

-m mountpoint

Sets the mount point for the root dataset. The default mount point is "/pool" or "altroot/pool" if altroot is specified. The mount point must be an

absolute path, "legacy", or "none". For more infor-

mation on dataset mount points, see zfs(1M).

zpool destroy [-f] pool

Destroys the given pool, freeing up any devices for other use. This command tries to unmount any active datasets before destroying the pool.

-f

Forces any active datasets contained within the pool to be unmounted.

zpool detach pool device

Detaches device from a mirror. The operation is refused if there are no other valid replicas of the data.

zpool export [-f] pool ...

Exports the given pools from the system. All devices are marked as exported, but are still considered in use by

other subsystems. The devices can be moved between sys-

tems (even those of different endianness) and imported

SunOS 5.11 Last change: 20 Aug 2010 16

System Administration Commands zpool(1M)

as long as a sufficient number of devices are present. Before exporting the pool, all datasets within the pool are unmounted. A pool can not be exported if it has a shared spare that is currently being used.

For pools to be portable, you must give the zpool com-

mand whole disks, not just slices, so that ZFS can label the disks with portable EFI labels. Otherwise, disk drivers on platforms of different endianness will not recognize the disks.

-f

Forcefully unmount all datasets, using the "unmount

-f" command.

This command will forcefully export the pool even if it has a shared spare that is currently being used. This may lead to potential data corruption.

zpool get "all" | property[,...] pool ...

Retrieves the given list of properties (or all proper-

ties if "all" is used) for the specified storage

pool(s). These properties are displayed with the follow-

ing fields: name Name of storage pool property Property name value Property value source Property source, either 'default' or 'local'. See the "Properties" section for more information on the available pool properties.

zpool history [-il] [pool] ...

Displays the command history of the specified pools or all pools if no pool is specified.

-i

Displays internally logged ZFS events in addition to user initiated events.

SunOS 5.11 Last change: 20 Aug 2010 17

System Administration Commands zpool(1M)

-l

Displays log records in long format, which in addi-

tion to standard format includes, the user name, the hostname, and the zone in which the operation was performed.

zpool import [-d dir | -c cachefile] [-D]

Lists pools available to import. If the -d option is not

specified, this command searches for devices in

"/dev/dsk". The -d option can be specified multiple

times, and all directories are searched. If the device appears to be part of an exported pool, this command displays a summary of the pool with the name of the pool, a numeric identifier, as well as the vdev layout and current health of the device for each device or

file. Destroyed pools, pools that were previously des-

troyed with the "zpool destroy" command, are not listed

unless the -D option is specified.

The numeric identifier is unique, and can be used instead of the pool name when multiple exported pools of the same name are available.

-c cachefile

Reads configuration from the given cachefile that was created with the "cachefile" pool property. This cachefile is used instead of searching for devices.

-d dir

Searches for devices or files in dir. The -d option

can be specified multiple times.

-D

Lists destroyed pools only.

zpool import [-o mntopts] [ -o property=value] ... [-d dir |

-c cachefile] [-D] [-f] [-m] [-N] [-R root] [-F [-n]] -a

Imports all pools found in the search directories. Identical to the previous command, except that all pools with a sufficient number of devices available are

SunOS 5.11 Last change: 20 Aug 2010 18

System Administration Commands zpool(1M)

imported. Destroyed pools, pools that were previously

destroyed with the "zpool destroy" command, will not be

imported unless the -D option is specified.

-o mntopts

Comma-separated list of mount options to use when

mounting datasets within the pool. See zfs(1M) for a description of dataset properties and mount options.

-o property=value

Sets the specified property on the imported pool. See the "Properties" section for more information on the available pool properties.

-c cachefile

Reads configuration from the given cachefile that was created with the "cachefile" pool property. This cachefile is used instead of searching for devices.

-d dir

Searches for devices or files in dir. The -d option

can be specified multiple times. This option is

incompatible with the -c option.

-D

Imports destroyed pools only. The -f option is also

required.

-f

Forces import, even if the pool appears to be poten-

tially active.

-F

Recovery mode for a non-importable pool. Attempt to

return the pool to an importable state by discarding the last few transactions. Not all damaged pools can be recovered by using this option. If successful,

the data from the discarded transactions is irre-

trievably lost. This option is ignored if the pool

SunOS 5.11 Last change: 20 Aug 2010 19

System Administration Commands zpool(1M)

is importable or already imported.

-a

Searches for and imports all pools found.

-m

Allows a pool to import when there is a missing log device.

-R root

Sets the "cachefile" property to "none" and the "altroot" property to "root".

-N

Import the pool without mounting any file systems.

-n

Used with the -F recovery option. Determines whether

a non-importable pool can be made importable again,

but does not actually perform the pool recovery. For

more details about pool recovery mode, see the -F

option, above.

zpool import [-o mntopts] [ -o property=value] ... [-d dir |

-c cachefile] [-D] [-f] [-m] [-R root] [-F [-n]] pool | id

[newpool] Imports a specific pool. A pool can be identified by its name or the numeric identifier. If newpool is specified, the pool is imported using the name newpool. Otherwise, it is imported with the same name as its exported name. If a device is removed from a system without running

"zpool export" first, the device appears as potentially

active. It cannot be determined if this was a failed export, or whether the device is really in use from

another host. To import a pool in this state, the -f

option is required.

SunOS 5.11 Last change: 20 Aug 2010 20

System Administration Commands zpool(1M)

-o mntopts

Comma-separated list of mount options to use when

mounting datasets within the pool. See zfs(1M) for a description of dataset properties and mount options.

-o property=value

Sets the specified property on the imported pool. See the "Properties" section for more information on the available pool properties.

-c cachefile

Reads configuration from the given cachefile that was created with the "cachefile" pool property. This cachefile is used instead of searching for devices.

-d dir

Searches for devices or files in dir. The -d option

can be specified multiple times. This option is

incompatible with the -c option.

-D

Imports destroyed pool. The -f option is also

required.

-f

Forces import, even if the pool appears to be poten-

tially active.

-F

Recovery mode for a non-importable pool. Attempt to

return the pool to an importable state by discarding the last few transactions. Not all damaged pools can be recovered by using this option. If successful,

the data from the discarded transactions is irre-

trievably lost. This option is ignored if the pool is importable or already imported.

SunOS 5.11 Last change: 20 Aug 2010 21

System Administration Commands zpool(1M)

-R root

Sets the "cachefile" property to "none" and the "altroot" property to "root".

-n

Used with the -F recovery option. Determines whether

a non-importable pool can be made importable again,

but does not actually perform the pool recovery. For

more details about pool recovery mode, see the -F

option, above.

-m

Allows a pool to import when there is a missing log device.

zpool iostat [-T d|u] [-v] [pool] ... [interval[count]]

Displays I/O statistics for the given pools. When given an interval, the statistics are printed every interval

seconds until Ctrl-C is pressed. If no pools are speci-

fied, statistics for every pool in the system is shown. If count is specified, the command exits after count reports are printed.

-T d|u

Display a time stamp. Specify d for standard date format. See date(1).

Specify u for a printed representation of the inter-

nal representation of time. See time(2).

-v

Verbose statistics. Reports usage statistics for individual vdevs within the pool, in addition to the

pool-wide statistics.

zpool list [-H] [-o props[,...]] [-T d|u] [pool] ...

Lists the given pools along with a health status and space usage. When given no arguments, all pools in the

SunOS 5.11 Last change: 20 Aug 2010 22

System Administration Commands zpool(1M)

system are listed. When given an interval, the status and space usage are

displayed every interval seconds until Ctrl-C is

entered. If count is specified, the command exits after count reports are displayed.

-H

Scripted mode. Do not display headers, and separate fields by a single tab instead of arbitrary space.

-o props

Comma-separated list of properties to display. See

the "Properties" section for a list of valid proper-

ties. The default list is name, size, allocated, free, capacity, health, altroot.

-T d|u

Display a time stamp. Specify d for standard date format. See date(1).

Specify u for a printed representation of the inter-

nal representation of time. See time(2).

zpool offline [-t] pool device ...

Takes the specified physical device offline. While the device is offline, no attempt is made to read or write to the device.

This command is not applicable to spares or cache dev-

ices.

-t

Temporary. Upon reboot, the specified physical dev-

ice reverts to its previous state.

zpool online [-e] pool device...

Brings the specified physical device online. This command is not applicable to spares or cache

SunOS 5.11 Last change: 20 Aug 2010 23

System Administration Commands zpool(1M)

devices.

-e

Expand the device to use all available space. If the device is part of a mirror or raidz then all devices must be expanded before the new space will become available to the pool.

zpool remove pool device ...

Removes the specified device from the pool. This command currently only supports removing hot spares, cache, and log devices. A mirrored log device can be removed by

specifying the top-level mirror for the log. Non-log

devices that are part of a mirrored configuration can be

removed using the zpool detach command. Non-redundant

and raidz devices cannot be removed from a pool.

zpool replace [-f] pool old_device [new_device]

Replaces old_device with new_device. This is equivalent

to attaching new_device, waiting for it to resilver, and

then detaching old_device.

The size of new_device must be greater than or equal to

the minimum size of all the devices in a mirror or raidz configuration.

new_device is required if the pool is not redundant. If

new_device is not specified, it defaults to old_device.

This form of replacement is useful after an existing disk has failed and has been physically replaced. In this case, the new disk may have the same /dev/dsk path

as the old device, even though it is actually a dif-

ferent disk. ZFS recognizes this.

In zpool status output, the old_device is shown under

the word replacing with the string /old appended to it. Once the resilver completes, both the replacing and the

old_device are automatically removed. If the new device

fails before the resilver completes and a third device is installed in its place, then both failed devices will show up with /old appended, and the resilver starts over again. After the resilver completes, both /old devices are removed along with the word replacing.

-f

SunOS 5.11 Last change: 20 Aug 2010 24

System Administration Commands zpool(1M)

Forces use of new_device, even if its appears to be

in use. Not all devices can be overridden in this manner.

zpool scrub [-s] pool ...

Begins a scrub. The scrub examines all data in the specified pools to verify that it checksums correctly.

For replicated (mirror or raidz) devices, ZFS automati-

cally repairs any damage discovered during the scrub.

The "zpool status" command reports the progress of the

scrub and summarizes the results of the scrub upon com-

pletion. Scrubbing and resilvering are very similar operations. The difference is that resilvering only examines data that ZFS knows to be out of date (for example, when attaching a new device to a mirror or replacing an existing device), whereas scrubbing examines all data to discover silent errors due to hardware faults or disk failure.

Because scrubbing and resilvering are I/O-intensive

operations, ZFS allows only one at a time. If a scrub is

already in progress, a subsequent "zpool scrub" returns

an error, with the advice to use zpool scrub -s to can-

cel the current scrub. If a resilver is in progress, ZFS does not allow a scrub to be started until the resilver completes.

-s

Stop scrubbing.

zpool set property=value pool

Sets the given property on the specified pool. See the

"Properties" section for more information on what pro-

perties can be set and acceptable values.

zpool split [-R altroot] [-n] [-o mntopts] [-o

property=value] pool newpool [device ...]

Splits off one disk from each mirrored top-level vdev in

a pool and creates a new pool from the split-off disks.

The original pool must be made up of one or more mirrors and must not be in the process of resilvering. The split

SunOS 5.11 Last change: 20 Aug 2010 25

System Administration Commands zpool(1M)

subcommand chooses the last device in each mirror vdev

unless overridden by a device specification on the com-

mand line.

When using a device argument, split includes the speci-

fied device(s) in a new pool and, should any devices

remain unspecified, assigns the last device in each mir-

ror vdev to that pool, as it does normally. If you are uncertain about the outcome of a split command, use the

-n ("dry-run") option to ensure your command will have

the effect you intend.

-R altroot

Automatically import the newly created pool after splitting, using the specified altroot parameter for the new pool's alternate root. See the altroot description in the "Properties" section, above.

-n

Displays the configuration that would be created without actually splitting the pool. The actual pool split could still fail due to insufficient privileges or device status.

-o mntopts

Comma-separated list of mount options to use when

mounting datasets within the pool. See zfs(1M) for a description of dataset properties and mount options.

Valid only in conjunction with the -R option.

-o property=value

Sets the specified property on the new pool. See the "Properties" section, above, for more information on the available pool properties.

zpool status [-xv] [-T d|u] [pool] ... [interval[count]]

Displays the detailed health status for the given pools. If no pool is specified, then the status of each pool in the system is displayed. For more information on pool and device health, see the "Device Failure and Recovery" section.

SunOS 5.11 Last change: 20 Aug 2010 26

System Administration Commands zpool(1M)

When given an interval, the status and space usage are

displayed every interval seconds until Ctrl-C is

entered. If count is specified, the command exits after count reports are displayed. If a scrub or resilver is in progress, this command reports the percentage done and the estimated time to completion. Both of these are only approximate, because the amount of data in the pool and the other workloads on the system can change.

-x

Only display status for pools that are exhibiting errors or are otherwise unavailable.

-v

Displays verbose data error information, printing out a complete list of all data errors since the last complete pool scrub.

-T d|u

Display a time stamp. Specify d for standard date format. See date(1).

Specify u for a printed representation of the inter-

nal representation of time. See time(2).

zpool upgrade

Identifies a pool's on-disk version, which determines

available pool features in the currently running software release. You can continue to use older pool versions, but some features might not be available. A

pool can be upgraded by using the zpool upgrade -a com-

mand. You will not be able to access a pool of a later

version on a system that runs an earlier software ver-

sion.

zpool upgrade -v

Displays ZFS pool versions supported by the current software. The current ZFS pool versions and all previous

supported versions are displayed, along with an explana-

tion of the features provided with each version.

SunOS 5.11 Last change: 20 Aug 2010 27

System Administration Commands zpool(1M)

zpool upgrade [-V version] -a | pool ...

Upgrades the specified pool to the latest on-disk ver-

sion. If this command reveals that a pool is out-of-

date, the pool can subsequently be upgraded using the

zpool upgrade -a command. A pool that is upgraded will

not be accessible on a system that runs an earlier software release.

-a

Upgrades all pools.

-V version

Upgrade to the specified version, which must be

higher than the current version. If the -V flag is

not specified, the pool is upgraded to the most recent version.

EXAMPLES

Example 1 Creating a RAID-Z Storage Pool

The following command creates a pool with a single raidz root vdev that consists of six disks.

# zpool create tank raidz c0t0d0 c0t1d0 c0t2d0 c0t3d0 c0t4d0 c0t5d0

Example 2 Creating a Mirrored Storage Pool The following command creates a pool with two mirrors, where each mirror contains two disks.

# zpool create tank mirror c0t0d0 c0t1d0 mirror c0t2d0 c0t3d0

Example 3 Creating a ZFS Storage Pool by Using Slices The following command creates an unmirrored pool using two disk slices.

SunOS 5.11 Last change: 20 Aug 2010 28

System Administration Commands zpool(1M)

# zpool create tank /dev/dsk/c0t0d0s1 c0t1d0s4

Example 4 Creating a ZFS Storage Pool by Using Files The following command creates an unmirrored pool using files. While not recommended, a pool based on files can be useful for experimental purposes.

# zpool create tank /path/to/file/a /path/to/file/b

Example 5 Adding a Mirror to a ZFS Storage Pool The following command adds two mirrored disks to the pool

"tank", assuming the pool is already made up of two-way mir-

rors. The additional space is immediately available to any datasets within the pool.

# zpool add tank mirror c1t0d0 c1t1d0

Example 6 Listing Available ZFS Storage Pools

The following command lists all available pools on the sys-

tem.

# zpool list

NAME SIZE ALLOC FREE CAP DEDUP HEALTH ALTROOT

pool 136G 109M 136G 0% 3.00x ONLINE -

rpool 67.5G 12.6G 54.9G 18% 1.01x ONLINE -

Example 7 Listing All Properties for a Pool The following command lists all the properties for a pool.

% zpool get all pool

NAME PROPERTY VALUE SOURCE

pool size 464G -

SunOS 5.11 Last change: 20 Aug 2010 29

System Administration Commands zpool(1M)

pool capacity 0% -

pool altroot - default

pool health ONLINE -

pool guid 9893442355858802973 default pool version 23 default

pool bootfs - default

pool delegation on default pool autoreplace off default

pool cachefile - default

pool failmode wait default pool listsnapshots off default pool autoexpand off default pool dedupditto 0 default

pool dedupratio 1.00x -

pool free 464G -

pool allocated 130K -

Example 8 Destroying a ZFS Storage Pool The following command destroys the pool "tank" and any datasets contained within.

# zpool destroy -f tank

Example 9 Exporting a ZFS Storage Pool The following command exports the devices in pool tank so that they can be relocated or later imported.

# zpool export tank

Example 10 Importing a ZFS Storage Pool The following command displays available pools, and then imports the pool "tank" for use on the system. The results from this command are similar to the following:

SunOS 5.11 Last change: 20 Aug 2010 30

System Administration Commands zpool(1M)

# zpool import

pool: tank id: 7678868315469843843 state: ONLINE action: The pool can be imported using its name or numeric identifier. config: tank ONLINE

mirror-0 ONLINE

c1t2d0 ONLINE c1t3d0 ONLINE

# zpool import tank

Example 11 Upgrading All ZFS Storage Pools to the Current Version The following command upgrades all ZFS Storage pools to the current version of the software.

# zpool upgrade -a

This system is currently running ZFS pool version 22. All pools are formatted using this version. Example 12 Managing Hot Spares The following command creates a new pool with an available hot spare:

# zpool create tank mirror c0t0d0 c0t1d0 spare c0t2d0

If one of the disks were to fail, the pool would be reduced to the degraded state. The failed device can be replaced using the following command:

# zpool replace tank c0t0d0 c0t3d0

SunOS 5.11 Last change: 20 Aug 2010 31

System Administration Commands zpool(1M)

After the device has been resilvered, the spare is automati-

cally detached and is made available should another device fail. The hot spare can be permanently removed from the pool using the following command:

# zpool remove tank c0t2d0

Example 13 Creating a ZFS Pool with Mirrored Separate Intent Logs The following command creates a ZFS storage pool consisting

of two, two-way mirrors and mirrored log devices:

# zpool create pool mirror c0d0 c1d0 mirror c2d0 c3d0 log mirror \

c4d0 c5d0 Example 14 Adding Cache Devices to a ZFS Pool

The following command adds two disks for use as cache dev-

ices to a ZFS storage pool:

# zpool add pool cache c2d0 c3d0

Once added, the cache devices gradually fill with content

from main memory. Depending on the size of your cache dev-

ices, it could take over an hour for them to fill. Capacity

and reads can be monitored using the iostat option as fol-

lows:

# zpool iostat -v pool 5

Example 15 Removing a Mirrored Log Device The following command removes the mirrored log device

mirror-2.

SunOS 5.11 Last change: 20 Aug 2010 32

System Administration Commands zpool(1M)

Given this configuration: pool: tank state: ONLINE scrub: none requested config:

NAME STATE READ WRITE CKSUM

tank ONLINE 0 0 0

mirror-0 ONLINE 0 0 0

c6t0d0 ONLINE 0 0 0 c6t1d0 ONLINE 0 0 0

mirror-1 ONLINE 0 0 0

c6t2d0 ONLINE 0 0 0 c6t3d0 ONLINE 0 0 0 logs

mirror-2 ONLINE 0 0 0

c4t0d0 ONLINE 0 0 0 c4t1d0 ONLINE 0 0 0

The command to remove the mirrored log mirror-2 is:

# zpool remove tank mirror-2

Example 16 Recovering a Faulted ZFS Pool If a pool is faulted but recoverable, a message indicating

this state is provided by zpool status if the pool was

cached (see cachefile above), or as part of the error output

from a failed zpool import of the pool.

Recover a cached pool with the zpool clear command:

# zpool clear -F data

Pool data returned to its state as of Tue Sep 08 13:23:35 2009. Discarded approximately 29 seconds of transactions.

SunOS 5.11 Last change: 20 Aug 2010 33

System Administration Commands zpool(1M)

If the pool configuration was not cached, use zpool import

with the recovery mode flag:

# zpool import -F data

Pool data returned to its state as of Tue Sep 08 13:23:35 2009. Discarded approximately 29 seconds of transactions. Example 17 Importing with a Single Intent Log Device The following sequence of commands attempts to import a pool

with a missing device, then employs the -m option to com-

plete the import operation.

# zpool import

pool: tank id: 429789444028972405 state: UNAVAIL status: One or more devices are missing from the system. action: The pool cannot be imported. Attach the missing devices and try again.

see: http://www.sun.com/msg/ZFS-8000-6X

config: tank UNAVAIL missing device c7t0d0 ONLINE Additional devices are known to be part of this pool, though their exact configuration cannot be determined.

# zpool import tank

The devices below are missing, use '-m' to import the pool anyway:

c5t0d0 [log] cannot import 'tank': one or more devices is currently unavailable

# zpool import -m tank

# zpool status tank

pool: tank state: DEGRADED status: One or more devices could not be opened. Sufficient replicas exist for the pool to continue functioning in a degraded state.

action: Attach the missing device and online it using 'zpool online'.

SunOS 5.11 Last change: 20 Aug 2010 34

System Administration Commands zpool(1M)

see: http://www.sun.com/msg/ZFS-8000-2Q

scan: none requested config:

NAME STATE READ WRITE CKSUM

tank DEGRADED 0 0 0 c7t0d0 ONLINE 0 0 0 logs 1693927398582730352 UNAVAIL 0 0 0 was /dev/dsk/c5t0d0 errors: No known data errors Example 18 Importing with a Mirrored Intent Log Device The following sequence of commands attempts to import a pool when a mirrored log device is unavailable, then employs the

-m option to complete the import operation.

# zpool import

pool: tank id: 429789444028972405 state: UNAVAIL status: One or more devices are missing from the system. action: The pool cannot be imported. Attach the missing devices and try again.

see: http://www.sun.com/msg/ZFS-8000-6X

config: tank UNAVAIL missing device c7t0d0 ONLINE Additional devices are known to be part of this pool, though their exact configuration cannot be determined.

# zpool import tank

The devices below are missing, use '-m' to import the pool anyway:

mirror-1 [log]

c5t0d0 c5t1d0

# zpool import -m tank

# zpool status tank

SunOS 5.11 Last change: 20 Aug 2010 35

System Administration Commands zpool(1M)

pool: tank state: DEGRADED status: One or more devices could not be opened. Sufficient replicas exist for the pool to continue functioning in a degraded state.

action: Attach the missing device and online it using 'zpool online'.

see: http://www.sun.com/msg/ZFS-8000-2Q

scan: none requested config:

NAME STATE READ WRITE CKSUM

tank DEGRADED 0 0 0 c7t0d0 ONLINE 0 0 0 logs

mirror-1 UNAVAIL 0 0 0

insufficient replicas 46385995713041169 UNAVAIL 0 0 0 was /dev/dsk/c5t0d0 13821442324672734438 UNAVAIL 0 0 0 was /dev/dsk/c5t1d0 errors: No known data errors EXIT STATUS The following exit values are returned: 0 Successful completion. 1 An error occurred. 2 Invalid command line options were specified.

ATTRIBUTES

See attributes(5) for descriptions of the following attri-

butes:

SunOS 5.11 Last change: 20 Aug 2010 36

System Administration Commands zpool(1M)

____________________________________________________________

| ATTRIBUTE TYPE | ATTRIBUTE VALUE |

|_____________________________|_____________________________|

| Availability | system/file-system/zfs |

|_____________________________|_____________________________|

| Interface Stability | Committed |

|_____________________________|_____________________________|

SEE ALSO

zfs(1M), attributes(5)

SunOS 5.11 Last change: 20 Aug 2010 37




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™