Windows PowerShell command on Get-command vrrpadm
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man vrrpadm

System Administration Commands vrrpadm(1M)

NAME

vrrpadm - VRRP administration tool

SYNOPSIS

vrrpadm create-router -V vrid -l link -A inet | inet6

[-p priority] [-i adv_interval] [-o flags] router_name

vrrpadm delete-router router_name

vrrpadm disable-router router_name

vrrpadm enable-router router_name

vrrpadm modify-router [-p priority] [-i adv_interval]

[-o flags] [router_name]

vrrpadm show-router [-P | -x] [-p] [-o field[,...]] [router_name]

DESCRIPTION

The vrrpadm command is used to administer the VRRP (Virtual

Router Redundancy Protocol) service in a system. VRRP specifies an election protocol that dynamically assigns responsibility for a virtual router to one of the VRRP routers within a LAN. At a given moment, only one VRRP

router controls the IPv4 or IPv6 virtual address(es) associ-

ated with a virtual router (known as the master), and for-

wards packets sent to these IP addresses. The election pro-

cess provides dynamic failover of the forwarding responsi-

bility should the master become unavailable.

Each vrrpadm subcommand operates on a VRRP router, which is

identified by a name given by the administrator. VRRP routers with the same VRID and address family within a LAN comprise a virtual router, which protects a set of virtual IP addresses. A system can have multiple VRRP routers; each belongs to a different virtual router.

SUB-COMMANDS

The following subcommands are supported. Note that all sub-

commands but show-router require the solaris.network.vrrp

SunOS 5.11 Last change: 14 Oct 2009 1

System Administration Commands vrrpadm(1M)

authorization. The show-router subcommand does not require

special authorizations.

vrrpadm create-router -V vrid -l link -A inet | inet6 [-p

priority] [-i adv_interval] [-o flags] router_name

Create a VRRP router with a specified configuration.

-A inet | inet6, --address_family=inet | inet6

Address family. Either IPv4 or IPv6.

-i adv_interval, --adv_interval=adv_interval

The advertisement interval in milliseconds. Default is 1000 (one second). The valid interval range is

10-40950.

-l link, --link=link

The data link on which the VRRP router is config-

ured. This determines the LAN this VRRP router is

running in. The data-link can be a physical link, a

VLAN, or an aggregation.

-o flags, --flags=flags

The preempt and accept modes, delimited by a comma. Values can be: o preempt

o un_preempt

o accept o noaccept By default both modes are set to true. The preempt mode controls whether an enabled higher priority backup router preempts a lower priority master router. If preempt mode is true, then the preemption is allowed; otherwise, preemption is prohibited. Note that the preempt mode must be true if the VRRP router is the owner of the virtual IP addresses. The accept mode controls the local packet acceptance of the virtual IP addresses. If accept mode is true,

SunOS 5.11 Last change: 14 Oct 2009 2

System Administration Commands vrrpadm(1M)

the master must accept packets sent to the virtual IP addresses. If accept mode is false, the master does not accept those packets, although it does respond to ARP requests or ND Solicitations and

Advertisement for those non-accepted virtual IP

addresses. It also must forward packets for the router specified in this subcommand. Note that accept mode must be true if the VRRP router is the owner of the virtual IP addresses. An example of syntax for this option:

-o preempt,no_accept

-p priority, --priority=priority

The priority of the specified VRRP router used in master selection. The higher the value, the greater

the possibility the router is selected as the mas-

ter.

The default value is 255, which indicates the speci-

fied VRRP router is the IP Address Owner and owns all the virtual IP addresses. An IP Address Owner will respond to the packets addressed to one of the

virtual IP addresses for ICMP pings, TCP connec-

tions, and so forth.

The range 1-254 is available for VRRP routers back-

ing up a virtual router. Master selection is weighted toward the VRRP router with the higher priority.

-V vrid, --VRID=vrid

The virtual router identifier (VRID). Together with the address family, it identifies a virtual router within a LAN.

router_name

The name of a VRRP router. This name is used to

identify a VRRP router in other vrrpadm subcommands.

The maximum length of a valid router name is 31

characters. Legal characters are alphanumeric (a-z,

A-Z, 0-9) and the underscore ('_').

SunOS 5.11 Last change: 14 Oct 2009 3

System Administration Commands vrrpadm(1M)

vrrpadm delete-router router_name

Delete the VRRP router identified by router_name.

vrrpadm disable-router router_name

Disable the virtual router identified by router_name.

Once the router is disabled, it will stop participating in the master selection process in the virtual router.

vrrpadm enable-router router_name

Re-enable the virtual router identified by router_name

that was disabled. The router will resume participating in the master selection process in the virtual router.

vrrpadm modify-router [-p priority] [-i adv_interval]

[-o flags] [router_name]

Modify the configuration of the VRRP router identified

by router_name. Only the priority, the advertisement

interval, the preempt mode, and the accept mode can be modified.

-p priority, --priority=priority

The new priority of this VRRP router.

-i adv_interval, --adv_interval=adv_interval

The new advertisement interval.

-o flags, --flags=flags

The new preempt and accept modes. Either one or both can be specified. If both are specified, they are delimited by a comma. For example:

-o preempt,no_accept

vrrpadm show-router [-P | -x] [-p] [-o field[,...]]

[router_name]

SunOS 5.11 Last change: 14 Oct 2009 4

System Administration Commands vrrpadm(1M)

Display the information for the VRRP router identified

by router_name. If no router_name is specified, display

information for all the VRRP routers on the system. By default (with no options), the following fields are displayed:

NAME

The name of the VRRP router. VRID The VRID of the VRRP router. LINK The data link on which the VRRP router is created. AF he address family of the VRRP router, either IPv4 or IPv6. PRIO The priority of this VRRP router used in master selection.

ADV_INTV

The advertisement interval, in milliseconds. STATE

The current state of the VRRP router, INIT (Initial-

ize), BACK (Backup), or MAST (Master). MODE

A set of flags associated with the VRRP router. Pos-

sible values are: e The router has been enabled.

SunOS 5.11 Last change: 14 Oct 2009 5

System Administration Commands vrrpadm(1M)

p Preempt mode is true. a Accept mode is true. o Virtual address owner. VNIC The VRRP VNIC created for this VRRP router. Note that the name of the VNIC can change over time unless the router is enabled.

The show-router subcommand has the following options:

-x, --extended

Display additional information of the given VRRP router:

PRIMARY_IP

The primary IP address selected by the VRRP router.

VIRTUAL_IPS

The virtual IP addresses configured on the VRRP router.

PRV_STAT

The previous state of the VRRP router.

STAT_LAST

Time since the last state transition.

-P, --peer

Display information for the backup VRRP router. This option is meaningful only when the VRRP router is in the backup state.

SunOS 5.11 Last change: 14 Oct 2009 6

System Administration Commands vrrpadm(1M)

The following fields are displayed:

NAME

The name of the VRRP router. PEER The primary IP address of the peer VRRP router.

P_PRIO

The priority of the peer VRRP router contained in the advertisement received from the peer.

P_INTV

The advertisement interval (in milliseconds) contained in advertisements received from the peer.

P_ADV_LAST

Time since last received advertisement from the peer.

MASTER_DOWN_INT

Time interval (in milliseconds) after which to declare Master down.

-p, --parseable

Display the VRRP router information in the machine parseable format.

-o field[,...], --output=field

A case-insensitive, comma-separated list of output

fields to display. The field name must be one of the fields listed above, or the special value all to

display all fields. By default (without -o), vrrpadm

show displays all fields.

SunOS 5.11 Last change: 14 Oct 2009 7

System Administration Commands vrrpadm(1M)

ATTRIBUTES

See attributes(5) for descriptions of the following attri-

butes:

____________________________________________________________

| ATTRIBUTE TYPE | ATTRIBUTE VALUE |

|_____________________________|_____________________________|

| Availability | system/network/routing/vrrp |

|_____________________________|_____________________________|

| Interface Stability | Committed |

|_____________________________|_____________________________|

SEE ALSO

dladm(1M), vrrpd(1M), attributes(5)

SunOS 5.11 Last change: 14 Oct 2009 8




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™