STREAMS Modules usbwcm(7M)
NAME
usbwcm - STREAMS module for Wacom USB Tablets
SYNOPSIS
# include
DESCRIPTION
The usbwcm STREAMS module processes byte streams generated
by a Wacom USB tablet.The usbwcm module must be pushed on top of the HID class
driver. See hid(7D). The usbwcm module translates data from
Wacom USB tablet into formatted events expected by Wacom X.org XInputdriver. The event structure is the same as that of FreeBSD uwacom driver. Event StructureThe event_input structure is defined in:
usr/include/sys/usb/clients/usbinput/usbwcm/usbwcm.h
struct event_input {
#if defined(_LP64) || defined(_I32LPx)
struct timeval32 time;#else
struct timeval time;#endif
uint16_t type;
uint16_t index;
int32_t value;
}; time The event's timestamp. When the event occurred. The timestamp is not defined to be meaningful except by being compared with other input event timestamps. type The event's unique type: button, relative/absolute valuator, sync, and so forth. type is among thefollowing: EVT_SYN, EVT_BTN, EVT_REL, EVT_ABS and
EVT_MSC.
index The event's sub-type. The index in a button event
identifies which button status was changed. Typicalbutton index includes: BTN_LEFT, BTN_RIGHT,
BTN_MIDDLE, BTN_SIDE, BTN_EXTRA, BTN_TOOL_PEN,
BTN_TOOL_ERASER, BTN_TOOL_PAD, BTN_TOOL_MOUSE,
BTN_TIP, BTN_STYLUS_1, BTN_STYLUS_2
For absolute valuators, index is among theSunOS 5.11 Last change: 15 Jan 2010 1
STREAMS Modules usbwcm(7M)
following: ABS_X, ABS_Y, ABS_Z, ABS_RX, ABS_RY,
ABS_WHEEL, ABS_PRESSURE, ABS_DISTANCE, ABS_TILT_X,
ABS_TILT_Y, and ABS_MISC.
Ioctls EVTIOCGVERSION The argument is a pointer to an int. This option returns the current version of the event interface implemented by the STREAMS module.EVTIOCGDEVID The argument is a pointer to event_dev_id
structure. This ioctl returns the identif-
iers of the device.struct event_dev_id {
uint16_t bus;
#defineID_BUS_USB 3
uint16_t vendor;
uint16_t product;
uint16_t version;
};EVTIOCGBM The argument is a pointer to an variable-
length char array. This ioctl returns the event types reported by device:EVT_SYN, EVT_BTN, EVT_REL, EVT_ABS,
EVT_MSC
EVTIOCGABS The argument is a pointer to anevent_abs_axis structure. This ioctl
returns the ranges, and other parameters for the specified axis.struct event_abs_axis {
int32_t value;
int32_t min;
int32_t max;
int32_t fuzz;
int32_t flat;
}; FILES/kernel/strmod/usbwcm
SunOS 5.11 Last change: 15 Jan 2010 2
STREAMS Modules usbwcm(7M)
32-bit ELF kernel STREAMS module
/kernel/strmod/amd64/usbwcm
64-bit ELF kernel STREAMS module
/kernel/strmod/sparcv9/usbwcm
SPARC 64-bit ELF kernel STREAMS module
ATTRIBUTES
See attributes(5) for descriptions of the following attri-
butes:____________________________________________________________
| ATTRIBUTE TYPE | ATTRIBUTE VALUE |
|_____________________________|_____________________________|
| Architecture | SPARC, x86-based systems |
|_____________________________|_____________________________|
| Availability | driver/usb ||_____________________________|_____________________________|
SEE ALSO
ioctl(2), attributes(5), hid(7D) System Administration Guide: Basic Administration http://linuxwacom.sourceforge.net http://www.sun.comSunOS 5.11 Last change: 15 Jan 2010 3