Windows PowerShell command on Get-command usb_pipe_get_max_bulk_transfer_size
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man usb_pipe_get_max_bulk_transfer_size

Kernel Functions for Drivers

usb_pipe_get_max_bulk_transfer_size(9F)

NAME

usb_pipe_get_max_bulk_transfer_size - Get maximum bulk

transfer size

SYNOPSIS

#include

int usb_pipe_get_max_bulk_transfer_size(dev_info_t dip, size_t *size);

INTERFACE LEVEL

Solaris DDI specific (Solaris DDI)

PARAMETERS

dip Pointer to the device's dev_info structure.

size Returns the bulk transfer size.

DESCRIPTION

The usb_pipe_get_max_bulk_transfer_size() function returns

the maximum data transfer size in bytes that the host con-

troller driver can support per bulk request. This informa-

tion can be used to limit or break down larger requests to manageable sizes.

RETURN VALUES

USB_SUCCESS Size is returned in size argument.

USB_INVALID_ARGS dip and/or size argument is NULL.

USB_FAILURE Size could not be returned. Zero is

returned in size arg.

CONTEXT

May be called from user, kernel or interrupt context.

EXAMPLES

int xxx_attach(dev_info_t *dip, int command)

{ ...

usb_pipe_get_max_bulk_transfer_size(dip, &state>max_xfer_size);

... }

void xxx_minphys(struct buf bp)

{

SunOS 5.11 Last change: 5 Jan 2004 1

Kernel Functions for Drivers

usb_pipe_get_max_bulk_transfer_size(9F)

...

if (bp->b_bcount > state->max_xfer_size) {

bp->b_bcount = state->max_xfer_size;

} ... }

ATTRIBUTES

See attributes(5) for descriptions of the following attri-

butes:

____________________________________________________________

| ATTRIBUTE TYPE | ATTRIBUTE VALUE |

|_____________________________|_____________________________|

| Architecture | PCI-based systems |

|_____________________________|_____________________________|

| Interface Stability | Committed |

|_____________________________|_____________________________|

| Availability | driver/usb |

|_____________________________|_____________________________|

SEE ALSO

attributes(5), usb_pipe_bulk_xfer(9F),

usb_alloc_request(9F), usb_bulk_request(9S)

SunOS 5.11 Last change: 5 Jan 2004 2

Kernel Functions for Drivers

usb_pipe_get_max_bulk_transfer_size(9F)

SunOS 5.11 Last change: 5 Jan 2004 3




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™