Windows PowerShell command on Get-command usb_get_max_pkts_per_isoc_request
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man usb_get_max_pkts_per_isoc_request

Kernel Functions for Drivers

usb_get_max_pkts_per_isoc_request(9F)

NAME

usb_get_max_pkts_per_isoc_request - Get maximum number of

packets allowed per isochronous request

SYNOPSIS

#include

uint_t usb_get_max_pkts_per_isoc_request(dev_info_t *dip);

INTERFACE LEVEL

Solaris DDI specific (Solaris DDI)

PARAMETERS

dip Pointer to the device's dev_info structure.

DESCRIPTION

The usb_get_max_pkts_per_isoc_request() function returns the

maximum number of isochronous packets per request that the host control driver can support. This number can be used to determine the maximum amount of data which can be handled by a single isochronous request. That length is found by:

max = usb_get_max_pkts_per_isoc_request(dip) * endpoint_max_packet_size;

where endpoint_max_packet_size is the wMaxPacketSize field

of the isochronous endpoint over which the transfer will take place.

RETURN VALUES

On success, the usb_get_current_frame_number() function

returns the maximum number of isochronous pkts per request. On failure it returns 0. The function fails if dip is NULL.

CONTEXT

May be called from user, kernel or interrupt context.

EXAMPLES

/* * Set up to receive periodic isochronous data, requesting * the maximum amount for each transfer. */ int pkt; /* Get max packet size from endpoint descriptor. */

uint_t ep_max_pkt_size = ep_descr.wMaxPacketSize;

uint_t isoc_pkts_count = usb_get_max_pkts_per_isoc_request(dip);

SunOS 5.11 Last change: 5 Jan 2004 1

Kernel Functions for Drivers

usb_get_max_pkts_per_isoc_request(9F)

/* * Allocate an isoc request, specifying the max number of packets * and the greatest size transfer possible. */

usb_isoc_req_t *isoc_req = usb_alloc_isoc_req(dip,

isoc_pkts_count,

isoc_pkts_count * ep_max_pkt_size,

USB_FLAGS_SLEEP);

/* Init each packet descriptor for maximum size. */

for (pkt = 0; pkt < isoc_pkts_count; pkt++) {

isoc_req->isoc_pkt_descr[pkt].isoc_pkt_length = ep_max_pkt_size;

} /* Set the length of a packet in the request too. */

isoc_req->isoc_pkts_length = ep_max_pkt_size;

/* Other isoc request initialization. */ ... ...

if (usb_pipe_isoc_xfer(pipe, isoc_req, USB_FLAGS_NOSLEEP) != USB_SUCCESS) {

... }

ATTRIBUTES

See attributes(5) for descriptions of the following attri-

butes:

____________________________________________________________

| ATTRIBUTE TYPE | ATTRIBUTE VALUE |

|_____________________________|_____________________________|

| Architecture | PCI-based systems |

|_____________________________|_____________________________|

| Interface Stability | Committed |

|_____________________________|_____________________________|

| Availability | driver/usb |

|_____________________________|_____________________________|

SEE ALSO

attributes(5), usb_pipe_isoc_xfer(9F),

usb_alloc_request(9F), usb_get_current_frame_number(9F).

usb_ep_descr(9S), usb_isoc_request(9S)

SunOS 5.11 Last change: 5 Jan 2004 2

Kernel Functions for Drivers

usb_get_max_pkts_per_isoc_request(9F)

SunOS 5.11 Last change: 5 Jan 2004 3




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™