Windows PowerShell command on Get-command tran_reset_notify
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man tran_reset_notify

Driver Entry Points tran_reset_notify(9E)

NAME

tran_reset_notify - request to notify SCSI target of bus

reset

SYNOPSIS

#include

int prefixtran_reset_notify(struct scsi_address *ap, int flag,

void (*callback, caddr_t),caddr_t arg);

INTERFACE LEVEL

Solaris architecture specific (Solaris DDI).

PARAMETERS

ap Pointer to the scsi_address(9S) structure.

flag A flag indicating registration or cancellation of a notification request.

callback A pointer to the target driver's reset notifi-

cation function. arg The callback function argument.

DESCRIPTION

The tran_reset_notify() entry point is called when a target

driver requests notification of a bus reset.

The tran_reset_notify() vector in the scsi_hba_tran(9S)

structure may be initialized in the HBA driver's attach(9E) routine to point to the HBA entry point to be called when a

target driver calls scsi_reset_notify(9F).

The argument flag is used to register or cancel the notifi-

cation. The supported values for flag are as follows:

SCSI_RESET_NOTIFY Register callback as the reset notifi-

cation function for the target.

SCSI_RESET_CANCEL Cancel the reset notification request

for the target.

SunOS 5.11 Last change: 30 Aug 1995 1

Driver Entry Points tran_reset_notify(9E)

The HBA driver maintains a list of reset notification requests registered by the target drivers. When a bus reset occurs, the HBA driver notifies registered target drivers by calling the callback routine, callback, with the argument, arg, for each registered target.

RETURN VALUES

For SCSI_RESET_NOTIFY requests, tran_reset_notify() must

return DDI_SUCCESS if the notification request has been

accepted, and DDI_FAILURE otherwise.

For SCSI_RESET_CANCEL requests, tran_reset_notify() must

return DDI_SUCCESS if the notification request has been can-

celed, and DDI_FAILURE otherwise.

SEE ALSO

attach(9E), scsi_ifgetcap(9F), scsi_reset_notify(9F),

scsi_address(9S), scsi_hba_tran(9S)

Writing Device Drivers

SunOS 5.11 Last change: 30 Aug 1995 2




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™