Windows PowerShell command on Get-command strqset
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man strqset

Kernel Functions for Drivers strqset(9F)

NAME

strqset - change information about a queue or band of the

queue

SYNOPSIS

#include

int strqset(queue_t *q, qfields_t what, unsigned char pri, intptr_t val);

INTERFACE LEVEL

Architecture independent level 1 (DDI/DKI).

PARAMETERS

q Pointer to the queue. what Field of the queue structure (or the specified priority band) to return information about. Valid values are one of: QHIWAT High water mark. QLOWAT Low water mark. QMAXPSZ Largest packet accepted. QMINPSZ Smallest packet accepted. pri Priority band of interest. val The value for the field to be changed.

DESCRIPTION

The strqset() function gives drivers and modules a way to

change information about a queue or a particular band of a queue without directly accessing STREAMS data structures.

RETURN VALUES

On success, 0 is returned. EINVAL is returned if an unde-

fined attribute is specified.

SunOS 5.11 Last change: 16 Jan 2006 1

Kernel Functions for Drivers strqset(9F)

CONTEXT

The strqset() function can be called from user, interrupt,

or kernel context.

SEE ALSO

strqget(9F), queue(9S) Writing Device Drivers STREAMS Programming Guide NOTES When lowering existing values, set QMINPSZ before setting QMAXPSZ; when raising existing values, set QMAXPSZ before setting QMINPSZ.

SunOS 5.11 Last change: 16 Jan 2006 2




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™