Ioctl Requests sockio(7I)
NAME
sockio - ioctls that operate directly on sockets
SYNOPSIS
#include
DESCRIPTION
The ioctls listed in this manual page apply directly tosockets, independent of any underlying protocol. The set-
sockopt() call (see getsockopt(3SOCKET)) is the primarymethod for operating on sockets, rather than on the underly-
ing protocol or network interface. ioctls for a specific network interface or protocol are documented in the manual page for that interface or protocol. SIOCSPGRP The argument is a pointer to an int. Set theprocess-group ID that will subsequently
receive SIGIO or SIGURG signals for the socket referred to by the descriptor passedto ioctl to the value of that int. The argu-
ment must be either positive (in which case it must be a process ID) or negative (in which case it must be a process group). SIOCGPGRP The argument is a pointer to an int. Set thevalue of that int to the process-group ID
that is receiving SIGIO or SIGURG signals for the socket referred to by the descriptor passed to ioctl. SIOCCATMARK The argument is a pointer to an int. Set the value of that int to 1 if the read pointer for the socket referred to by the descriptor passed to ioctl points to a mark in the datastream for an out-of-band message. Set the
value of that int to 0 if the read pointer for the socket referred to by the descriptor passed to ioctl does not point to a mark inthe data stream for an out-of-band message.
SEE ALSO
ioctl(2), getsockopt(3SOCKET)SunOS 5.11 Last change: 8 Nov 1996 1