Windows PowerShell command on Get-command smccompile
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man smccompile

System Administration Commands smccompile(1M)

NAME

smccompile - build class list and compile Solaris Management

Console service beans for remote use

SYNOPSIS

/usr/sadm/bin/smccompile -c beanname

/usr/sadm/bin/smccompile -j tool | service [-n altjarname] jarfile

/usr/sadm/bin/smccompile -j library [-n altjarname] ALLTOOL | ALLSERVICE | ALL | attachedBeanname jarfile

DESCRIPTION

The smccompile command is used by developers of tools, ser-

vices, and libraries for the Solaris Management Console. For information regarding the Solaris Management Console, see smc(1M).

smccompile compiles service class files given by the bean

name for use with the Solaris Management Console. This step builds the extra proxy and stub classes for services to be

used with Solaris Management Console tools. Solaris Manage-

ment Console requires running smccompile -c before creating

service jar files, and smccompile -j after creating tool,

service, and library jars.

smccompile, in conjunction with smcregister(1M), is intended

to replace the smcconf command as the preferred interface for managing the Solaris Management Console repository as well as toolboxes from within scripts, due to significant performance enhancements over smcconf. OPTIONS The following options are supported: ALL Specify that the library being registered to or unregistered from the repository is for use by all tools and services. ALLSERVICE Specify that the library being registered to or unregistered from the repository is for use by all services. ALLTOOL Specify that the library being registered to or unregistered from the repository is for use by all tools.

SunOS 5.11 Last change: 17 Jul 2001 1

System Administration Commands smccompile(1M)

attachedBeaname Specify the name of a registered jar to which the library jarfile should be attached to (or detached from). This is

typically the same as altjarname (if pro-

vided) or jarfile used to register the jar to which this library is being attached or detached. An attached library means the library is only available for use by the tool or service to which it is being attached. beanname The full package path of the bean name to be compiled. An example bean name is: com.mycompany.myproduct.MyService.

-c Compile and build service class files for

the specified bean name. This step builds

the extra proxy and stub classes for ser-

vices to be used with Solaris Management

Console tools. You must run smccompile

with this option before creating service type jar files.

-j Build a list of classes in text format,

suitable as input to smcregister for registration with the Solaris Management Console repository. The output is written to standard out and should be redirected

to a file. You must run smccompile with

this option after creating any tool, ser-

vice, or library jar. jarfile Specify the full path to the jar file to be registered. The name must be in the form beanname.jar, where beanname is the package path to the bean. If it is not, an alternate name must be given in that

form using the -n option.

-n altjarname Rename the jarfile in the repository to

altjarname. Typically. this is the full bean name. For example, if the jarfile was MyTool.jar, then altjarname might be com.mycompany.myproduct.MyTool.jar. It is recommended that an altjarname containing the full package path be used. You must use this same name when registering the

SunOS 5.11 Last change: 17 Jul 2001 2

System Administration Commands smccompile(1M)

jar with smcregister.

EXAMPLES

Example 1 Compiling a Service The following command takes a Solaris Management Console service and builds its proxy and stub classes to make the service usable by Solaris Management Console tools:

/usr/sadm/bin/smccompile -c com.mycompany.myproject.MyServiceImpl

Example 2 Building a Class List for a Service The following command builds the class list file (classlist.txt) for a service suitable for use with the smcregister(1M) command:

/usr/sadm/bin/smccompile -j service \

-n com.mycompany.myproject.MyServiceImpl.jar \

${HOME}/workarea/MyServiceImpl.jar > classlist.txt

The following command does the same thing without specifying an alternate name:

/usr/sadm/bin/smccompile -j service \

${HOME}/workarea/com.mycompany.myproject.MyServiceImpl.jar > classlist.txt

Example 3 Building a Class List for a Tool The following command builds the class list file (classlist.txt) for a tool suitable for use with the smcregister(1M) command:

/usr/sadm/bin/smccompile -j tool \

-n com.mycompany.myproject.MyTool.jar \

${HOME}/workarea/MyTool.jar > classlist.txt

SunOS 5.11 Last change: 17 Jul 2001 3

System Administration Commands smccompile(1M)

The following command does the same thing without specifying an alternate name:

/usr/sadm/bin/smccompile -j tool \

${HOME}/workarea/com.mycompany.myproject.MyTool.jar > classlist.txt

Example 4 Building a Class List for a Library Attached to All Tools The following command builds the class list file (classlist.txt) for a library suitable for use with the smcregister(1M) command, and is attached to all tools:

/usr/sadm/bin/smccompile -j library \

-n com.mycompany.myproject.MyLibrary.jar \

ALLTOOL ${HOME}/workarea/MyLibrary.jar > classlist.txt

The following command does the same thing without specifying an alternate name:

/usr/sadm/bin/smccompile -j library \

ALLTOOL \

${HOME}/workarea/com.mycompany.myproject.MyLibrary.jar > classlist.txt

Example 5 Building a Class List for a Library Attached to a Specific Tool The following command builds the class list file (classlist.txt) for a library suitable for use with the smcregister(1M) command, and is attached to a specific tool:

/usr/sadm/bin/smccompile -j library \

-n com.mycompany.myproject.MyLibrary.jar \

com.mycompany.myproject.MyTool.jar \

${HOME}/workarea/MyLibrary.jar > classlist.txt

SunOS 5.11 Last change: 17 Jul 2001 4

System Administration Commands smccompile(1M)

The following command does the same thing without specifying an alternate name:

/usr/sadm/bin/smccompile -j library \

com.mycompany.myproject.MyTool.jar \

${HOME}/workarea/com.mycompany.myproject.MyLibrary.jar > classlist.txt

ENVIRONMENT VARIABLES See environ(5) for descriptions of the following environment

variables that affect the execution of smccompile:

JAVA_HOME If you do not specify this environment vari-

able, your PATH is searched for a suitable java. Otherwise, the /usr/j2se location is used. EXIT STATUS The following exit values are returned: 0 Successful completion. 1 An error occurred.

ATTRIBUTES

See attributes(5) for descriptions of the following attri-

butes:

____________________________________________________________

| ATTRIBUTE TYPE | ATTRIBUTE VALUE |

|_____________________________|_____________________________|

| Availability | SUNWMc |

|_____________________________|_____________________________|

SEE ALSO

smc(1M), smcconf(1M), smcregister(1M), attributes(5), environ(5) NOTES All standard shell quoting rules apply.

SunOS 5.11 Last change: 17 Jul 2001 5




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™