Windows PowerShell command on Get-command scsi_validate_sense
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man scsi_validate_sense

Kernel Functions for Drivers scsi_validate_sense(9F)

NAME

scsi_validate_sense - find descriptor in SCSI sense data

SYNOPSIS

#include

int scsi_validate_sense(uint8_t *sense_buffer, int sense_buf_len,

int *flags);

INTERFACE LEVEL

Solaris DDI specific (Solaris DDI).

PARAMETERS

sense_buffer Pointer to a buffer containing SCSI sense

data. The sense data is expected in wire format starting at the response code.

sense_buf_len Length of sense buffer in bytes.

flags Returns additional properties of the sense data.

DESCRIPTION

The scsi_validate_sense() function returns the format of the

sense data contained in the provided sense buffer. If the response code field in the sense data is not recognized or if there is not enough sense data to include sense key, asc,

and ascq then scsi_validate_sense() returns SENSE_UNUSABLE.

If the buffer contains usable sense data in fixed format,

the function returns SENSE_FIXED_FORMAT. If the buffer con-

tains usable sense data in descriptor format, the function

returns SENSE_DESCR_FORMAT.

The following flags may be set as appropriate depending on the sense data:

SNS_BUF_OVERFLOW The sense data buffer provided for the

request is too small to hold all the sense data.

SNS_BUF_DEFERRED The sense data contained in the buffer

relates to an error that has occurred during the processing of a successfully completed command, such as a cached

SunOS 5.11 Last change: 29 Jun 2006 1

Kernel Functions for Drivers scsi_validate_sense(9F)

write that could not be commited to the media.

RETURN VALUES

SENSE_UNUSABLE The response code from the sense data

is unrecognized or not enough sense data present to provide the sense key, asc, and ascq.

SENSE_FIXED_FORMAT The sense data in the buffer is in

"fixed format".

SENSE_DESCR_FORMAT The sense data in the buffer is in

"descriptor format".

CONTEXT

The scsi_validate_sense() function can be called from user

or interrupt context.

SEE ALSO

scsi_ext_sense_fields(9F), scsi_find_sense_descr(9F),

scsi_sense_asc(9F), scsi_sense_ascq(9F),

scsi_sense_cmdspecific_uint64(9F),

scsi_sense_info_uint64(9F), scsi_sense_key(9F)

SunOS 5.11 Last change: 29 Jun 2006 2




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™