Windows PowerShell command on Get-command scsi_sense_asc
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man scsi_sense_asc

Kernel Functions for Drivers scsi_sense_key(9F)

NAME

scsi_sense_key, scsi_sense_asc, scsi_sense_ascq - retrieve

fields from SCSI sense data

SYNOPSIS

#include

uint8_t scsi_sense_key(uint8_t *sense_buffer);

uint8_t scsi_sense_asc(uint8_t *sense_buffer);

uint8_t scsi_sense_ascq(uint8_t *sense_buffer);

INTERFACE LEVEL

Solaris DDI specific (Solaris DDI).

PARAMETERS

sense_buffer Pointer to a buffer containing SCSI sense

data. The sense data is expected in wire format starting at the response code. It can be in either fixed or descriptor format.

DESCRIPTION

The scsi_sense_key() function returns the sense key value

from the sense data contained in the sense_buffer.

The scsi_sense_asc() function returns the additional sense

code (ASC) value from the sense data contained in the

sense_buffer.

The scsi_sense_ascq() function returns the additional sense

code qualifier (ASCQ) value from the sense data contained in

the sense_buffer.

The scsi_sense_key(), scsi_sense_asc(), and

scsi_sense_ascq() functions are used to retrieve values from

SCSI sense data, regardles of whether the sense data is in fixed format or descriptor format.

Drivers should use scsi_validate_sense(9F) to ensure that

valid sense key, asc, and ascq values are present in the sense data.

SunOS 5.11 Last change: 28 Jun 2006 1

Kernel Functions for Drivers scsi_sense_key(9F)

RETURN VALUES

The scsi_sense_key() function returns the sense key value

from the sense buffer. The scsi_sense_asc() function returns

the additional sense code (ASC) from the sense buffer and

the scsi_sense_ascq() function returns the additional sense

code qualifier (ASCQ) from the sense buffer.

CONTEXT

The scsi_sense_key(), scsi_sense_asc(), and

scsi_sense_ascq() functions can be called from user or

interrupt context.

SEE ALSO

scsi_ext_sense_fields(9F), scsi_find_sense_descr(9F),

scsi_sense_cmdspecific_uint64(9F),

scsi_sense_info_uint64(9F), scsi_validate_sense(9F)

SunOS 5.11 Last change: 28 Jun 2006 2




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™