Windows PowerShell command on Get-command scsi_poll
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man scsi_poll

Kernel Functions for Drivers scsi_poll(9F)

NAME

scsi_poll - run a polled SCSI command on behalf of a target

driver

SYNOPSIS

#include

int scsi_poll(struct scsi_pkt *pkt);

INTERFACE LEVEL

Solaris DDI specific (Solaris DDI).

PARAMETERS

pkt Pointer to the scsi_pkt(9S) structure.

DESCRIPTION

The scsi_poll() function requests the host adapter driver to

run a polled command. Unlike scsi_transport(9F) which runs

commands asynchronously, scsi_poll() runs commands to com-

pletion before returning. If the pkt_time member of pkt is

0, the value of pkt_time is defaulted to SCSI_POLL_TIMEOUT

to prevent an indefinite hang of the system.

RETURN VALUES

The scsi_poll() function returns:

0 command completed successfully.

-1 command failed.

CONTEXT

The scsi_poll() function can be called from user, interrupt,

or kernel context. This function should not be called when the caller is executing timeout(9F) in the context of a thread.

SEE ALSO

makecom(9F), scsi_transport(9F), scsi_pkt(9S)

Writing Device Drivers WARNINGS

Since scsi_poll() runs commands to completion before return-

ing, it may require more time than is desirable when called

from interrupt context. Therefore, calling scsi_poll from

SunOS 5.11 Last change: 16 Jan 2006 1

Kernel Functions for Drivers scsi_poll(9F)

interrupt context is not recommended.

SunOS 5.11 Last change: 16 Jan 2006 2




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™