Windows PowerShell command on Get-command scsi_hba_pkt_comp
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man scsi_hba_pkt_comp

Kernel Functions for Drivers scsi_hba_pkt_comp(9F)

NAME

scsi_hba_pkt_comp - scsi_pkt completion routine

SYNOPSIS

#include

void scsi_hba_pkt_comp(struct scsi_pkt *pkt);

PARAMETERS

pkt Pointer to a scsi_pkt(9S) structure.

INTERFACE LEVEL

Solaris DDI specific (Solaris DDI).

DESCRIPTION

After filling in scsi_pkt(9S) fields with packet completion

information, an HBA driver should call the

scsi_hba_pkt_comp() function. This function is the recom-

mended way for an HBA driver to signal completion of a

scsi_pkt structure. Use is mandatory for HBA drivers that

use tran_setup_pkt(9E).

Calling the scsi_hba_pkt_comp() function allows SCSA to

observe, and possibly react to, the completion of a scsi_pkt

request.

A call to the scsi_hba_pkt_comp() function will always

result in a call to the pkt_comp() callback function defined

in scsi_pkt(9S). This pkt_comp() callback may, however,

occur after return from scsi_hba_pkt_comp(), and may occur

from a different thread executing on a different CPU.

CONTEXT

The scsi_hba_pkt_comp() function can be called from user,

interrupt, or kernel context.

ATTRIBUTES

See attributes(5) for descriptions of the following attri-

butes:

SunOS 5.11 Last change: 29 Jan 2009 1

Kernel Functions for Drivers scsi_hba_pkt_comp(9F)

____________________________________________________________

| ATTRIBUTE TYPE | ATTRIBUTE VALUE |

|_____________________________|_____________________________|

| Interface Stability | Committed |

|_____________________________|_____________________________|

SEE ALSO

attributes(5), tran_setup_pkt(9E), scsi_pkt(9S)

NOTES

HBA driver calls scsi_hba_pkt_comp() instead of calling

scsi_pkt(9S) pkt_comp directly.

SunOS 5.11 Last change: 29 Jan 2009 2




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™