Windows PowerShell command on Get-command scsi_destroy_pkt
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man scsi_destroy_pkt

Kernel Functions for Drivers scsi_destroy_pkt(9F)

NAME

scsi_destroy_pkt - free an allocated SCSI packet and its DMA

resource

SYNOPSIS

#include

void scsi_destroy_pkt(struct scsi_pkt *pktp);

INTERFACE LEVEL

Solaris DDI specific (Solaris DDI).

PARAMETERS

pktp Pointer to a scsi_pkt(9S) structure.

DESCRIPTION

The scsi_destroy_pkt() function releases all necessary

resources, typically at the end of an I/O transfer. The data

is synchronized to memory, then the DMA resources are deal-

located and pktp is freed.

CONTEXT

The scsi_destroy_pkt() function may be called from user,

interrupt, or kernel context.

EXAMPLES

Example 1 Releasing resources

scsi_destroy_pkt(un->un_rqs);

SEE ALSO

tran_destroy_pkt(9E), scsi_init_pkt(9F), scsi_pkt(9S)

Writing Device Drivers

SunOS 5.11 Last change: 16 Jan 2006 1




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™