Windows PowerShell command on Get-command sane-fujitsu
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man sane-fujitsu

SANE Scanner Access Now Easy sane-fujitsu(5)

NAME

sane-fujitsu - SANE backend for Fujitsu flatbed and ADF

scanners

DESCRIPTION

The sane-fujitsu library implements a SANE (Scanner Access

Now Easy) backend which provides access to most Fujitsu flatbed and ADF scanners. This document describes the rewritten backend versions 1.0.21 and greater. The backend supports lineart, halftone, grayscale, and color scanning for most USB and SCSI scanners, depending on hardware capabilities. Most simple scanning related features are exposed. This version features at least basic support for many more models. See KNOWN ISSUES. HARDWARE SUPPORT The following scanners are thought to have at least basic scanning capability, either because they have been tested with a prior version, or because documentation indicates they are compatible with a tested model. WORKGROUP SIZED SCANNERS:

--------------------------------------

SCSI: SCSI/USB: USB:

------------ ------------ ------------

M3091DC fi-4120C fi-5110C

M3092DC fi-4220C fi-5110EOX

SP-93GX fi-4120C2 fi-5110EOX2

fi-4220C2 fi-5110EOXM

fi-5120C S500

fi-5220C S500M

DEPARTMENTAL SIZED SCANNERS:

--------------------------------------

SCSI: SCSI/USB:

------------ ------------

M3093GX/DG fi-4340C

M3096G/GX fi-4530C

M3097G+/DG fi-5530C

fi-4640S

fi-4750C

PRODUCTION SIZED SCANNERS:

--------------------------------------

SCSI: SCSI/USB:

------------ ------------

M3099G/GH/GX fi-5650C

sane-backends 1.0.19 Last change: 2007-07-14 1

SANE Scanner Access Now Easy sane-fujitsu(5)

M4097D fi-5750C

fi-4750L fi-5900C

fi-4860C

M4099D

The following scanners are known NOT to work with this back-

end, either because they have a non-fujitsu chipset, or an

unsupported interface type. Some of these scanners may be supported by another backend. UNSUPPORTED SCANNERS:

--------------------------------------

SCSI: SERIAL: USB:

------------ ------------ ------------

ScanStation M3093E/DE/EX fi-4110EOX2

ScanPartner M3096EX fi-4010CU

SP-Jr M3097E+/DE

SP-10/10C M3099A/EH/EX

SP-15C/300C

SP-600C/620C

This backend may support scanners not listed here. The best way to determine level of support is to test the scanner directly. Fujitsu equipment has historically been good enough to not be damaged by incorrect commands if the scanner is incompatible. Please contact the author with test results, positive or negative. OPTIONS A modest effort has been made to expose the standard options to the API. This allows a frontend to set scanning region,

resolution, bit-depth, color mode, and enable the automatic

document feeder. The fujitsu backend supports the following basic options for most scanners: source s Selects the source for the scan. Options may include "Flatbed", "ADF Front", "ADF Back", "ADF Duplex". mode m Selects the mode for the scan. Options may include "Lineart", "Halftone", "Gray", and "Color".

resolution, y-resolution

Controls scan resolution. Setting --resolution also

sets --y-resolution, though this behavior is overridden

by some frontends.

tl-x, tl-y, br-x, br-y

Sets scan area upper left and lower right coordinates. These are renamed t, l, x, y by some frontends.

sane-backends 1.0.19 Last change: 2007-07-14 2

SANE Scanner Access Now Easy sane-fujitsu(5)

pagewidth, pageheight Sets paper size. Used by scanner to determine centering of scan coordinates when using ADF and to detect double feed errors. Other options will be available based on the capabilities of

the scanner. Use 'scanimage --help' to get a list. Be aware

that some options may appear only when another option has been set, and that advanced options may be hidden by the frontend. CONFIGURATION FILE The configuration file "fujitsu.conf" is used to tell the

backend how to look for scanners, and provide options con-

trolling the operation of the backend. This file is read each time the frontend asks the backend for a list of scanners, generally only when the frontend starts. If the configuration file is missing, the backend will use a set of

compiled defaults, which are identical to the default confi-

guration file shipped with SANE. Scanners can be specified in the configuration file in 4 ways: "scsi FUJITSU"

Requests backend to search all scsi busses in the sys-

tem for a device which reports itself to be a scanner made by 'FUJITSU'. "scsi /dev/sg0" (or other scsi device file) Requests backend to open the named scsi device. Only

useful if you have multiple compatible scanners con-

nected to your system, and need to specify one. Prob-

ably should not be used with the other "scsi" line above. "usb 0x04c5 0x1042" (or other vendor/product ids) Requests backend to search all usb busses in the system for a device which uses that vendor and product id. The device will then be queried to determine if it is a Fujitsu scanner. "usb /dev/usb/scanner0" (or other device file) Some systems use a kernel driver to access usb scanners. This method is untested.

The only configuration option supported is "buffer-

size=xxx", allowing you to set the number of bytes in the

data buffer to something other than the compiled-in default,

65536 (64K). Some users report that their scanner will

"hang" mid-page, or fail to transmit the image if the buffer

is not large enough.

sane-backends 1.0.19 Last change: 2007-07-14 3

SANE Scanner Access Now Easy sane-fujitsu(5)

Note: This option may appear multiple times in the confi-

guration file. It only applies to scanners discovered by 'scsi/usb' lines that follow this option. Note: The backend does not place an upper bound on this value, as some users required it to be quite large. Values above the default are not recommended, and may crash your OS or lockup your scsi card driver. You have been warned. ENVIRONMENT The backend uses a single environment variable,

SANE_DEBUG_FUJITSU, which enables debugging output to

stderr. Valid values are: 5 Errors 10 Function trace 15 Function detail 20 Option commands

25 SCSI/USB trace

30 SCSI/USB detail 35 Useless noise OLDER VERSIONS Backend versions prior to this were numbered with a two part version, or with no version number at all. At the time this version was written, all older versions were retroactively

renumbered, 1.0.2 - 1.0.20.

The current backend may have lost support for some feature you were using. The last of the "old" backends, 1.0.20, is still available as source from: http://www.thebility.com/fujitsu/ If you find that you need to use the older version, please contact the author, to try and get those features restored to a later version. KNOWN ISSUES All IPC, imprinter options are disabled. Most scanner specific 'quirks' are not accounted for, making it possible to set some options in ways that the scanner does not support. Some flatbed options are affected by adf settings. Any model that does not support VPD during inquiry will not function. HISTORY m3091 backend: Frederik Ramm

sane-backends 1.0.19 Last change: 2007-07-14 4

SANE Scanner Access Now Easy sane-fujitsu(5)

m3096g backend: Randolph Bentson (with credit to the unnamed author of the coolscan driver)

fujitsu backend, m3093, fi-4340C, ipc, cmp, long-time main-

tainer: Oliver Schirrmeister

m3092: Mario Goppold chemnitz dot de>

fi-4220C and basic USB support: Ron Cemer d o t com>

fi-4120, fi-series color support, backend re-write, current

maintainer: m. allan noah:

SEE ALSO

sane(7), sane-scsi(5), sane-usb(5), sane-sp15c(5), sane-

avision(5) AUTHOR m. allan noah:

ATTRIBUTES

See attributes(5) for descriptions of the following attri-

butes:

_________________________________________________________

| ATTRIBUTE TYPE | ATTRIBUTE VALUE |

|____________________|____________________________________|_

| Availability | image/scanner/xsane/sane-backends|

|____________________|____________________________________|_

| Interface Stability| Uncommitted |

|____________________|___________________________________|

NOTES Source for SANE is available on http://opensolaris.org.

sane-backends 1.0.19 Last change: 2007-07-14 5




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™