Windows PowerShell command on Get-command samestr
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man samestr

Kernel Functions for Drivers SAMESTR(9F)

NAME

SAMESTR, samestr - test if next queue is in the same stream

SYNOPSIS

#include

int SAMESTR(queue_t *q);

INTERFACE LEVEL

Architecture independent level 1 (DDI/DKI).

PARAMETERS

q Pointer to the queue.

DESCRIPTION

The SAMESTR() function is used to see if the next queue in a stream (if it exists) is the same type as the current queue (that is, both are read queues or both are write queues). This function accounts for the twisted queue connections

that occur in a STREAMS pipe and should be used in prefer-

ence to direct examination of the q_next field of queue(9S)

to see if the stream continues beyond q.

RETURN VALUES

The SAMESTR() function returns 1 if the next queue is the same type as the current queue. It returns 0 if the next queue does not exist or if it is not the same type.

CONTEXT

The SAMESTR() function can be called from user, interrupt, context.

SEE ALSO

OTHERQ(9F) Writing Device Drivers STREAMS Programming Guide

SunOS 5.11 Last change: 16 Jan 2006 1




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™