Windows PowerShell command on Get-command qinit
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man qinit

Data Structures for Drivers qinit(9S)

NAME

qinit - STREAMS queue processing procedures structure

SYNOPSIS

#include

INTERFACE LEVEL

Architecture independent level 1 (DDI/DKI)

DESCRIPTION

The qinit structure contains pointers to processing pro-

cedures for a QUEUE. The streamtab structure for the module or driver contains pointers to one queue(9S) structure for both upstream and downstream processing. STRUCTURE MEMBERS

int (*qi_putp)(); /* put procedure */

int (*qi_srvp)(); /* service procedure */

int (*qi_qopen)(); /* open procedure */

int (*qi_qclose)(); /* close procedure */

int (*qi_qadmin)(); /* unused */

struct module_info *qi_minfo; /* module parameters */

struct module_stat *qi_mstat; /* module statistics */

SEE ALSO

queue(9S), streamtab(9S) Writing Device Drivers STREAMS Programming Guide NOTES This release includes no support for module statistics.

SunOS 5.11 Last change: 11 Apr 1991 1




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™