Windows PowerShell command on Get-command putctl1
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man putctl1

Kernel Functions for Drivers putctl1(9F)

NAME

putctl1 - send a control message with a one-byte parameter

to a queue

SYNOPSIS

#include

int putctl1(queue_t *q, int type, int p);

INTERFACE LEVEL

Architecture independent level 1 (DDI/DKI).

PARAMETERS

q Queue to which the message is to be sent. type Type of message.

p One-byte parameter.

DESCRIPTION

The putctl1() function, like putctl(9F), tests the type

argument to make sure a data type has not been specified, and attempts to allocate a message block. The p parameter can be used, for example, to specify how long the delay will

be when an M_DELAY message is being sent. putctl1() fails if

type is M_DATA, M_PROTO, or M_PCPROTO, or if a message block

cannot be allocated. If successful, putctl1() calls the

put(9E) routine of the queue pointed to by q with the newly allocated and initialized message.

RETURN VALUES

On success, 1 is returned. 0 is returned if type is a data type, or if a message block cannot be allocated.

CONTEXT

The putctl1() function can be called from user, interrupt,

or kernel context.

EXAMPLES

See the putctl(9F) function page for an example of

putctl1().

SEE ALSO

put(9E), allocb(9F), datamsg(9F), putctl(9F), putnextctl1(9F)

SunOS 5.11 Last change: 16 Jan 2006 1

Kernel Functions for Drivers putctl1(9F)

Writing Device Drivers STREAMS Programming Guide

SunOS 5.11 Last change: 16 Jan 2006 2




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™