Windows PowerShell command on Get-command pci_config_setup
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man pci_config_setup

Kernel Functions for Drivers pci_config_setup(9F)

NAME

pci_config_setup, pci_config_teardown - setup or tear down

the resources for enabling accesses to the PCI Local Bus Configuration space

SYNOPSIS

#include

#include

int pci_config_setup(dev_info_t *dip, ddi_acc_handle_t *handle);

void pci_config_teardown(ddi_acc_handle_t *handle);

INTERFACE LEVEL

Solaris DDI specific (Solaris DDI).

PARAMETERS

dip Pointer to the device's dev_info structure.

handle Pointer to a data access handle.

DESCRIPTION

pci_config_setup() sets up the necessary resources for ena-

bling subsequent data accesses to the PCI Local Bus Confi-

guration space. pci_config_teardown() reclaims and removes

those resources represented by the data access handle

returned from pci_config_setup().

RETURN VALUES

pci_config_setup() returns:

DDI_SUCCESS Successfully setup the resources.

DDI_FAILURE Unable to allocate resources for setup.

CONTEXT

pci_config_setup() must be called from user or kernel con-

text. pci_config_teardown() can be called from any context.

NOTES These functions are specific to PCI bus device drivers. For drivers using these functions, a single source to support

devices with multiple bus versions may not be easy to main-

tain.

SunOS 5.11 Last change: 1 Jan 1997 1

Kernel Functions for Drivers pci_config_setup(9F)

ATTRIBUTES

See attributes(5) for descriptions of the following attri-

butes:

____________________________________________________________

| ATTRIBUTE TYPE | ATTRIBUTE VALUE |

|_____________________________|_____________________________|

| Architecture | PCI Local Bus |

|_____________________________|_____________________________|

SEE ALSO

attributes(5) IEEE 1275 PCI Bus Binding

SunOS 5.11 Last change: 1 Jan 1997 2




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™