Windows PowerShell command on Get-command net_protocol_walk
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man net_protocol_walk

Kernel Functions for Drivers net_protocol_walk(9F)

NAME

net_protocol_walk - step through the list of registered net-

work protocols

SYNOPSIS

#include

net_data_t *net_protocol_walk(net_data_t net);

INTERFACE LEVEL

Solaris DDI specific (Solaris DDI).

PARAMETERS

net value returned from a successful call to

net_protocol_lookup(9F).

DESCRIPTION

The net_protocol_walk() function walks through all of the

network protocols that have been registered with this inter-

face. The initial call to net_protocol_walk() should be made

by passing in NULL as the value for net. When this function returns NULL, the end of the list has been reached.

A caller of net_protocol_walk() is required to walk through

the entire list of network protocols, until NULL is returned or, when finished with using the value returned, pass it

into a call to net_protocol_release(9F).

RETURN VALUES

The net_protocol_walk() function returns NULL when the end

of the list is returned. Otherwise, it returns a non-NULL

value as a token for being passed into other function calls within this interface.

CONTEXT

The net_protocol_walk() function may be called from user,

kernel, or interrupt context.

ATTRIBUTES

See attributes(5) for descriptions of the following attri-

butes:

SunOS 5.11 Last change: 1 May 2008 1

Kernel Functions for Drivers net_protocol_walk(9F)

____________________________________________________________

| ATTRIBUTE TYPE | ATTRIBUTE VALUE |

|_____________________________|_____________________________|

| Availability | SUNWcs |

|_____________________________|_____________________________|

| Interface Stability | Committed |

|_____________________________|_____________________________|

SEE ALSO

net_protocol_lookup(9F), net_protocol_release(9F), attri-

butes(5)

SunOS 5.11 Last change: 1 May 2008 2




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™