Windows PowerShell command on Get-command net_phylookup
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man net_phylookup

Kernel Functions for Drivers net_phylookup(9F)

NAME

net_phylookup - determine if a network interface name exists

for a network protocol

SYNOPSIS

#include

phy_if_t net_phylookup(const net_data_t net, const char *name);

INTERFACE LEVEL

Solaris DDI specific (Solaris DDI).

PARAMETERS

net value returned from a successful call to

net_protocol_lookup(9F).

name name of the network interface to find.

DESCRIPTION

The net_phylookup() function attempts to resolve the inter-

face name passed in with the network protocol. When called successfully, the value returned represents a network interface that exists, at the time of the call, within the scope of the network interface. This value is only guaranteed to be unique for a name within the scope of the network protocol.

RETURN VALUES

The net_phylookup() function returns -1 if it is not sup-

ported by the network protocol, and 0 if the named network

interface does not exist (or is otherwise unknown). Other-

wise, it returns a value greater than 0 representing a network interface that currently exists within the scope of this network protocol.

CONTEXT

The net_phylookup() function may be called from user, ker-

nel, or interrupt context.

ATTRIBUTES

See attributes(5) for descriptions of the following attri-

butes:

SunOS 5.11 Last change: 1 May 2008 1

Kernel Functions for Drivers net_phylookup(9F)

____________________________________________________________

| ATTRIBUTE TYPE | ATTRIBUTE VALUE |

|_____________________________|_____________________________|

| Availability | SUNWcs |

|_____________________________|_____________________________|

| Interface Stability | Committed |

|_____________________________|_____________________________|

SEE ALSO

net_getifname(9F), net_phygetnext(9F),

net_protocol_lookup(9F), attributes(5)

SunOS 5.11 Last change: 1 May 2008 2




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™