Windows PowerShell command on Get-command net_phygetnext
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man net_phygetnext

Kernel Functions for Drivers net_phygetnext(9F)

NAME

net_phygetnext - search through the current list of network

interfaces

SYNOPSIS

#include

phy_if_t net_phygetnext(const net_data_t net, const phy_if_t ifp);

INTERFACE LEVEL

Solaris DDI specific (Solaris DDI).

PARAMETERS

net value returned from a successful call to

net_protocol_lookup(9F).

ifp value returned from a successful call to this func-

tion or net_phylookup(9F).

DESCRIPTION

The net_phygetnext() function searches through all of the

network interfaces that a network protocol "owns". To start searching through all of the interfaces owned by a protocol, a value of 0 should be passed through as the value of ifp.

When 0 is returned by this function, the last of the inter-

faces owned by this protocol has been reached. When called successfully, the value returned represents a network interface that exists, at the time of the call, within the scope of the network interface. This value is only guaranteed to be unique for a name within the scope of the network protocol.

EXAMPLES

net_data_t net;

phy_if_t ifp;

char buffer[32];

net = net_protocol_lookup("inet");

if (net != NULL) {

for (ifp = net_phygetnext(net, 0); ifp != 0;

ifp = net_phygetnext(net, ifp)) {

/* Do something with ifp */

if (net_getifname(net, ifp, buffer,

sizeof(buffer) >= 0)

printf("Interface %s0, buffer);

}

SunOS 5.11 Last change: 1 May 2008 1

Kernel Functions for Drivers net_phygetnext(9F)

}

RETURN VALUES

The net_phygetnext() function returns -1 if it is not sup-

ported by the network protocol or 0 if an attempt to go beyond the last network interface is made. Otherwise, it returns a value representing a network interface.

CONTEXT

The net_phygetnext() function may be called from user, ker-

nel, or interrupt context.

ATTRIBUTES

See attributes(5) for descriptions of the following attri-

butes:

____________________________________________________________

| ATTRIBUTE TYPE | ATTRIBUTE VALUE |

|_____________________________|_____________________________|

| Availability | SUNWcs |

|_____________________________|_____________________________|

| Interface Stability | Committed |

|_____________________________|_____________________________|

SEE ALSO

net_phylookup(9F), net_protocol_lookup(9F), attributes(5)

SunOS 5.11 Last change: 1 May 2008 2




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™