Windows PowerShell command on Get-command net_isvalidchecksum
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man net_isvalidchecksum

Kernel Functions for Drivers net_isvalidchecksum(9F)

NAME

net_isvalidchecksum - verify layer 3 and layer 4 checksums

SYNOPSIS

#include

int net_isvalidchecksum(const net_data_t net, mblk_t *mb);

INTERFACE LEVEL

Solaris DDI specific (Solaris DDI).

PARAMETERS

net value returned from a successful call to

net_protocol_lookup(9F).

mb the mblk structure holding a packet that is the sub-

ject of this query.

DESCRIPTION

The net_isvalidchecksum() function verifies the layer 3

checksum (and, in some case, the layer 4 checksum) in the packet. If possible, fields that are used by hardware checksum'ing are examined rather than manually verifying that the checksums are present for packets received from a network interface. For both IPv4 and IPv6, TCP, UDP and ICMP (including ICMPV6 for IPv6) layer 4 checksums are currently validated.

RETURN VALUES

The net_isvalidchecksum() function returns:

-1 The network protocol does not support this function.

0 The packet does not contain partial checksums. 1 The packet does contain partial checksums.

CONTEXT

The net_isvalidchecksum() function may be called from user,

kernel, or interrupt context.

ATTRIBUTES

See attributes(5) for descriptions of the following attri-

butes:

SunOS 5.11 Last change: 1 May 2008 1

Kernel Functions for Drivers net_isvalidchecksum(9F)

____________________________________________________________

| ATTRIBUTE TYPE | ATTRIBUTE VALUE |

|_____________________________|_____________________________|

| Availability | SUNWcs |

|_____________________________|_____________________________|

| Interface Stability | Committed |

|_____________________________|_____________________________|

SEE ALSO

net_ispartialchecksum(9F), net_protocol_lookup(9F), attri-

butes(5)

SunOS 5.11 Last change: 1 May 2008 2




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™