Windows PowerShell command on Get-command net_instance_protocol_unregister
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man net_instance_protocol_unregister

Kernel Functions for Drivers net_protocol_notify_register(9F)

NAME

net_protocol_notify_register,

net_instance_protocol_unregister - add/delete a function to

be called for changes to a protocol

SYNOPSIS

#include

#include

int net_protocol_notify_register(net_handle_t family,

hook_notify_fn_t *callback, void *arg);

int net_protocol_notify_unregister(net_handle_t family,

hook_notify_fn_t *callback);

typedef int (* hook_notify_fn_t)(hook_notify_cmd_t command,

void *arg, const char *name1, const char *name2, const char *name3);

INTERFACE LEVEL

Solaris DDI specific (Solaris DDI).

PARAMETERS

family value returned from net_protocol_lookup().

callback function to call when a change occurs. arg pointer to pass into the callback() function when a change occurs.

DESCRIPTION

The net_protocol_notify_register() function registers a

function represented by the pointer callback to be called

when there is a change to the protocol represented by fam-

ily. The types of changes for which notifications are avail-

able for is currently limited to the addition and removal of protocols.

The net_protocol_notify_unregister() function removes the

function specified by the pointer callback from the list of

functions to call. This call may fail if the specified func-

tion cannot be found. Multiple callback functions may be registered through this interface. The same set of parameters is passed to each callback function. The memory referenced through the

SunOS 5.11 Last change: 30 Oct 2008 1

Kernel Functions for Drivers net_protocol_notify_register(9F)

pointers passed to the callback should be treated as point-

ing to read-only memory. Changing this data is strictly

prohibited.

The function that is called must not block any other proto-

cols. The arguments passed through to the callback are as follows

(the command is either HN_REGISTER or HN_UNREGISTER):

name1 is the name of the protocol name2 is NULL. name3 is the name of the protocol being added/removed

RETURN VALUES

If these functions succeed, 0 is returned. Otherwise, the following error is returned: EEXIST the given callback function is already registered.

CONTEXT

These functions may be called from user or kernel context.

ATTRIBUTES

See attributes(5) for descriptions of the following attri-

butes:

____________________________________________________________

| ATTRIBUTE TYPE | ATTRIBUTE VALUE |

|_____________________________|_____________________________|

| Availability | SUNWcs |

|_____________________________|_____________________________|

| Interface Stability | Committed |

|_____________________________|_____________________________|

SEE ALSO

attributes(5), net_protocol_lookup(9F)

SunOS 5.11 Last change: 30 Oct 2008 2




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™