Windows PowerShell command on Get-command net_hook_register
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man net_hook_register

Kernel Functions for Drivers net_hook_register(9F)

NAME

net_hook_register - add a hook to be called in event pro-

cessing

SYNOPSIS

#include

net_hook_t net_hook_register(const net_data_t net, hook_t *hook);

INTERFACE LEVEL

Solaris DDI specific (Solaris DDI).

PARAMETERS

net value returned from a successful call to

net_protocol_register().

hook pointer to a hook_t structure.

DESCRIPTION

The net_hook_register() function uses hooks that allow call-

backs to be registered with events that belong to a network

protocol. A successful call to net_hook_register() requires

that a valid handle for a network protocol be provided (the net parameter), along with a hook description that includes a reference to an available event.

While it is possible to use the same hook_t structure with

multiple calls to net_hook_register(), it is not encouraged.

The hook_t structure passed in with this function is

described by hook_t(9S). The following describes how this

structure is used.

h_func Must be non-NULL and represent a

function that fits the specified interface.

h_name Gives the hook a name that represents

its owner. No duplication of h_name

among the hooks present for an event is allowed.

h_flags Currently unused and must be set to

0.

SunOS 5.11 Last change: 1 May 2008 1

Kernel Functions for Drivers net_hook_register(9F)

h_hint, h_hintvalue Specify a hint to net_hook_register()

on how to insert this hook. If the hint cannot be specified, then an error is returned.

h_arg; May take any value that the consumer

wishes to have passed back when the hook is activated.

RETURN VALUES

If the net_hook_register() function succeeds, 0 is returned.

Otherwise, one of the following errors is returned:

ENOMEM The system cannot allocate any more memory to sup-

port registering this hook. ENXIO A hook cannot be found among the given family of events.

EEXIST A hook with the given h_name already exists on

that event. ESRCH A before or after dependency cannot be satisfied due to the hook with

EBUSY The h_hint field specifies a hint that cannot

currently be satisfied because it conflicts with

another hook. An example of this might be specify-

ing HH_FIRST or HH_LAST when another hook has

already been registered with this value.

CONTEXT

The net_hook_register() function may be called from user or

kernel context.

ATTRIBUTES

See attributes(5) for descriptions of the following attri-

butes:

SunOS 5.11 Last change: 1 May 2008 2

Kernel Functions for Drivers net_hook_register(9F)

____________________________________________________________

| ATTRIBUTE TYPE | ATTRIBUTE VALUE |

|_____________________________|_____________________________|

| Availability | SUNWcs |

|_____________________________|_____________________________|

| Interface Stability | Committed |

|_____________________________|_____________________________|

SEE ALSO

net_hook_unregister(9F), hook_t(9S)

SunOS 5.11 Last change: 1 May 2008 3




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™