Kernel Functions for Drivers net_getmtu(9F)
NAME
net_getmtu - determine the MTU of a given network interface
SYNOPSIS
#include
int net_getmtu(const net_data_t net, const phy_if_t ifp);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI).PARAMETERS
net value returned from a successful call tonet_protocol_lookup(9F).
ifp value returned from a successful call tonet_phylookup(9F) or net_phygetnext(9F).
DESCRIPTION
The net_getmtu() function receives information about the
current MTU of a network interface. The value returned fromthis function call should not be cached as the MTU of a net-
work interface since it is not guaranteed to be constant.RETURN VALUES
The net_getmtu() function returns -1 if the network protocol
does not support this feature and otherwise returns the current MTU of the network interface.CONTEXT
The net_getmtu() function may be called from user, kernel,
or interrupt context.ATTRIBUTES
See attributes(5) for descriptions of the following attri-
butes:SunOS 5.11 Last change: 1 May 2008 1
Kernel Functions for Drivers net_getmtu(9F)
____________________________________________________________
| ATTRIBUTE TYPE | ATTRIBUTE VALUE |
|_____________________________|_____________________________|
| Availability | SUNWcs ||_____________________________|_____________________________|
| Interface Stability | Committed ||_____________________________|_____________________________|
SEE ALSO
net_phygetnext(9F), net_phylookup(9F),
net_protocol_lookup(9F)
SunOS 5.11 Last change: 1 May 2008 2