Windows PowerShell command on Get-command net_getifname
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man net_getifname

Kernel Functions for Drivers net_getifname(9F)

NAME

net_getifname - determine the name given to a network inter-

face

SYNOPSIS

#include

int net_getifname(const net_data_t net, const phy_if_t ifp,

char *buffer, size_t buflen);

INTERFACE LEVEL

Solaris DDI specific (Solaris DDI).

PARAMETERS

net value returned from a successful call to

net_protocol_lookup(9F).

ifp value returned from a successful call to

net_phylookup(9F) or net_phygetnext(9F).

buffer pointer to the buffer in which to write the inter-

face name. buflen size of the buffer in which to store the interface name.

DESCRIPTION

The net_getifname() function copies the name of the network

interface into the buffer provided. The name will always be

null-terminated. If the buffer is too small to fit both the

interface name and the null-terminated name, the name in the

buffer is truncated to fit. See net_phygetnext(9F) for an

example on how to use this function.

RETURN VALUES

The net_getifname() function returns:

-1 The network protocol does not support this function.

0 Successful completion. 1 Unsuccessful.

SunOS 5.11 Last change: 1 May 2008 1

Kernel Functions for Drivers net_getifname(9F)

CONTEXT

The net_getifname() function may be called from user, ker-

nel, or interrupt context.

ATTRIBUTES

See attributes(5) for descriptions of the following attri-

butes:

____________________________________________________________

| ATTRIBUTE TYPE | ATTRIBUTE VALUE |

|_____________________________|_____________________________|

| Availability | SUNWcs |

|_____________________________|_____________________________|

| Interface Stability | Committed |

|_____________________________|_____________________________|

SEE ALSO

net_phygetnext(9F), net_phylookup(9F),

net_protocol_lookup(9F)

SunOS 5.11 Last change: 1 May 2008 2




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™