Windows PowerShell command on Get-command msgpullup
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man msgpullup

Kernel Functions for Drivers msgpullup(9F)

NAME

msgpullup - concatenate bytes in a message

SYNOPSIS

#include

mblk_t *msgpullup(mblk_t *mp, ssize_t len);

INTERFACE LEVEL

Architecture independent level 1 (DDI/DKI).

PARAMETERS

mp Pointer to the message whose blocks are to be con-

catenated. len Number of bytes to concatenate.

DESCRIPTION

The msgpullup() function concatenates and aligns the first

len data bytes of the message pointed to by mp, copying the

data into a new message. Any remaining bytes in the remain-

ing message blocks will be copied and linked onto the new message. The original message is unaltered. If len equals

-1, all data are concatenated. If len bytes of the same mes-

sage type cannot be found, msgpullup() fails and returns

NULL.

RETURN VALUES

The msgpullup function returns the following values:

Non-null Successful completion. A pointer to the new mes-

sage is returned. NULL An error occurred.

CONTEXT

The msgpullup() function can be called from user, interrupt,

or kernel context.

SEE ALSO

srv(9E), allocb(9F), pullupmsg(9F), msgb(9S) Writing Device Drivers

SunOS 5.11 Last change: 16 Jan 2006 1

Kernel Functions for Drivers msgpullup(9F)

STREAMS Programming Guide NOTES

The msgpullup() function is a DKI-compliant replacement for

the older pullupmsg(9F) routine. Users are strongly

encouraged to use msgpullup() instead of pullupmsg(9F).

SunOS 5.11 Last change: 16 Jan 2006 2




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™