Kernel Functions for Drivers msgdsize(9F)
NAME
msgdsize - return the number of bytes in a message
SYNOPSIS
#include
size_t msgdsize(mblk_t *mp);
INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI).
PARAMETERS
mp Message to be evaluated.DESCRIPTION
The msgdsize() function counts the number of bytes in a data
message. Only bytes included in the data blocks of typeM_DATA are included in the count.
RETURN VALUES
The number of data bytes in a message, expressed as an integer.CONTEXT
The msgdsize() function can be called from user, interrupt,
or kernel context.EXAMPLES
See bufcall(9F) for an example that uses msgdsize().
SEE ALSO
bufcall(9F) Writing Device Drivers STREAMS Programming GuideSunOS 5.11 Last change: 16 Jan 2006 1