Windows PowerShell command on Get-command miocpullup
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man miocpullup

Kernel Functions for Drivers miocpullup(9F)

NAME

miocpullup - Prepare the payload of an M_IOCTL message for

access

SYNOPSIS

#include

#include

int miocpullup(mblk_t *mp, size_t size);

INTERFACE LEVEL

Solaris DDI specific (Solaris DDI).

PARAMETERS

mp M_IOCTL message.

size Number of bytes to prepare.

DESCRIPTION

The miocpullup() function prepares the payload of the speci-

fied M_IOCTL message for access by ensuring that it consists

of at least size bytes of data.

If the M_IOCTL message is transparent, or its total payload

is less than size bytes, an error is returned. Otherwise,

the payload is concatenated as necessary to provide contigu-

ous access to at least size bytes of data. As a special

case, if size is zero, miocpullup() returns successfully,

even if no payload exists.

RETURN VALUES

Zero is returned on success. Otherwise an errno value is returned indicating the problem.

CONTEXT

This function can be called from user, kernel or interrupt context.

SEE ALSO

STREAMS Programming Guide

SunOS 5.11 Last change: 9 June 2004 1




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™