Windows PowerShell command on Get-command miocack
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man miocack

Kernel Functions for Drivers miocack(9F)

NAME

miocack - Positively acknowledge an M_IOCTL message

SYNOPSIS

#include

#include

void miocack(queue_t *wq, mblk_t *mp, intcount, int rval);

INTERFACE LEVEL

Solaris DDI specific (Solaris DDI).

PARAMETERS

wq Write queue associated with the read queue to send

the M_IOCACK on.

mp M_IOCTL message.

count Value to set the ioc_count of the iocblk(9S) to.

rval Value to set the ioc_rval of the iocblk(9S) to.

DESCRIPTION

The miocack() function converts an M_IOCTL message into a

M_IOCACK message and sends the resulting message upstream.

To convert the message, miocack() changes the message type

to M_IOCACK, sets the 'ioc_count' and 'ioc_rval' members of

the iocblk(9S) associated with mp to the passed-in values,

and clears the 'ioc_error' field. If the caller specifies a

non-zero value for count, it is expected that the caller has

already set 'mp->b_cont' field to point to a message block

with a length of at least count bytes. Callers that only need to perform the message conversion, or need to perform additional steps between the conversion and

the sending of the M_IOCACK should use mioc2ack(9F).

RETURN VALUES

None.

CONTEXT

SunOS 5.11 Last change: 9 June 2004 1

Kernel Functions for Drivers miocack(9F)

This function can be called from user, kernel or interrupt context. NOTES

Callers must not hold any locks across a miocack() that can

be acquired as part of put(9E) processing.

SEE ALSO

mioc2ack(9F), put(9E), iocblk(9S) STREAMS Programming Guide

SunOS 5.11 Last change: 9 June 2004 2




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™