Windows PowerShell command on Get-command mioc2ack
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man mioc2ack

Kernel Functions for Drivers mioc2ack(9F)

NAME

mioc2ack - Convert an M_IOCTL message to an M_IOCACK message

SYNOPSIS

#include

#include

void mioc2ack(mblk_t *mp, mblk_t *dp, size_t count, int rval);

INTERFACE LEVEL

Solaris DDI specific (Solaris DDI).

PARAMETERS

mp M_IOCTL message.

dp Payload to associate with M_IOCACK message.

count Value to set the ioc_count of the iocblk(9S) to.

rval Value to set the ioc_rval of the iocblk(9S) to.

DESCRIPTION

The mioc2ack() function converts an M_IOCTL message into an

M_IOCACK message using the supplied arguments.

To convert the message, mioc2ack() changes the message type

to M_IOCACK, sets the ioc_count and ioc_rval members of the

iocblk(9S) associated with mp to the passed-in values, and

clears the ioc_error field. Further, it frees any message

blocks chained off of mp->b_cont and resets mp->b_cont to

dp. Finally, if dp is not NULL, mioc2ack() resets dp->b_wptr

to be dp->b_rptr + count (that is, it sets dp to be exactly

count bytes in length).

RETURN VALUES

None.

CONTEXT

This function can be called from user, kernel or interrupt context.

SEE ALSO

miocack(9F), miocnak(9F), iocblk(9S)

SunOS 5.11 Last change: 9 June 2004 1

Kernel Functions for Drivers mioc2ack(9F)

STREAMS Programming Guide

SunOS 5.11 Last change: 9 June 2004 2




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™