Windows PowerShell command on Get-command mcopymsg
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man mcopymsg

Kernel Functions for Drivers mcopymsg(9F)

NAME

mcopymsg - Copy message contents into a buffer and free mes-

sage

SYNOPSIS

#include

#include

void mcopymsg(mblk_t *mp, void *buf);

INTERFACE LEVEL

Solaris DDI specific (Solaris DDI).

PARAMETERS

mp Message to be copied. buf Buffer in which to copy.

DESCRIPTION

The mcopymsg() function copies the contents of the specified

message into the specified buffer. If the message consists of more than a single message block, the contents of each message block are placed consecutively into the buffer.

After copying the message contents to buf, mcopymsg() frees

the message mp. The provided buffer must be large enough to accommodate the message. If the buffer is not large enough, the results are

unspecified. The msgsize(9F) function can be used to calcu-

late the total size of the message beforehand.

RETURN VALUES

None.

CONTEXT

This function can be called from user, kernel or interrupt context.

SEE ALSO

freemsg(9F), msgsize(9F) STREAMS Programming Guide

SunOS 5.11 Last change: 16 Oct 2007 1




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™