Windows PowerShell command on Get-command mac_prop_info_set_default_str
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man mac_prop_info_set_default_str

Kernel Functions for Drivers mac_prop_info_set_perm(9F)

NAME

mac_prop_info_set_perm, mac_prop_info_set_default_uint8,

mac_prop_info_set_default_str,

mac_prop_info_set_default_link_flowctrl,

mac_prop_info_set_range_uint32 - set property information

SYNOPSIS

#include

void mac_prop_info_set_perm(mac_prop_info_handle_t ph,

uint8_t perm);

void mac_prop_info_set_default_uint8(mac_prop_info_handle_t ph,

uint8_t val);

void mac_prop_info_set_default_str(mac_prop_info_handle_t ph,

const char *str);

void mac_prop_info_set_default_link_flowctrl(

mac_prop_info_handle_t ph, link_flowctrl_t val);

void mac_prop_info_set_range_uint32(mac_prop_info_handle_t ph,

uint32_t min, uint32_t max);

DESCRIPTION

The entry points described here are invoked from a device

driver's mc_getcapab(9E) entry point to associate informa-

tion such as default values, permissions, or allowed value ranges.

Each one of these functions takes as first argument the pro-

perty information handle which is passed to mc_propinfo() as

argument.

The mac_prop_info_set_perm() function specifies the property

of the property. The permission is passed through the perm argument and can be set to one of the following values.

MAC_PROP_PERM_READ The property is read-only.

MAC_PROP_PERM_WRITE The property is write-only.

SunOS 5.11 Last change: 20 Jul 2010 1

Kernel Functions for Drivers mac_prop_info_set_perm(9F)

MAC_PROP_PERM_RW The property can be read and written.

The driver is not required to call mac_prop_info_set_perm()

for every property. If the driver does not call that func-

tion for a specific property, the framework will assume that the property has read and write permissions, corresponding

to MAC_PROP_PERM_RW.

The mac_prop_info_set_default_uint8(),

mac_prop_info_set_default_str(), and

mac_prop_info_set_default_link_flowctrl() functions are used

to associate a default value with a specific property.

The mac_prop_info_set_range_uint32() function is used by a

driver to associate an allowed range of values for a specific property. The range is defined by the min and max arguments passed by the device driver. This function can be

called successively to specify multiple non-overlapping

ranges.

ATTRIBUTES

See attributes(5) for descriptions of the following attri-

butes:

____________________________________________________________

| ATTRIBUTE TYPE | ATTRIBUTE VALUE |

|_____________________________|_____________________________|

| Availability | SUNWhea |

|_____________________________|_____________________________|

| Interface Stability | Committed |

|_____________________________|_____________________________|

SEE ALSO

attributes(5), mac(9E)

SunOS 5.11 Last change: 20 Jul 2010 2




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™