Kernel Functions for Drivers mac_lso_get(9F)
NAME
mac_lso_get - LSO routine
SYNOPSIS
#include
void mac_lso_get(mblk_t *mp, uint32_t *mss, uint32_t *flags);
DESCRIPTION
LSO (Large Segment Offload, or Large Send Offload) allows the network stack to send larger buffers to a device driver. These large buffers can then segmented in hardware, allowing for reduced CPU utilization, PCI overhead, and reduced buffer management costs.LSO is enabled only for device driver instances that adver-
tise support for the MAC_CAPAB_LSO capability through the
mc_getcapab(9E) entry point.
Once a device driver advertises the LSO capability, it mustuse the mac_lso_get() entry point to query whether LSO must
be performed on the packet. The following values for the flags argument are supported:HW_LSO When set, this flag indicates that LSO is enabled
for that packet. The maximum segment size (MSS) to be used during segmentation of the large segment is returned through the location pointed to by mss.ATTRIBUTES
See attributes(5) for descriptions of the following attri-
butes:____________________________________________________________
| ATTRIBUTE TYPE | ATTRIBUTE VALUE |
|_____________________________|_____________________________|
| Availability | SUNWhea ||_____________________________|_____________________________|
| Interface Stability | Committed ||_____________________________|_____________________________|
SEE ALSO
attributes(5), mac(9E)SunOS 5.11 Last change: 26 Mar 2010 1