Windows PowerShell command on Get-command linkb
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man linkb

Kernel Functions for Drivers linkb(9F)

NAME

linkb - concatenate two message blocks

SYNOPSIS

#include

void linkb(mblk_t *mp1, mblk_t *mp2);

INTERFACE LEVEL

Architecture independent level 1 (DDI/DKI).

DESCRIPTION

The linkb() function creates a new message by adding mp2 to

the tail of mp1. The continuation pointer, b_cont, of mp1 is

set to point to mp2.

The following figure describes how the linkb(m1, m2); func-

tion concatenates two message blocks, mp1 and mp2: Printed copy or docs.sun.com shows a figure that describes

how the linkb(m1, m2); function creates a new message by

adding mp1 to the tail of mp2

PARAMETERS

mp1 The message to which mp2 is to be added. mblk_t is an

instance of the msgb(9S) structure. mp2 The message to be added.

CONTEXT

The linkb() function can be called from user, interrupt, or

kernel context.

EXAMPLES

See dupb(9F) for an example that uses linkb().

SEE ALSO

dupb(9F), unlinkb(9F), msgb(9S)

Writing Device Drivers STREAMS Programming Guide

SunOS 5.11 Last change: 16 Jan 2006 1




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™