Kernel Functions for Drivers ldi_remove_event_handler(9F)
NAME
ldi_remove_event_handler - remove an NDI event service call-
backSYNOPSIS
#include
int ldi_remove_event_handler(ldi_handle_t lh,
ldi_callback_id_t id);
INTERFACE LEVEL
ObsoletePARAMETERS
ldi_handle_t lh Layered handle representing the dev-
ice for which the event notification is requested.ldi_callback_id_t id Unique system-wide registration ID
returned byldi_add_event_handler(9F) upon suc-
cessful registration.DESCRIPTION
This function is obsolete and is only maintained for compa-
tibility. Use of this function is strongly discouraged. For equivalent functionality provided by new interfaces, seeldi_ev_register_callbacks(9F) and
ldi_ev_remove_callbacks(9F).
The ldi_remove_event_handler() function removes the callback
handler specified by the registration ID(ldi_callback_id_t). Upon successful removal, the callback
handler is removed from the system and is not invoked at the event occurance.RETURN VALUES
DDI_SUCCESS Callback handler removed successfully.
DDI_FAILURE Failed to remove callback handler.
CONTEXT
This function can be called from user and kernel contexts only.SunOS 5.11 Last change: 21 Aug 2007 1
Kernel Functions for Drivers ldi_remove_event_handler(9F)
SEE ALSO
ldi_ev_register_callbacks(9F), ldi_ev_remove_callbacks(9F),
ldi_add_event_handler(9F), ldi_get_eventcookie(9F)
Writing Device DriversSunOS 5.11 Last change: 21 Aug 2007 2