Windows PowerShell command on Get-command ldi_read
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man ldi_read

Kernel Functions for Drivers ldi_read(9F)

NAME

ldi_read, ldi_write - Read and write from a device

SYNOPSIS

#include

int ldi_read(ldi_handle_t lh, struct uio *uiop, cred_t *cr);

int ldi_write(ldi_handle_t lh, struct uio *uiop, cred_t *cr);

PARAMETERS

lh Layered handle. cr Pointer to a credential structure used to open a device. uiop Pointer to the uio(9S) structure. uio(9S) specifies the location of the read or write data. (Either userland or kernel.)

DESCRIPTION

The ldi_read() function passes a read request to the device

entry point for the device specified by the layered handle. This operation is supported for block, character, and streams devices.

The ldi_write() function passes a write request to the dev-

ice entry point for a device specified by the layered han-

dle. This operation is supported for block, character, and streams devices.

RETURN VALUES

The ldi_read() and ldi_write() functions return 0 upon suc-

cess. If a failure occurs before the request is passed to

the device, the possible return values are shown below. Oth-

erwise any other error number may be returned by the device. EINVAL Invalid input parameters. ENOTSUP Operation is not supported for this device.

CONTEXT

These functions may be called from user or kernel context.

SunOS 5.11 Last change: 3 June 2003 1




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™