Windows PowerShell command on Get-command ldi_ident_from_dev
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man ldi_ident_from_dev

Kernel Functions for Drivers ldi_ident_from_dev(9F)

NAME

ldi_ident_from_dev, ldi_ident_from_stream,

ldi_ident_from_dip, ldi_ident_release - ldi cookie manage-

ment

SYNOPSIS

#include

int ldi_ident_from_dip(dev_info_t *dip, ldi_ident_t *lip);

int ldi_ident_from_dev(dev_t dev, ldi_ident_t *lip);

int ldi_ident_from_stream(struct queue *sq, ldi_ident_t *lip);

void ldi_ident_release(ldi_ident_t li);

PARAMETERS

li ldi identifier lip ldi identifier pointer dip pointer to device info node dev device number sq pointer to a stream queue

DESCRIPTION

The ldi_ident_from_dev() function allocates and returns an

ldi identifier that is associated with the device number specified by dev. The new ldi identifier is returned in the ldi identifier pointer parameter lip.

The ldi_ident_from_dip() function allocates and returns an

ldi identifier that is associated with the device info node pointed to by dip. The new ldi identifier is returned in the ldi identifier pointer parameter lip.

The ldi_ident_from_stream() function allocates and returns

an ldi identifier that is associated with the stream pointed to by queue. The new ldi identifier is returned in the ldi

SunOS 5.11 Last change: 26 Mar 2009 1

Kernel Functions for Drivers ldi_ident_from_dev(9F)

identifier pointer parameter lip.

The ldi_ident_release() function releases an identifier that

was allocated by one of the ldi_ident_from_*() functions.

RETURN VALUES

The ldi_ident_from_dev(), ldi_ident_from_dip(), and

ldi_ident_from_stream() functions return 0 upon success.

All of these functions return EINVAL for invalid input parameters.

CONTEXT

These functions can be called from user or kernel context.

SunOS 5.11 Last change: 26 Mar 2009 2




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™