Windows PowerShell command on Get-command ldi_get_size
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man ldi_get_size

Kernel Functions for Drivers ldi_get_size(9F)

NAME

ldi_get_size - Retrieve device size

SYNOPSIS

#include

int ldi_get_size(ldi_handle_t lh, uint64_t *sizep);

PARAMETERS

lh Layered handle.

sizep Pointer to the caller's unsigned 64-bit integer

buffer.

DESCRIPTION

The ldi_get_size() function uses the layered driver handle

to calculate and return a device's size. The device size is returned within the caller supplied buffer (*sizep). A valid layered driver handle must be obtained via the

ldi_open_by_name(9F) interface prior to calling

ldi_get_size().

RETURN VALUES

The ldi_get_size() function returns the following values:

DDI_SUCCESS The device size has been returned within the

caller supplied buffer.

DDI_FAILURE The device size could not be found or deter-

mined.

CONTEXT

This function may be called from user or kernel context.

SEE ALSO

ldi_open_by_name(9F)

Writing Device Drivers

SunOS 5.11 Last change: 18 Mar 2004 1




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™