Manual Pages for UNIX Operating System command usage for man ipmitool
Maintenance Commands ipmitool(1m)
NAME
ipmitool - utility for controlling IPMI-enabled devices
SYNOPSIS
ipmitool [-chvV] -I lan -H hostname [-p ] [-U
name>] [-f ] [-S ]
ipmitool [-chvV] -I lanplus -H hostname [-p ] [-U
] [-f ] [-S ]
ipmitool [-chvV] -I bmc [-S ]
DESCRIPTION
This program lets you manage Intelligent Platform Management
Interface (IPMI) functions of either the local system, via a
kernel device driver, or a remote system, using IPMI v1.5
and IPMI v2.0. These functions include printing FRU informa-
tion, LAN configuration, sensor readings, and remote chassis
power control.
IPMI management by a remote station is disabled on platforms
as they are shipped. It can be enabled only by the root user
on the local system.
SECURITY WARNING
There are several security issues to be considered before
enabling the IPMI LAN interface. A remote station has the
ability to control a system's power state as well as being
able to gather certain platform information. To reduce vul-
nerability it is strongly advised that the IPMI LAN inter-
face only be enabled in 'trusted' environments where system
security is not an issue or where there is a dedicated
secure 'management network'.
Further it is strongly advised that you should not enable
IPMI for remote access without setting a password, and that
that password should not be the same as any other password
on that system.
When an IPMI password is changed on a remote machine the new
password is sent across the network as clear text. This
could be observed and then used to attack the remote system.
It is thus recommended that IPMI password management only be
done using a tool, such as 'ipmitool', running on the local
station.
OPTIONS
-c Present output in CSV (comma separated variable) for-
mat.
SunOS 5.10 Last change: 10 December 2008 1
Maintenance Commands ipmitool(1m)
-f
Specifies a file containing the remote server password.
If this option is absent, or if password_file is empty,
the password will default to NULL.
If the -f option is not present, ipmitool will prompt
the user for a password. If no password is entered at
the prompt, the remote server password will default to
NULL.
For IPMI v1.5, the maximum password length is 16 char-
acters. Passwords longer than 16 characters will be
truncated.
For IPMI v2.0, the maximum password length is 20 char-
acters; longer passwords are truncated. The longer
password length is supported by the lanplus interface.
-h Get basic usage help from the command line.
-H
Remote server address, can be IP address or hostname.
This option is required for the LAN interface connec-
tion.
-I
Selects IPMI interface to use. Possible interfaces are
lan, lanplus or bmc.
-p
Selects remote port (default is 623).
-S
Uses Sensor Data Repository information from the file
to dramatically speed up the `sdr' and `sel
elist' commands. This file is typically created with
the `sdr dump ' command.
-U
Remote username, default is NULL user.
-v Increase verbose output level. This option may be
specified multiple times to increase the level of debug
output. If given three times you will get hexdumps of
all incoming and outgoing packets.
-V Display version information.
COMMANDS
help This can be used to get command-line help on ipmitool
SunOS 5.10 Last change: 10 December 2008 2
Maintenance Commands ipmitool(1m)
commands. It may also be placed at the end of commands
to get option usage help.
ipmitool -I bmc help
Commands:
raw Send a RAW IPMI request and print
response
i2c Send an I2C Master Write-Read
command and print response
spd Print SPD information from remote
I2C device
lan Configure LAN Channels
chassis Get chassis status and set power
state
power Alias for chassis power commands
event Send pre-defined events to MC
mc Management Controller status and
global enables
sdr Print Sensor Data Repository
entries and readings
sensor Print detailed sensor information
fru Print built-in FRU and scan SDR
for FRU locators
sel Print System Event Log (SEL)
pef Configure Platform Event Filtering
(PEF)
sol Configure IPMIv2.0 Serial-over-LAN
isol Configure IPMIv1.5 Serial-over-LAN
user Configure Management Controller
users
channel Configure Management Controller
channels
sunoem OEM Commands for Sun servers
kontronoem OEM Commands for Kontron
picmg Run a PICMG/ATA extended command
firewall Configure firmware firewall
session Print session information
exec Run list of commands from file
set Set runtime variable for shell and
exec
echo Echo lines to stdout in scripts
ekanalyzer Run FRU-Ekeying analyzer using FRU
files
ipmitool -I bmc chassis help
Chassis Commands: status, power, identify, policy,
restart_cause, poh, bootdev, bootparam, selftest
ipmitool -I bmc chassis power help
chassis power Commands: status, on, off, cycle, reset,
diag, soft
SunOS 5.10 Last change: 10 December 2008 3
Maintenance Commands ipmitool(1m)
bmc|mc
reset
Instructs the BMC to perform a warm or cold reset.
info
Displays information about the BMC hardware,
including device revision, firmware revision, IPMI
version supported, manufacturer ID, and informa-
tion on additional device support.
watchdog
These commands allow a user to view and change the
current state of the watchdog timer.
get
Show current Watchdog Timer settings and
countdown state.
reset
Reset the Watchdog Timer to its most recent
state and restart the countdown timer.
off
Turn off a currently running Watchdog count-
down timer.
selftest
Check on the basic health of the BMC by executing
the Get Self Test results command and reporting
the results.
getenables
Displays a list of the currently enabled options
for the BMC.
setenables =[on|off]
Enables or disables the given option. Currently
supported values for option include:
recv_msg_intr
Receive Message Queue Interrupt
SunOS 5.10 Last change: 10 December 2008 4
Maintenance Commands ipmitool(1m)
event_msg_intr
Event Message Buffer Full Interrupt
event_msg
Event Message Buffer
system_event_log
System Event Logging
oem0
OEM-Defined option #0
oem1
OEM-Defined option #1
oem2
OEM-Defined option #2
channel
authcap
Displays information about the authentication
capabilities of the selected channel at the speci-
fied privilege level.
Possible privilege levels are:
1 Callback level
2 User level
3 Operator level
4 Administrator level
5 OEM Proprietary level
info [channel number]
Displays information about the selected chan-
nel. If no channel is given it will display
information about the currently used channel:
ipmitool -I bmc channel info
Channel 0xf info:
Channel Medium Type : System Interface
Channel Protocol Type : KCS
Session Support : session-less
Active Session Count : 0
Protocol Vendor ID : 7154
SunOS 5.10 Last change: 10 December 2008 5
Maintenance Commands ipmitool(1m)
getaccess [userid]
Configure the given userid as the default on the
given channel number. When the given channel is
subsequently used, the user is identified impli-
citly by the given userid.
setaccess [callin=on|off]
[ipmi=on|off] [link=on|off] [privilege=level]
Configure user access information on the given
channel for the given userid.
getciphers [channel]
Displays the list of cipher suites supported for
the given application (ipmi or sol) on the given
channel.
chassis
status
Displays information regarding the high-level
status of the system chassis and main power sub-
system.
poh
This command will return the Power-On Hours
counter.
identify
Control the front panel identify light. Default
interval is 15 seconds. Use 0 to turn off. Use
"force" to turn on indefinitely.
restart_cause
Query the chassis for the cause of the last system
restart.
selftest
Check on the basic health of the BMC by executing
the Get Self Test results command and reporting
the results.
policy
Set the chassis power policy in the event power
SunOS 5.10 Last change: 10 December 2008 6
Maintenance Commands ipmitool(1m)
failure.
list
Return supported policies.
always-on
Turn on when power is restored.
previous
Returned to previous state when power is
restored.
always-off
Stay off after power is restored.
power
Performs a chassis control command to view and
change the power state.
status
Show current chassis power status.
on
Power up chassis.
off
Power down chassis into soft off (S4/S5
state). WARNING: This command does not ini-
tiate a clean shutdown of the operating sys-
tem prior to powering down the system.
cycle
Provides a power off interval of at least 1
second. No action should occur if chassis
power is in S4/S5 state, but it is recom-
mended to check power state first and only
issue a power cycle command if the system
power is on or in lower sleep state than
S4/S5.
reset
This command will perform a hard reset.
SunOS 5.10 Last change: 10 December 2008 7
Maintenance Commands ipmitool(1m)
diag
Pulse a diagnostic interrupt (NMI) directly
to the processor(s).
soft
Initiate a soft-shutdown of OS via ACPI by
emulating a fatal overtemperature.
bootdev [clear-cmos=yes|no] [options=help,...]
Request the system to boot from an alternate boot
device on next reboot. If the optional `clear-
cmos` argument is present, the parameter given
will be used to determine if the values stored in
persistent CMOS memory are cleared the next time
the system is rebooted. Note that this command is
not supported on many platforms. Various options
may be used to modify the boot device settings.
Run "bootdev none options=help" for a list of
available boot device modifiers/options.
Currently supported values for are:
pxe
Force PXE boot
disk
Force boot from BIOS default boot device
safe
Force boot from BIOS default boot device,
request Safe Mode
diag
Force boot from diagnostic partition
cdrom
Force boot from CD/DVD
bios
Force boot into BIOS setup
floppy
SunOS 5.10 Last change: 10 December 2008 8
Maintenance Commands ipmitool(1m)
Force boot from Floppy/primary removable
media
bootparam
Get or set various system boot option parameters.
get
Get boot parameter. Currently supported
values for are:
0 - Set In Progress
1 - Service Partition Selector
2 - Service Partition Scan
3 - BMC Boot Flag Valid Bit Clearing
4 - Boot Info Acknowledge
5 - Boot Flags
6 - Boot Initiator Info
7 - Boot Initiator Mailbox
set [value ...]
Set boot parameter.
Currently supported values for are:
force_pxe
Force PXE boot
force_disk
Force boot from default hard-drive
force_safe
Force boot from default hard-drive,
request Safe Mode
force_diag
Force boot from diagnostic partition
SunOS 5.10 Last change: 10 December 2008 9
Maintenance Commands ipmitool(1m)
force_cdrom
Force boot from CD/DVD
force_bios
Force boot into BIOS setup
ekanalyzer [] ...
NOTE : This command can support a maximum of 8 files
per command line
file1
binary file that stores FRU data of a Carrier or
an AMC module
file2
binary file that stores FRU data of an AMC module.
These binary files can be generated from command:
ipmitool fru read
file3
configuration file used for configuring On-Carrier
Device ID or OEM GUID. This file is optional.
xx : indicates the type of the file.
It can take the following value:
oc : On-Carrier device
a1 : AMC slot A1
a2 : AMC slot A2
a3 : AMC slot A3
a4 : AMC slot A4
b1 : AMC slot B1
b2 : AMC slot B2
b3 : AMC slot B3
b4 : AMC slot B4
sm : Shelf Manager
The available commands for ekanalyzer are:
SunOS 5.10 Last change: 10 December 2008 10
Maintenance Commands ipmitool(1m)
print []
carrier (default) ...
Display point-to-point physical connectivity
between carriers and AMC modules.
Example:
ipmitool ekanalyzer print carrier oc=fru
oc=carrierfru
From Carrier file: fru
Number of AMC bays supported by Car-
rier: 2
AMC slot B1 topology:
Port 0 =====> On Carrier Device ID
0, Port 16
Port 1 =====> On Carrier Device ID
0, Port 12
Port 2 =====> AMC slot B2, Port 2
AMC slot B2 topology:
Port 0 =====> On Carrier Device ID
0, Port 3
Port 2 =====> AMC slot B1, Port 2
*-*-*-*-*-*-*-*-*-
*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*
From Carrier file: carrierfru
On Carrier Device ID 0 topology:
Port 0 =====> AMC slot B1, Port 4
Port 1 =====> AMC slot B1, Port 5
Port 2 =====> AMC slot B2, Port 6
Port 3 =====> AMC slot B2, Port 7
AMC slot B1 topology:
Port 0 =====> AMC slot B2, Port 0
AMC slot B1 topology:
Port 1 =====> AMC slot B2, Port 1
Number of AMC bays supported by Car-
rier: 2
power ...
Display power supply information between car-
rier and AMC modules.
all ...
Display both physical connectivity and power
supply of each carrier and AMC modules.
frushow
Convert a binary FRU file into human readable text
SunOS 5.10 Last change: 10 December 2008 11
Maintenance Commands ipmitool(1m)
format. Use -v option to get more display informa-
tion.
summary []
match (default) ...
Display only matched results of Ekeying match
between an On-Carrier device and an AMC
module or between 2 AMC modules. Example:
ipmitool ekanalyzer summary match oc=fru
b1=amcB1 a2=amcA2
On-Carrier Device vs AMC slot B1
AMC slot B1 port 0 ==> On-Carrier Device 0
port 16
Matching Result
- From On-Carrier Device ID 0
-Channel ID 11 || Lane 0: enable
-Link Type: AMC.2 Ethernet
-Link Type extension: 1000BASE-BX (SerDES
Gigabit) Ethernet link
-Link Group ID: 0 || Link Asym. Match:
exact match
- To AMC slot B1
-Channel ID 0 || Lane 0: enable
-Link Type: AMC.2 Ethernet
-Link Type extension: 1000BASE-BX (SerDES
Gigabit) Ethernet link
-Link Group ID: 0 || Link Asym. Match:
exact match
*-*-*-*-*-*-*-*-*-
*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*
AMC slot B1 port 1 ==> On-Carrier Device 0
port 12
Matching Result
- From On-Carrier Device ID 0
-Channel ID 6 || Lane 0: enable
-Link Type: AMC.2 Ethernet
-Link Type extension: 1000BASE-BX (SerDES
Gigabit) Ethernet link
-Link Group ID: 0 || Link Asym. Match:
exact match
- To AMC slot B1
-Channel ID 1 || Lane 0: enable
-Link Type: AMC.2 Ethernet
-Link Type extension: 1000BASE-BX (SerDES
Gigabit) Ethernet link
-Link Group ID: 0 || Link Asym. Match:
exact match
*-*-*-*-*-*-*-*-*-
*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*
SunOS 5.10 Last change: 10 December 2008 12
Maintenance Commands ipmitool(1m)
On-Carrier Device vs AMC slot A2
AMC slot A2 port 0 ==> On-Carrier Device 0
port 3
Matching Result
- From On-Carrier Device ID 0
-Channel ID 9 || Lane 0: enable
-Link Type: AMC.2 Ethernet
-Link Type extension: 1000BASE-BX (SerDES
Gigabit) Ethernet link
-Link Group ID: 0 || Link Asym. Match:
exact match
- To AMC slot A2
-Channel ID 0 || Lane 0: enable
-Link Type: AMC.2 Ethernet
-Link Type extension: 1000BASE-BX (SerDES
Gigabit) Ethernet link
-Link Group ID: 0 || Link Asym. Match:
exact match
*-*-*-*-*-*-*-*-*-
*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*
AMC slot B1 vs AMC slot A2
AMC slot A2 port 2 ==> AMC slot B1 port 2
Matching Result
- From AMC slot B1
-Channel ID 2 || Lane 0: enable
-Link Type: AMC.3 Storage
-Link Type extension: Serial Attached
SCSI (SAS/SATA)
-Link Group ID: 0 || Link Asym. Match: FC
or SAS interface {exact match}
- To AMC slot A2
-Channel ID 2 || Lane 0: enable
-Link Type: AMC.3 Storage
-Link Type extension: Serial Attached
SCSI (SAS/SATA)
-Link Group ID: 0 || Link Asym. Match: FC
or SAS interface {exact match}
*-*-*-*-*-*-*-*-*-
*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*
unmatch ...
Display the unmatched results of Ekeying
match between an On-Carrier device and an AMC
module or between 2 AMC modules
all ...
Display both matched result and unmatched
results of Ekeying match between two cards or
two modules.
SunOS 5.10 Last change: 10 December 2008 13
Maintenance Commands ipmitool(1m)
event
Send a pre-defined test event to the System Event
Log. The following events are included as a means
to test the functionality of the System Event Log
component of the BMC (an entry will be added each
time the event n command is executed).
Currently supported values for n are:
1 Temperature: Upper Critical: Going High
2 Voltage Threshold: Lower Critical: Going Low
3 Memory: Correctable ECC
NOTE: These pre-defined events will likely not
produce "accurate" SEL records for a particular
system because they will not be correctly tied to
a valid sensor number, but they are sufficient to
verify correct operation of the SEL.
file
Event log records specified in filename will be
added to the System Event Log.
The format of each line in the file is as follows:
<{EvM Revision} {Sensor Type} {Sensor Num} {Event
Dir/Type} {Event Data 0} {Event Data 1} {Event
Data 2}>[# COMMENT]
e.g.:
0x4 0x2 0x60 0x1 0x52 0x0 0x0 # Voltage threshold:
Lower Critical: Going Low
EvM Revision - The "Event Message Revision" is
0x04 for messages that comply with the IPMI 2.0
Specification and 0x03 for messages that comply
with the IPMI 1.0 Specification.
Sensor Type - Indicates the Event Type or Class.
Sensor Num - Represents the 'sensor' within the
management controller that generated the Event
Message.
Event Dir/Type - This field is encoded with the
event direction as the high bit (bit 7) and the
event type as the low 7 bits. Event direction is
0 for an assertion event and 1 for a deassertion
SunOS 5.10 Last change: 10 December 2008 14
Maintenance Commands ipmitool(1m)
event.
See the IPMI 2.0 specification for further details
on the definitions for each field.
Get a list of all the possible Sensor States and
pre-defined Sensor State Shortcuts available for a
particular sensor. sensorid is the character
string representation of the sensor and must be
enclosed in double quotes if it includes white
space. Several different commands including ipmi-
tool sensor list may be used to obtain a list that
includes the sensorid strings representing the
sensors on a given system.
ipmitool -I open event "PS 2T Fan Fault" list
Finding sensor PS 2T Fan Fault... ok
Sensor States:
State Deasserted
State Asserted
Sensor State Shortcuts:
present absent
assert deassert
limit nolimit
fail nofail
yes no
on off
up down
[]
Generate a custom event based on existing sensor
information. The optional event direction can be
either assert (the default) or deassert.
ipmitool event "PS 2T Fan Fault" "State Asserted"
Finding sensor PS 2T Fan Fault... ok
0 | Pre-Init Time-stamp | Fan PS 2T Fan Fault
| State Asserted
ipmitool event "PS 2T Fan Fault" "State
Deasserted"
Finding sensor PS 2T Fan Fault... ok
0 | Pre-Init Time-stamp | Fan PS 2T Fan Fault
| State Desserted
SunOS 5.10 Last change: 10 December 2008 15
Maintenance Commands ipmitool(1m)
exec
Execute ipmitool commands from filename. Each line is
a complete command. The syntax of the commands are
defined by the COMMANDS section in this manpage. Each
line may have an optional comment at the end of the
line, delimited with a `#' symbol.
e.g., a command file with one line:
sdr list # get a list of sdr records
fru
print
This command will read all Field Replaceable
Unit (FRU) inventory data and extract such
information as serial number, part number, asset
tags, and short strings describing the chassis,
board, or product.
read
fru id is the digit ID of the FRU (see output of
'fru print'). fru file is the absolute pathname
of a file in which to dump the binary FRU data
pertaining to the specified FRU entity.
write
fru id is the digit ID of the FRU (see output of
'fru print'). fru file is the absolute pathname
of a file from which to pull the binary FRU data
before uploading it to the specified FRU.
upgEkey
Update a multirecord FRU location. fru id is the
digit ID of the FRU (see output of 'fru print').
fru file is the absolute pathname of a file from
which to pull the binary FRU data to upload into
the specified multirecord FRU entity.
edit
This command provides interactive editing of some
supported records, namely PICMG Carrier Activation
Record. fru id is the digit ID of the FRU (see
output of 'fru print'); default is 0.
SunOS 5.10 Last change: 10 December 2008 16
Maintenance Commands ipmitool(1m)
edit field
This command may be used to set a field string to
a new value. It replaces the FRU data found at
index in the specified section with the supplied
string.
fru id
is the digit ID of the FRU (see output of
'fru print').
section
is a string which refers to FRU Inventory
Information Storage Areas and may be refer
to:
c FRU Inventory Chassis Info Area
b FRU Inventory Board Info Area
p FRU Inventory Product Info Area
index
specifies the field number. Field numbering
starts on the first 'english text' field
type. For instance in the info area
field '0' is and field
'2' is ; see IPMI Plat-
form Management FRU Information Storage
Definition v1.0 R1.1 for field locations.
string
must be the same length as the string being
replaced and must be 8-bit ASCII (0xCx).
edit oem iana []
This command edits the data found in the mul-
tirecord area. Support for OEM specific records is
limited.
firewall
This command supports the firmware firewall capability.
It may be used to add or remove security-based restric-
tions on certain commands/command sub-functions or to
list the current firmware firewall restrictions set on
SunOS 5.10 Last change: 10 December 2008 17
Maintenance Commands ipmitool(1m)
any commands. For each firmware firewall command
listed below, parameters may be included to cause the
command to be executed with increasing granularity on a
specific LUN, for a specific NetFn, for a specific IPMI
Command, and finally for a specific command's sub-
function (see Appendix H in the IPMI 2.0 Specification
for a listing of any sub-function numbers that may be
associated with a particular command).
Parameter syntax and dependencies are as follows:
[] [ [ []]]]
Note that if "netfn " is specified, then "lun "
must also be specified; if "command " is specified,
then "netfn " (and therefore "lun ") must also be
specified, and so forth.
"channel " is an optional and standalone parameter.
If not specified, the requested operation will be per-
formed on the current channel. Note that command sup-
port may vary from channel to channel.
Firmware firewall commands:
info []
List firmware firewall information for the speci-
fied LUN, NetFn, and Command (if supplied) on the
current or specified channel. Listed information
includes the support, configurable, and enabled
bits for the specified command or commands.
Some usage examples:
info [] []
This command will list firmware firewall
information for all NetFns for the specified
LUN on either the current or the specified
channel.
info [] [ []]
This command will print out all command
information for a single LUN/NetFn pair.
info [] [ [ [ This prints out detailed, human-readable
information showing the support,
SunOS 5.10 Last change: 10 December 2008 18
Maintenance Commands ipmitool(1m)
configurable, and enabled bits for the speci-
fied command on the specified LUN/NetFn pair.
Information will be printed about each of the
command subfunctions.
[]]]]
info [] [ [ [ Print out information for a specific sub-
function.
enable []
This command is used to enable commands for a
given NetFn/LUN combination on the specified chan-
nel.
disable [] [force]
This command is used to disable commands for a
given NetFn/LUN combination on the specified chan-
nel. Great care should be taken if using the
"force" option so as not to disable the "Set Com-
mand Enables" command.
reset []
This command may be used to reset the firmware
firewall back to a state where all commands and
command sub-functions are enabled.
i2c []
Sends an I^2C Master Write-Read command (if data> is supplied, it is written to the I^2C master
first) to the device at address and displays
bytes of response.
Note: this command is not supported by all BMCs.
The following command writes the values 0x2, 0x3, and
0x4, then attempts to read 5 bytes from the I^2C master
at address 0xa:
ipmitool i2c 0xa 5 0x2 0x3 0x4
isol
info
SunOS 5.10 Last change: 10 December 2008 19
Maintenance Commands ipmitool(1m)
Retrieve information about the Intel IPMI v1.5
Serial-Over-LAN configuration.
set
Configure parameters for Intel IPMI v1.5
Serial-over-LAN.
Valid parameters and values are:
enabled
true, false
privilege-level
user, operator, admin, oem
bit-rate
9.6, 19.2, 38.4, 57.6, 115.2
activate
Causes ipmitool to enter Intel IPMI v1.5 Serial
Over LAN mode. An RMCP+ connection is made to the
BMC, the terminal is set to raw mode, and user
input is sent to the serial console on the remote
server. On exit, the the SOL payload mode is deac-
tivated and the terminal is reset to its original
settings.
Special escape sequences are provided to control
the SOL session:
~. Terminate connection
~^Z Suspend ipmitool
on restart
~^X Suspend ipmitool, but don't restore tty
~B Send break
twice
~~ Send the escape character by typing it
~? Print the supported escape sequences
Note that escapes are only recognized immediately
after newline.
kontronoem
SunOS 5.10 Last change: 10 December 2008 20
Maintenance Commands ipmitool(1m)
OEM commands specific to Kontron devices.
setsn
Set FRU serial number.
setmfgdate
Set FRU manufacturing date.
nextboot
Select the next boot order on the Kontron CP6012.
lan
print []
Print the current configuration for the given
channel. The default will print information on
the first found LAN channel.
set
Set the given command and parameter on the
given channel. Valid command/parameters are:
ipaddr
Set the IP address for this channel.
netmask
Set the netmask for this channel.
macaddr
Set the MAC address for this channel.
defgw ipaddr
Set the default gateway IP address.
defgw macaddr
Set the default gateway MAC address.
bakgw ipaddr
Set the backup gateway IP address.
bakgw macaddr
SunOS 5.10 Last change: 10 December 2008 21
Maintenance Commands ipmitool(1m)
Set the backup gateway MAC address.
password
Set the null user password.
snmp
Set the SNMP community string.
user
Enable user access mode for userid 1 (issue
the `user' command to display information
about userids for a given channel).
access
Set LAN channel access mode.
alert
Enable or disable PEF alerting for this chan-
nel.
ipsrc
Set the IP address source:
none = unspecified
static = manually configured static IP
address
dhcp = address obtained by BMC running DHCP
bios = address loaded by BIOS or system
software
arp respond
Set BMC generated ARP responses.
arp generate
Set BMC generated gratuitous ARPs.
arp interval
Set BMC generated gratuitous ARP interval.
auth
Set the valid authtypes for a given auth
level.
Levels: callback, user, operator, admin
SunOS 5.10 Last change: 10 December 2008 22
Maintenance Commands ipmitool(1m)
Types: none, md2, md5, password, oem
cipher_privs
Correlates cipher suite numbers with the max-
imum privilege level that is allowed to use
it. In this way, cipher suites can res-
tricted to users with a given privilege
level, so that, for example, administrators
are required to use a stronger cipher suite
than normal users.
The format of privlist is as follows. Each
character represents a privilege level and
the character position identifies the cipher
suite number. For example, the first charac-
ter represents cipher suite 1 (cipher suite 0
is reserved), the second represents cipher
suite 2, and so on. privlist must be 15
characters in length.
Characters used in privlist and their associ-
ated privilege levels are:
X Cipher Suite Unused
c CALLBACK
u USER
o OPERATOR
a ADMIN
O OEM
So, to set the maximum privilege for cipher
suite 1 to USER and suite 2 to ADMIN, issue
the following command:
ipmitool -I interface lan set channel
cipher_privs uaXXXXXXXXXXXXX
alert print [] []
Print alert information for the specified channel
and destination. The default will print all alerts
for all alert destinations on the first found LAN
channel.
alert set
Set an alert on the given LAN channel and destina-
tion. Alert Destinations are listed via the 'lan
alert print' command. Valid command/parameters
SunOS 5.10 Last change: 10 December 2008 23
Maintenance Commands ipmitool(1m)
are:
ipaddr
Set alert IP address.
macaddr
Set alert MAC address.
gateway
Set the channel gateway to use for alerts.
ack
Set Alert Acknowledge on or off.
type
Set the destination type as PET or OEM.
time
Set ack timeout or unack retry interval.
retry
Set the number of alert retries.
stats get []
Retrieve information about the IP connections on
the specified channel. The default will retrieve
statistics on the first found LAN channel.
stats clear []
Clear all IP/UDP/RMCP Statistics to 0 on the
specified channel. The default will clear statis-
tics on the first found LAN channel.
pef
info
This command will query the BMC and print informa-
tion about the PEF supported features.
status
This command prints the current PEF status (the
SunOS 5.10 Last change: 10 December 2008 24
Maintenance Commands ipmitool(1m)
last SEL entry processed by the BMC, etc).
policy
This command lists the PEF policy table entries.
Each policy entry describes an alert destination.
A policy set is a collection of table entries.
PEF alert actions reference policy sets.
list
This command lists the PEF table entries. Each
PEF entry relates a sensor event to an action.
When PEF is active, each platform event causes the
BMC to scan this table for entries matching the
event, and possible actions to be taken. Actions
are performed in priority order (higher critical-
ity first).
picmg
Run a PICMG/ATA extended command. Get PICMG properties
may be used to obtain and print Extension major version
information, PICMG identifier, FRU Device ID and Max
FRU Device ID.
addrinfo
Get address information. This command may return
information on the Hardware address, IPMB-0
Address, FRU ID, Site/Entity ID, and Site/Entity
Type.
frucontrol
Set various control options:
0x00 - Cold Reset
0x01 - Warm Reset
0x02 - Graceful Reboot
0x03 - Issue Diagnostic Interrupt
0x04 - Quiesce [AMC only]
0x05-0xFF - Cold Reset
activate
Activate the specified FRU.
SunOS 5.10 Last change: 10 December 2008 25
Maintenance Commands ipmitool(1m)
deactivate
Deactivate the specified FRU.
policy get
Get FRU activation policy.
policy set
Set FRU activation policy. lockmask is 1 or 0 to
indicate action on the deactivation or activation
locked bit respectively. lock is 1 or 0 to
set/clear locked bit.
portstate set|getall|getgranted|getdenied
Get or set various port states. See usage for
parameter details.
power
Alias for the "chassis power" commands. See the
"chassis power" commands for usage information.
raw []
This will allow you to execute raw IPMI commands. For
example to query the POH counter with a raw command:
ipmitool -v -I bmc raw 0x0 0xf
RAW REQ (netfn=0x0 cmd=0xf data_len=0)
RAW RSP (5 bytes)
3c 72 0c 00 00
sdr
info
This command will query the BMC for Sensor Data
Record (SDR) Repository information.
type [list|]
Displays sensor data records only for the sensor
type (e.g. `temperature', `voltage', etc.)
chosen. A list of all supported sensor types may
be displayed if the `list' keyword is used instead
of a sensor type. Note that the sensor type is
not case sensitive. Also note that there may be a
large delay before any information is displayed,
because ipmitool does a full scan of all sensor
SunOS 5.10 Last change: 10 December 2008 26
Maintenance Commands ipmitool(1m)
records and builds a list of just those that meet
the type criterion given.
list|elist [all|full|compact|event|mcloc|fru|generic]
This command will read the Sensor Data Records
(SDR) and extract sensor information of a given
type, then query each sensor and print its name,
reading, and status. The `elist' form of this
command prints additional information about each
data record (e.g. threshold type, sensor number,
sensor entity).
Valid types are:
all
All SDR records (Sensor and Locator)
full
Full Sensor Record
compact
Compact Sensor Record
event
Event-Only Sensor Record
mcloc
Management Controller Locator Record
fru
FRU Locator Record
generic
Generic SDR records
entity [.]
Displays all sensors associated with an entity.
Get a list of valid entity ids on the target sys-
tem by issuing the `sdr list' command with the
verbose option (`-v'). A list of all entity ids
can be found in the IPMI specifications.
dump
SunOS 5.10 Last change: 10 December 2008 27
Maintenance Commands ipmitool(1m)
Dumps raw SDR data to a file. This file may also
be used as the sdr cache, supplied to ipmitool
with the `-S' option, dramatically speeding up the
`sdr' and `sel elist' commands.
fill sensors
Create the SDR Repository for the current confi-
guration. Will perform a 'Clear SDR Repository'
command so be careful.
fill file
Fill the SDR Repository using records stored in a
binary data file. Will perform a 'Clear SDR Repo-
sitory' command so be careful.
sel
NOTE: System Event Log (SEL) entry-times are displayed
as `Pre-Init Time-stamp' if the SEL clock needs to be
set. Ensure that the SEL clock is accurate by invoking
the `sel time get' and `sel time set '
commands.
info
This command will query the BMC for information
about the System Event Log (SEL) and its contents.
clear
This command will clear the contents of the SEL.
It cannot be undone so be careful.
list|elist
When this command is invoked without arguments,
the entire contents of the SEL are displayed. In
addition to the information displayed by the
`list' command, the `elist' command will cross-
reference SEL records with SDR records to produce
descriptive event output.
| first
Displays the first count (least-recent)
entries in the SEL. If count is zero, all
entries are displayed.
last
SunOS 5.10 Last change: 10 December 2008 28
Maintenance Commands ipmitool(1m)
Displays the last count (most-recent) entries
in the SEL. If count is zero, all entries
are displayed.
delete ...
Delete one or more SEL event records.
add
Read event entries from a file and add them to the
SEL. New SEL entries area added onto the SEL
after the last record in the SEL. Record added is
of type 2 and is automatically timestamped.
get
Print information on the specified SEL Record
entry.
save
Save SEL records to a text file that can be fed
back into the `event file' ipmitool command. This
can be useful for testing Event generation by
building an appropriate Platform Event Message
file based on existing events. Please see the
available help for the 'event file ...' command
for a description of the format of this file.
writeraw
Save SEL records to a file in raw, binary format.
This file can be fed back to the `sel readraw'
ipmitool command for viewing.
readraw
Read and display SEL records from a binary file.
Such a file can be created using the `sel wri-
teraw' ipmitool command.
time
get
Displays the SEL clock's current time.
set
Sets the SEL clock. Future SEL entries will
use the time set by this command. Maintenance Commands ipmitool(1m)
string> is of the form "MM/DD/YYYY HH:MM:SS".
Note that hours are in 24-hour form. It is
recommended that the SEL be cleared before
setting the time.
sensor
list
Lists sensors and thresholds in a wide table for-
mat.
get ... [id]
Prints information for sensors specified by name.
thresh
This allows you to set a particular sensor thres-
hold value. The sensor is specified by name.
Valid thresholds are:
unr Upper Non-Recoverable
ucr Upper Critical
unc Upper Non-Critical
lnc Lower Non-Critical
lcr Lower Critical
lnr Lower Non-Recoverable
session
info
Get information about the specified session(s).
You may identify sessions by their id, by their
handle number, by their active status, or by using
the keyword `all' to specify all sessions.
sol
info []
Retrieve information about the Serial-Over-LAN
configuration on the specified channel. If no
channel is given, it will display SOL configura-
tion data for the currently used channel.
payload
Enable or disable SOL payload for the user on the
specified channel.
SunOS 5.10 Last change: 10 December 2008 30
Maintenance Commands ipmitool(1m)
set [channel]
Configure parameters for Serial Over Lan. If no
channel is given, it will display SOL configura-
tion data for the currently used channel. Confi-
guration parameter updates are automatically
guarded with the updates to the set-in-progress
parameter.
Valid parameters and values are:
set-in-progress
set-complete set-in-progress commit-write
enabled
true false
force-encryption
true false
force-authentication
true false
privilege-level
user operator admin oem
character-accumulate-level
Decimal number given in 5-millisecond incre-
ments
character-send-threshold
Decimal number
retry-count
Decimal number. 0 indicates no retries after
packet is transmitted.
retry-interval
Decimal number in 10 millisend increments. 0
indicates that retries should be sent back to
back.
non-volatile-bit-rate
serial, 19.2, 38.4, 57.6, 115.2. Setting
this value to serial indicates that the BMC
should use the setting used by the IPMI over
serial channel.
volatile-bit-rate
serial, 19.2, 38.4, 57.6, 115.2. Setting
this value to serial indiates that the BMC
should use the setting used by the IPMI over
SunOS 5.10 Last change: 10 December 2008 31
Maintenance Commands ipmitool(1m)
serial channel.
activate [usesolkeepalive | nokeepalive]
Causes ipmitool to enter Serial Over LAN mode, and
is only available when using the lanplus inter-
face. An RMCP+ connection is made to the BMC, the
terminal is set to raw mode, and user input is
sent to the serial console on the remote server.
On exit,the the SOL payload mode is deactivated
and the terminal is reset to its original set-
tings.
Special escape sequences are provided to control
the SOL session:
~. Terminate connection
~^Z Suspend ipmitool
restart
~^X Suspend ipmitool, but don't restore tty on
~B Send break
~~ Send the escape character by typing it twice
~? Print the supported escape sequences
Note that escapes are only recognized immediately
after newline.
deactivate
Deactivates Serial Over LAN mode on the BMC.
Exiting Serial Over LAN mode should automatically
cause this command to be sent to the BMC, but in
the case of an unintentional exit from SOL mode,
this command may be necessary to reset the state
of the BMC.
spd [] []
This command may be used to read SPD (Serial Presence
Detect) data using the I2C Master Write-Read IPMI com-
mand.
sunoem
Sun OEM-specific IPMI commands. Support for these com-
mands depends heavily on the Sun platform targeted.
SunOS 5.10 Last change: 10 December 2008 32
Maintenance Commands ipmitool(1m)
Please consult your Sun Hardware Reference Guide for
information on Sun OEM-specific IPMI functionality to
determine if the following commands are supported on
your desired platform.
fan speed <0-100>
Sets the system fan speed (in units of PWM duty
cycle)
sshkey
Administer SSH keys for service processor users.
set
Sets the SSH key for the given userid to the
key found in the given file. (A list of
users may be obtained with the 'user list'
command).
del
Delete the SSH key for the given userid.
led
Manipulate the settings for LEDs found via the
`sdr elist generic' command. Once the sensor ID
of the LED is found (the `elist' command displayed
the sensor ID), it may be used in the following
subcommands. When an LED type is required, it can
be one of the following values: `OK2RM' (OK to
Remove), `SERVICE' (Service Required), `ACT'
(Activity), or `LOCATE' (Locate). When an LED
mode is required, it can be one of the following
values: `OFF' (Off), `ON' (Steady On), `STANDBY'
(100ms ON, 2900ms OFF blink rate), `SLOW' (1HZ
blink rate), or `FAST' (4HZ blink rate).
get []
Read the status of the LED with the given
. If is the special
keyword `all', then the status of all LEDs
will be displayed. The optional parameter,
, further restricts the output to
LEDs of the given type.
set []
SunOS 5.10 Last change: 10 December 2008 33
Maintenance Commands ipmitool(1m)
Sets the mode of the LED with the given
sorid> (and optionally the given type type>) to the given . If
is the special keyword `all', then the status
of all LEDs will be set (optionally qualified
by the given type ).
user
summary
Displays a summary of userid information, includ-
ing maximum number of userids, the number of
enabled users, and the number of fixed names
defined.
list
Displays a list of user information for all
defined userids.
set
name
Sets the username associated with the given
userid.
password []
Sets the password for the given userid. If
no password is given, the password is cleared
(set to the NULL password). Be careful when
removing passwords from administrator-level
accounts.
disable
Disables access to the BMC by the given userid.
enable
Enables access to the BMC by the given userid.
priv []
Set user privilege level on the specified channel.
If the channel is not specified, the current chan-
nel will be used.
test <16|20> []
SunOS 5.10 Last change: 10 December 2008 34
Maintenance Commands ipmitool(1m)
Determine whether a password has been stored as 16
or 20 bytes.
NOTE: Sun systems, such as the v20z and v40z, maintain the
LAN interface on channel 1. To determine on which channel
the LAN interface is located, issue the `channel info chan-
nel' command.
BMC INTERFACE
The ipmitool bmc interface utilizes the bmc device driver.
In order to force ipmitool to make use of the device inter-
face you can specify it on the command line:
ipmitool -I bmc
LAN INTERFACE
The ipmitool lan interface communicates with a remote BMC
over an Ethernet LAN connection using UDP over IPv4. UDP
datagrams are formatted to contain IPMI request/response
messages with IPMI session headers and RMCP headers.
IPMI-over-LAN uses version 1 of the Remote Management Con-
trol Protocol (RMCP) to support pre-OS and OS-absent manage-
ment. RMCP is a request-response protocol delivered using
UDP datagrams to port 623.
The LAN interface is an authenticated multi-session connec-
tion; messages delivered to the BMC can (and should) be
authenticate with a challenge/response protocol with either
straight password/key or MD5 message-digest. ipmitool
will attempt to connect with administrator privilege
level as this is required to perform chassis power func-
tions.
You can tell ipmitool to use the lan interface with the -I
option:
ipmitool -I lan -H [-f password_file]
A hostname must be given on the command line in order to use
the lan interface with 'ipmitool'. The password_file is
optional but, if present, should contain the password to be
used for authentication. If no password is given, ipmitool
will attempt to connect without authentication.
If password_file is present and non-empty ipmitool will
attempt to authenticate with an MD5 message-digest if MD5 is
supported by the BMC. If MD5 is not supported by the BMC,
straight password/key authentication will be attempted.
SunOS 5.10 Last change: 10 December 2008 35
Maintenance Commands ipmitool(1m)
LANPLUS INTERFACE
Like the lan interface, the lanplus interface communicates
with the BMC over an Ethernet LAN connection using UDP over
IPv4. The difference is that the lanplus interface uses the
RMCP+ protocol as described in the IPMI v2.0 specification.
RMCP+ allows for improved authentication and data integrity
checks, as well as encryption and the ability to carry mul-
tiple types of payloads. Generic Serial-over-LAN support
requires RMCP+, so the ipmitool sol activate command
requires the use of the lanplus interface.
Establishing a RMCP+ session uses RAKP (Remote Authenticated
Key-Exchange Protocol), which enables the negotiation of
many options. ipmitool does not yet allow the user to
specify values for all the options, defaulting to the most
obvious settings for those settings marked as required in
the v2.0 specification. Authentication and integrity HMACs
use the SHA-1 algorithm, and encryption is performed with
AES, in CBC mode, at 128-bits of strength. Role-level logins
are not supported. ipmitool must be configured with the
appropriate option for the lanplus interface to be avail-
able, as it is not enabled by default. This interface
currently requires the OpenSSL library.
You can tell ipmitool to use the lanplus interface with the
-I option:
ipmitool -I lanplus -H [-U username] [-f
password_file]
The options available for the lanplus interface are identi-
cal to those available for
the lan interface.
EXIT STATUS
Upon successful completion, ipmitool returns 0. On failure,
1 is returned.
EXAMPLES
Example 1 : Listing remote sensors:
> ipmitool -I lan -H 1.2.3.4 -f passfile sdr list
Baseboard 1.25V | 1.24 Volts | ok
Baseboard 2.5V | 2.49 Volts | ok
Baseboard 3.3V | 3.32 Volts | ok
Example 2: Displaying status of a remote sensor:
> ipmitool -I lan -H 1.2.3.4 -f passfile sensor get
"Baseboard 1.25V"
SunOS 5.10 Last change: 10 December 2008 36
Maintenance Commands ipmitool(1m)
Locating sensor record...
Sensor ID : Baseboard 1.25V (0x10)
Sensor Type (Analog) : Voltage
Sensor Reading : 1.245 (+/- 0.039) Volts
Status : ok
Lower Non-Recoverable : na
Lower Critical : 1.078
Lower Non-Critical : 1.107
Upper Non-Critical : 1.382
Upper Critical : 1.431
Upper Non-Recoverable : na
Example 3: Displaying the power status of a remote chassis:
> ipmitool -I lan -H 1.2.3.4 -f passfile chassis power
status
Chassis Power is on
Example 4: Controlling the power on a remote chassis:
> ipmitool -I lan -H 1.2.3.4 -f passfile chassis power
on
Chassis Power Control: Up/On
FILES
/platform/i86pc/kernel/drv/bmc
32-bit ELF kernel module for
the bmc driver.
/platform/i86pc/kernel/drv/amd64/bmc
64-bit ELF kernel module for
the bmc driver.
/dev/bmc
Character device node used to
communicate with the bmc
driver.
ATTRIBUTES
See attributes(5) for descriptions of the following attri-
butes:
SunOS 5.10 Last change: 10 December 2008 37
Maintenance Commands ipmitool(1m)
____________________________________________
| ATTRIBUTE TYPE | ATTRIBUTE VALUE |
|____________________|______________________|
| Availability | system/ipmi/ipmitool|
|____________________|______________________|
| Interface Stability| Volatile |
|____________________|______________________|
SEE ALSO
attributes(5)
IPMI Specifications
http://www.intel.com/design/servers/ipmi/spec.htm
NOTES
IPMI V1.5 and, at the time of writing, IPMI V2.X only sup-
port IPv4. There is no requirement for a BMC to use the same
IP address as its host system. In an IPv6 environment the
host system can have an IPv6 address and 'ipmitool' can be
used to assign an IPv4 address to the BMC.
SunOS 5.10 Last change: 10 December 2008 38