Windows PowerShell command on Get-command ipge
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man ipge

Devices ipge(7D)

NAME

ipge - PCI-E Gigabit-Ethernet device driver for Intel

82571-based ethernet controller.

SYNOPSIS

/dev/ipge

DESCRIPTION

The ipge Sun Gigabit-Ethernet driver is a multi-threaded,

loadable, clonable, STREAMS hardware driver supporting the

connectionless Data Link Provider Interface, dlpi(7P). Mul-

tiple PCI-E based adapters installed within the system are

supported by the driver. The ipge driver provides basic sup-

port for the PCI-E-based Ethernet hardware and is used to

handle pci8086,105e (PCI-E) devices. Functions include chip

initialization, frame transmit and receive, multicast and promiscuous support, and error recovery and reporting. The

PCI-E device provides 1000BASE-SX networking interfaces

using PCI-E ASIC, external SERDES and fiber optical tran-

sceiver, or 10/100/1000BASE-T using a PCI-E ASIC attached to

a GMII twisted pair copper transceiver, or 10/100BASE-T

using a PCI-E ASIC attached to a MII twisted pair copper

transceiver.

The 1000Base-SX standard specifies an "auto-negotiation"

protocol to automatically select the mode of operation. In addition to duplex mode of operation, the MAC controller can

auto-negotiate for IEEE 802.3x frame based flow control

capabilities. The PCI-E PCS is capable of doing auto-

negotiation with the remote-end of the link (link partner)

and receives the capabilities of the remote end. It selects the highest common denominator mode of operation based on

the priorities and also supports forced-mode of operation,

in which the driver selects the mode of operation. APPLICATION PROGRAMMING INTERFACE

The /dev/ipge cloning character-special device is used to

access all ipge controllers installed within the system.

IPGE AND DLPI

The ipge driver is a "style 2" Data Link Service provider.

All M_PROTO and M_PCPROTO type messages are interpreted as

DLPI primitives. Valid DLPI primitives are defined in . Refer to dlpi(7P) for more information. An

explicit DL_ATTACH_REQ message by a DLS user is required to

associate an opened stream to a particular device (ppa). The ppa ID is interpreted as an unsigned long data type and indicates the corresponding device instance (unit) number.

An error (DL_ERROR_ACK) is returned by the driver if the ppa

field value does not correspond to a valid device instance

SunOS 5.11 Last change: 23 June 2005 1

Devices ipge(7D)

number in the system. The device is initialized on first

attach and un-initialized (stopped) during last detach.

The values returned by the driver in the DL_INFO_ACK primi-

tive in response to the DL_INFO_REQ are as follows:

o Maximum SDU is 1500. (ETHERMTU - defined in

. o Minimum SDU is 0. o DSLAP address length is 8 bytes.

o MAC type is DL_ETHER.

o SAP length value is -2 meaning the physical

address component is followed immediately by a 2-

byte sap component within the DLSAP address.

o Service mode is DL_CLDLS.

o No optional quality of service (QOS) support is currently included and the QOS fields are 0.

o Provider style is DL_STYLE2.

o Version is DL_VERSION_2.

o Broadcast address value is Ethernet/IEEE broadcast address (FF:FF:FF:FF:FF:FF).

Once in the DL_ATTACHED state, you must send a DL_BIND_REQ

to associate a particular SAP (Service Access Point) with

the stream. The ipge driver interprets the sap field within

the DL_BIND_REQ as an Ethernet "type," meaning valid values

for the sap field are in the [0-0xFFFF] range. Only one Eth-

ernet type can be bound to the stream at any time. When you select a sap with a value of 0, the receiver is in "802.3 mode." All frames received from the media having a

"type" field in the range [0-1500] are assumed to be 802.3

frames and are routed up all open streams which are bound to sap value 0. If more than one stream is in "802.3 mode" then the frame is duplicated and routed up multiple streams

as DL_UNITDATA_IND messages.

During transmission, the driver checks if either the sap

value is 0 or destination type field is in the range [0-

SunOS 5.11 Last change: 23 June 2005 2

Devices ipge(7D)

1500]. If true, the driver sets MAC frame header length

field with the length of DL_UNITDATA_REQ message blocks,

excluding initial M_PROTO message block, and transmits as

802.3 frames.

The ipge driver DLSAP address format consists of the 6 byte

physical (Ethernet) address component followed by 2 byte sap (type) component producing an 8 byte DLSAP address. Applications should not hard code to this particular

implementation-specific DLSAP address format but use

information returned in the DL_INFO_ACK primitive to compose

and decompose DLSAP addresses. The sap length, full DLSAP length, and sap/physical ordering are included within the

DL_INFO_ACK. The physical address length can be computed by

subtracting the sap length from the full DLSAP address

length or by issuing the DL_PHYS_ADDR_REQ to obtain the

current physical address associated with the stream.

Once the stream is in the DL_BOUND state, you may begin

transmitting by sending DL_UNITDATA_REQ messages to the

driver. During receive, the driver routes all received Ethernet

frames as DL_UNITDATA_IND messages to all open and bound

streams whose sap matches the Ethernet type of the received frame. Received Ethernet frames are duplicated and routed up

multiple open streams if necessary. The DLSAP address con-

tained within the DL_UNITDATA_REQ and DL_UNITDATA_IND mes-

sages consists of both the sap (type) and physical (Ether-

net) components. DLPI PRIMITIVES In addition to the mandatory connectionless DLPI messages, the driver supports the primitives described below.

The DL_ENABMULTI_REQ and DL_DISABMULTI_REQ primitives

enable/disable reception of individual multicast group addresses. A set of multicast addresses may be iteratively

created and modified on a per-stream basis using

DL_ENABMULTI_REQ and DL_DISABMULTI_REQ. DL_ENABMULTI_REQ

and DL_DISABMULTI_REQ are accepted by the driver in any

state following DL_ATTACHED state.

The DL_PROMISCON_REQ and DL_PROMISCOFF_REQ primitives with

the DL_PROMISC_PHYS flag set in dl_level field

enables/disables reception of all promiscuous mode frames on the media including frames generated by the local host. When

SunOS 5.11 Last change: 23 June 2005 3

Devices ipge(7D)

used with the DL_PROMISC_SAP flag set, this enables/disables

reception of all sap (Ethernet type) values. When used with

the DL_PROMISC_MULTI flag set, this enables/disables recep-

tion of all multicast group addresses. The effect of each is

always on a per-stream basis and independent of the other

sap and physical level configurations on this stream or other streams.

The DL_PHYS_ADDR_REQ primitive returns the 6 octet Ethernet

address currently associated (attached) to the stream in the

DL_PHYS_ADDR_ACK primitive. DL_PHYS_ADDR_REQ is valid only

in states following a successful DL_ATTACH_REQ.

The DL_SET_PHYS_ADDR_REQ primitive changes the 6 octet Eth-

ernet address currently associated (attached) to the stream. The credentials of the process which originally opened the stream must be superuser or EPERM is returned in

the DL_ERROR_ACK. Because it affects all current and future

streams attached to the device, the DL_SET_PHYS_ADDR_REQ is

destructive. An M_ERROR is sent up all other streams

attached to the device when DL_SET_PHYS_ADDR_REQ is success-

ful on the stream. Once changed, all streams subsequently opened and attached to the device obtain the new physical address. Once changed, the physical address remains until

DL_SET_PHYS_ADDR_REQ is used to change the physical address

again or the system is rebooted, whichever occurs first. CONFIGURATION

By default, the ipge driver performs auto-negotiation to

select the link speed and mode. Link speed and mode can be any one of the following, (as described in the IEEE803.2 standard):

o 1000 Mbps, full-duplex

o 1000 Mbps, half-duplex

o 100 Mbps, full-duplex

o 100 Mbps, half-duplex

o 10 Mbps, full-duplex

o 10 Mbps, half-duplex

The auto-negotiation protocol automatically selects:

o Speed (1000 Mbps, 100 Mbps, or 10 Mbps)

SunOS 5.11 Last change: 23 June 2005 4

Devices ipge(7D)

o Operation mode (full-duplex or half-duplex)

The auto-negotiation protocol:

Gets all the modes of operation supported by the link partner. Advertises its capabilities to the link partner. Selects the highest common denominator mode of operation based on the priorities

The PCI-E hardware is capable of all of the operating modes

listed above, when by default, auto-negotiation is used to

bring up the link and select the common mode of operation

with the link partner. Forced-mode of operation is supported

(in which the driver selects the mode of operation and the flow control capabilities) using the ndd(1M) utility.

PARAMETERS

The ipge driver enables setting/getting of various parame-

ters for the PCI-E device. The parameter list includes

current transceiver status, current link status, interpacket gap, PCS capabilities and link partner capabilities. PCS

capabilities consist of two sets: one reflects the capabili-

ties of the hardware (which are read-only (RO) parameters),

while the second reflects the values you choose and is used

in speed selection. At boot time, thse two sets of capabili-

ties are identical. By default, the link partner capabili-

ties are read only and cannot be modified. FILES

/dev/ipge Character special device.

/kernel/drv/ipge.conf System wide default device

driver properties.

SEE ALSO

ndd(1M), netstat(1M), driver.conf(4), dlpi(7P)

SunOS 5.11 Last change: 23 June 2005 5




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™