System Administration Commands install(1M)
NAME
install - install commands
SYNOPSIS
/usr/sbin/install -c dira [-m mode] [-u user] [-g group]
[-o] [-s] file
/usr/sbin/install -f dirb [-m mode] [-u user] [-g group]
[-o] [-s] file
/usr/sbin/install -n dirc [-m mode] [-u user] [-g group]
[-o] [-s] file
/usr/sbin/install -d | -i [-m mode] [-u user] [-g group]
[-o] [-s] dirx...
/usr/sbin/install [-m mode] [-u user] [-g group] [-o] [-s] file
[dirx]...DESCRIPTION
install is most commonly used in ``makefiles'' (see
make(1S)) to install a file in specific locations, or to
create directories within a file system. Each file isinstalled by copying it into the appropriate directory.
install uses no special privileges to copy files from one
place to another. The implications of this are: o You must have permission to read the files to beinstalled.
o You must have permission to copy into the destina-
tion directory. o You must have permission to change the modes on thefinal copy of the file if you want to use the -m
option.o You must be super-user if you want to specify the
ownership of the installed file with the -u or -g
options. If you are not the super-user, the
installed file is owned by you, regardless of who
owns the original.SunOS 5.11 Last change: 3 Nov 2005 1
System Administration Commands install(1M)
Note that if the ROOT environment variable is set, each of the default directory paths are prefixed by its value (forexample, $ROOT/bin and so on).
install prints messages telling the user exactly what files
it is replacing or creating and where they are going.If no options or directories (dirx ...) are given, install
searches a set of default directories ( /bin, /usr/bin, /etc, /lib, and /usr/lib, in that order) for a file with the same name as file. When the first occurrence is found,install issues a message saying that it is overwriting that
file with file, and proceeds to do so. If the file is not found, the program states this and exits. If one or more directories (dirx ...) are specified after file, those directories are searched before the default directories.This version of install (/usr/sbin/install) is not compati-
ble with the install binaries in many versions of Unix other
than Solaris. For a higher degree of compatibility withother Unix versions, use /usr/ucb/install, which is
described in the install(1B) man page.
OPTIONS The following options are supported:-c dira Install file in the directory specified by dira,
if file does not yet exist. If it is found,install issues a message saying that the file
already exists, and exits without overwriting it.-f dirb Force file to be installed in given directory,
even if the file already exists. If the filebeing installed does not already exist, the mode
and owner of the new file is set to 755 and bin , respectively. If the file already exists, the mode and owner is that of the already existing file.-n dirc If file is not found in any of the searched
directories, it is put in the directory speci-
fied in dirc. The mode and owner of the new file is set to 755 and bin, respectively.SunOS 5.11 Last change: 3 Nov 2005 2
System Administration Commands install(1M)
-d Create a directory. Missing parent directories
are created as required as in mkdir -p. If the
directory already exists, the owner, group and mode is set to the values given on the command line.-i Ignore default directory list, searching only
through the given directories (dirx ...).-m mode The mode of the new file is set to mode. Set to
0755 by default.-u user The owner of the new file is set to user. Only
available to the super-user. Set to bin by
default.-g group The group id of the new file is set to group.
Only available to the super-user. Set to bin by
default.-o If file is found, save the ``found'' file by
copying it to OLDfile in the directory in whichit was found. This option is useful when instal-
ling a frequently used file such as /bin/sh or /lib/saf/ttymon, where the existing file cannot be removed.-s Suppress printing of messages other than error
messages.USAGE
See largefile(5) for the description of the behavior ofinstall when encountering files greater than or equal to 2
Gbyte ( 2^31 bytes).ATTRIBUTES
See attributes(5) for descriptions of the following attri-
butes:SunOS 5.11 Last change: 3 Nov 2005 3
System Administration Commands install(1M)
____________________________________________________________
| ATTRIBUTE TYPE | ATTRIBUTE VALUE |
|_____________________________|_____________________________|
| Availability | SUNWcs ||_____________________________|_____________________________|
SEE ALSO
chgrp(1), chmod(1), chown(1), cp(1), install(1B), make(1S),
mkdir(1), attributes(5), largefile(5)SunOS 5.11 Last change: 3 Nov 2005 4