Windows PowerShell command on Get-command imqobjmgr
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man imqobjmgr

System Administration Commands imqobjmgr(1M)

NAME

imqobjmgr - manage Message Queue administered objects

SYNOPSIS

/usr/bin/imqobjmgr subcommand [[option]...]

/usr/bin/imqobjmgr -i fileName

/usr/bin/imqobjmgr -h | [-H] | -help | -Help

/usr/bin/imqobjmgr -v

DESCRIPTION

imqobjmgr manages Message Queue administered objects in an

object store accessible using JNDI. Administered objects

allow JMS clients to be provider-independent by insulating

them from provider-specific naming and configuration for-

mats.

imqobjmgr supports five management subcommands. These sub-

commands, and their corresponding options follow the

imqobjmgr command on the command line. See USAGE and

OPTIONS. The following subcommands are supported: add Add a new administered object delete Delete an administered object list Display a list of administered objects query Display information about administered objects update Update administered objects

You can use the -i option to specify the name of an input

file that uses java property file syntax to represent all or

part of any imqobjmgr subcommand clause. The -f, -s, and

-pre options can be used with any imqobjmgr subcommand.

SunOS 5.11 Last change: 7 Apr 2004 1

System Administration Commands imqobjmgr(1M)

OPTIONS The following options are supported:

-f Perform action without user confirma-

tion.

-h | -help Display usage help. Execute nothing

else on the command line.

-H | -Help Display usage help, attribute list,

and examples. Execute nothing else on the command line.

-i fileName Specify the name of an input file

containing all or part of the subcom-

mand clause, specifying object type, lookup name, object attributes, object store attributes, or other

options. Use this option for repeti-

tive information, such as object store attributes.

-j attribute=value Specify attributes necessary to iden-

tify and access a JNDI object store.

-javahome Specify an alternate Java 2 compati-

ble runtime to use. imqobjmgr uses

the runtime bundled with the operat-

ing system by default.

-l lookupName Specify the JNDI lookup name of an

administered object. This name must

be unique in the object store's con-

text.

-o attribute=value Specify the attributes of an admin-

istered object.

-pre Run command in preview mode. Preview

mode indicates what will be done without performing the command.

SunOS 5.11 Last change: 7 Apr 2004 2

System Administration Commands imqobjmgr(1M)

-r read-only_state Specify if an administered object is

a read-only object. A value of true

indicates the administered object is

a read-only object. JMS clients can-

not modify the attributes of read-

only administered objects. The read-

only state is set to false by default.

-s Silent mode. No output is displayed.

-t type Specify the type of an administered

object: q = queue t = topic cf = ConnectionFactory qf = queueConnectionFactory tf = topicConnectionFactory xcf = XA ConnectionFactory (distributed transactions) xqf = XA queueConnectionFactory (distributed transactions) xtf = XA topicConnectionFactory (distributed transactions) e = SOAP endpoint (used to support SOAP messaging)

-v Display version information. Execute

nothing else on the command line.

USAGE

This section provides information on subcommands, options, and attribute value pairs. Subcommands and Options

The following subcommands and corresponding options are sup-

ported:

add -t type -l lookupName [-o attribute=value]... - j

attribute=value... Add a new administered object of the specified type, lookup name , and object attributes to an object store.

delete -t type -l lookupName -j attribute=value...

Delete an administered object, of the specified type and lookup name from an object store.

SunOS 5.11 Last change: 7 Apr 2004 3

System Administration Commands imqobjmgr(1M)

list [-t type] -j attribute=value...

Display a list of administered objects of a specified type, or all administered objects, in an object store.

query -l lookupName -j attribute=value...

Display information about an administered object of a specified lookup name in an object store.

update -l lookupName [-o attribute=value]... -j

attribute=value... Update the specified attribute values of an administered object of the specified lookup name in an object store. Attribute Value Pairs The following attribute value pairs are supported for the specified administered object types:

Type = ConnectionFactories: ConnectionFactory, TopicConnec-

tionFactory, QueueConnectionFactory, XAConnectionFactory, XATopicConnectionFactory, and XAQueueConnectionFactory imqAckOnAcknowledge Value: String (true, false, not specified) Default: not specified imqAckOnProduce Value: String (true, false, not specified) Default: not specified imqAckTimeout Value: String (time in milliseconds) Default: 0 (no timeout) imqAddressList Value: String

SunOS 5.11 Last change: 7 Apr 2004 4

System Administration Commands imqobjmgr(1M)

Default: not specified imqAddressListBehavior Value: String Default: Priority imqAddressListIterations Value: Integer Default: 1 imqBrokerHostName Used if imqConnectionType is TCP or TLS. This attribute type is only supported in Message Queue 3.0. Value: String Default:localhost imqBrokerHostPort Used if imqConnectionType is TCP or TLS. This attribute type is only supported in Message Queue 3.0. Value: Integer Default: 7676 imqBrokerServicePort Used if imqConnectionType is TCP or TLS. This attribute type is only supported in Message Queue 3.0. Value: Integer Default: 0 imqConfiguredClientID Value: String (ID number) Default: no ID specified

SunOS 5.11 Last change: 7 Apr 2004 5

System Administration Commands imqobjmgr(1M)

imqConnectionFlowCount Value: Integer Default: 100 imqConnectionFlowLimit Value: Integer Default: 1000 imqConnectionFlowLimitEnabled Value: Boolean Default: false imqConnectionType This attribute type is only supported in Message Queue 3.0. Value: String (TCP, TLS, HTTP). Default: TCP imqConnectionURL Used if imqConnectionType is HTTP. This attribute type is only supported in Message Queue 3.0. Value: String Default: http://localhost/imq/tunnel imqConsumerFlowLimit Value: Integer Default: 1000 imqConsumerFlowThreshold Value: Integer

SunOS 5.11 Last change: 7 Apr 2004 6

System Administration Commands imqobjmgr(1M)

Default: 50 imqDefaultPassword Value: String Default: guest imqDefaultUsername Value: String Default: guest imqDisableSetClientID Value: Boolean Default: false imqJMSDeliveryMode

Value: Integer (1=non-persistent, 2=persistent)

Default: 2 imqJMSExpiration Value: Long (time in milliseconds) Default: 0 (does not expire) imqJMSPriority Value: Integer (0 to 9) Default: 4 imqLoadMaxToServerSession Value: Boolean Default: true

SunOS 5.11 Last change: 7 Apr 2004 7

System Administration Commands imqobjmgr(1M)

imqOverrideJMSDeliveryMode Value: Boolean Default: false imqOverrideJMSExpiration Value: Boolean Default: false imqOverrideJMSHeadersToTemporaryDestinations Value: Boolean Default: false imqOverrideJMSPriority Value: Boolean Default: false imqQueueBrowserMaxMessagesPerRetrieve Value: Integer Default: 1000 imqBrowserRetrieveTimeout Value: Long (time in milliseconds) Default: 60,000 imqReconnectAttempts Value: Integer Default: 0 imqReconnectEnabled Value: Boolean

SunOS 5.11 Last change: 7 Apr 2004 8

System Administration Commands imqobjmgr(1M)

Default: false imqReconnectInterval Value: Long (time in milliseconds) Default: 3000 imqSetJMSXAppID Value: Boolean Default: false imqSetJMSXConsumerTXID Value: Boolean Default: false imqSetJMSXProducerTXID Value: Boolean Default: false imqSetJMSXRcvTimestamp Value: Boolean Default: false imqSetJMSXUserID Value: Boolean Default: false imqSSLIsHostTrusted Used if imqConnectionType is TLS. This attribute type is only supported in Message Queue 3.0. Value: Boolean

SunOS 5.11 Last change: 7 Apr 2004 9

System Administration Commands imqobjmgr(1M)

Default: true Type = Destinations: Topic and Queue imqDestinationDescription Value: String Default: no description imqDestinationName Value: String Default:

Untitled_Destination_Object

Type = Endpoint (SOAP Endpoint) imqEndpointDescription Value: String Default: A description for the endpoint object imqEndpointName Value: String

Default: Untitled_Endpoint_Object

imqSOAPEndpointList Value: String (one or more space-

separated URLs) Default: no url

EXAMPLES

Example 1 Adding a Topic Administered Object to an Object Store Where JNDI lookup name=myTopic and imqDestinationName=MyTestTopic, the following command adds to an LDAP server object store:

imqobjmgr add -t t -l "cn=myTopic"\

-o "imqDestinationName=MyTestTopic"\

-j "java.naming.factory.initial=com.sun.jndi.ldap.LdapCtxFactory"\

-j "java.naming.provider.url=ldap://mydomain.com:389/o=imq"

SunOS 5.11 Last change: 7 Apr 2004 10

System Administration Commands imqobjmgr(1M)

Where JNDI lookup name=myTopic and imqDestinationName=MyTestTopic, the following command adds to a file system object store:

imqobjmgr add -t -l "cn=myTopic"\

-o "imqDestinationName=MyTestTopic"\

-j \

"java.naming.factory.initial=com.sun.jndi.fscontext.RefFSContextFactory"\

-j "java.naming.provider.url=file:/home/foo/imq_admin_objects"

Where JNDI lookup name=myTopic and imqDestinationName=MyTestTopic, the following command adds to a file system object store, using an input file:

imqobjmgr -i inputfile

The associated input file consists of the following: cmdtype=add obj.type=t obj.lookupName=cn=myTopic obj.attrs.imqDestinationName=MyTestTopic objstore.attrs.java.naming.factory.initial=com.sun.jndi.fscontext.\ RefFSContextFactory

objstore.attrs.java.naming.provider.url=file:/home/foo/imq_admin_objects

Example 2 Adding a QueueConnectionFactory Administered Object to an Object Store

Where JNDI lookup name=myQCF, read-only state=true,

imqAddressList=mq://foohost:777/jms, the following command adds to an LDAP server object store:

imqobjmgr add -t qf -l "cn=myQCF" -r true\

-o "imqAddressList=mq://foohost:777/jms"\

-j "java.naming.factory.initial=com.sun.jndi.ldap.LdapCtxFactory"\

-j "java.naming.provider.url=ldap://mydomain.com:389/o=imq"\

SunOS 5.11 Last change: 7 Apr 2004 11

System Administration Commands imqobjmgr(1M)

Where JNDI lookup name=myQCF, read-only state=true,

imqAddressList=mq://foohost:777/jms, the following command adds to an LDAP server object store using an input file:

imqobjmgr -i inputfile

The associated input file consists of the following: cmdtype=add obj.type=qf obj.lookupName=cn=myQCF obj.readOnly=true obj.attrs.imqAddressList=mq://foohost:777/jms objstore.attrs.java.naming.factory.initial=com.sun.jndi.\ ldap.LdapCtxFactory objstore.attrs.java.naming.provider.url=ldap://mydomain.com:389/o=imq

Where JNDI lookup name=myQCF, read-only state=true,

imqAddressList=mq://foohost:777/jms, the following command adds to an LDAP server object store, using both an input file and command options:

imqobjmgr add -t qf -l "cn=myQCF"\

-o "imqAddressList=mq://foohost:777/jms"\

-i inputfile

The associated input file consists of the following: objstore.attrs.java.naming.factory.initial=com.sun.jndi.ldap.LdapCtxFactory objstore.attrs.java.naming.provider.url=ldap://mydomain.com:389/o=imq Example 3 Deleting a Topic Administered Object from an Object Store Where JNDI lookup name=myTopic and no confirmation is requested, the following command deletes from an LDAP server object store:

SunOS 5.11 Last change: 7 Apr 2004 12

System Administration Commands imqobjmgr(1M)

imqobjmgr delete -f -l "cn=myTopic"\

-j "java.naming.factory.initial=com.sun.jndi.ldap.LdapCtxFactory"\

-j "java.naming.provider.url=ldap://mydomain.com:389/o=imq"

Example 4 Querying Information About a Topic Administered Object Where JNDI lookup name=myTopic, the following command queries from an LDAP server object store using simple authentication scheme:

imqobjmgr query -l "cn=myTopic"\

-j "java.naming.factory.initial=com.sun.jndi.ldap.LdapCtxFactory"\

-j "java.naming.provider.url=ldap://mydomain.com:389/o=imq"\

-j "java.naming.security.authentication=simple"\

-j "java.naming.security.principal=uid=foo,ou=imqobjmgr,o=imq"\

-j "java.naming.security.credentials=foo"

EXIT STATUS The following exit values are returned: 0 Successful completion. >0 An error occurred.

ATTRIBUTES

See attributes(5) for descriptions of the following attri-

butes:

____________________________________________________________

| ATTRIBUTE TYPE | ATTRIBUTE VALUE |

|_____________________________|_____________________________|

| Availability | SUNWiq |

|_____________________________|_____________________________|

SEE ALSO

imqadmin(1M), imqcmd(1M), imqbrokerd(1M), imqkeytool(1M), imqusermgr(1M), attributes(5)

SunOS 5.11 Last change: 7 Apr 2004 13

System Administration Commands imqobjmgr(1M)

Sun Java System Message Queue Administrator's Guide

SunOS 5.11 Last change: 7 Apr 2004 14




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™