Data Structures for Drivers hook_nic_event(9S)
NAME
hook_nic_event - data structure describing events related to
network interfacesSYNOPSIS
#include
#include
#include
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI).DESCRIPTION
The hook_nic_event structure contains fields that relate to
an event that has occurred and belongs to a network inter-
face. This structure is passed through to callbacks forNE_PLUMB, NE_UNPLUMB, NE_UP, NE_DOWN and NE_ADDRESS_CHANGE
events.A callback may not alter any of the fields in this struc-
ture. STRUCTURE MEMBERSnet_data_t hne_family;
phy_if_t pkt_private;
lif_if_t hne_lif;
nic_event_t hne_event;
nic_event_data_t hne_data;
size_t hne_datalen;
The following fields are set for each event:hne_family A valid reference for the network protocol
that owns this network interface and can be in calls to other netinfo(9F) functions.hne_nic The physical interface to which an event
belongs.hne_event A value that indicates the respective event.
The current list of available events is:NE_PLUMB
an interface has just been created.SunOS 5.11 Last change: 29 Sep 2009 1
Data Structures for Drivers hook_nic_event(9S)
NE_UNPLUMB
An interface has just been destroyed and no more events should be received for it.NE_UP
An interface has changed the state to "up" and may now generate packet events.NE_DOWN
An interface has changed the state to "down" and will no longer generate packet events.NE_ADDRESS_CHANGE
An address on an interface has changed.hne_lif refers to the logical interface
for which the change is occurring,hne_data is a pointer to a sockaddr struc-
ture that is hne_datalen bytes long and
contains the new network address.NE_IFINDEX_CHANGE
An interface index has changed. hne_lif
refers to the logical interface for whichthe change is occurring, hne_data is a new
ifindex value.ATTRIBUTES
See attributes(5) for descriptions of the following attri-
butes:____________________________________________________________
| ATTRIBUTE TYPE | ATTRIBUTE VALUE |
|_____________________________|_____________________________|
| Interface Stability | Committed ||_____________________________|_____________________________|
SunOS 5.11 Last change: 29 Sep 2009 2
Data Structures for Drivers hook_nic_event(9S)
SEE ALSO
attributes(5), netinfo(9F)SunOS 5.11 Last change: 29 Sep 2009 3