Windows PowerShell command on Get-command getq
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man getq

Kernel Functions for Drivers getq(9F)

NAME

getq - get the next message from a queue

SYNOPSIS

#include

mblk_t *getq(queue_t *q);

INTERFACE LEVEL

Architecture independent level 1 (DDI/DKI).

PARAMETERS

q Pointer to the queue from which the message is to be retrieved.

DESCRIPTION

The getq() function is used by a service ( srv(9E)) routine

to retrieve its enqueued messages. A module or driver may include a service routine to process enqueued messages. Once the STREAMS scheduler calls srv() it must process all enqueued messages, unless prevented by flow

control. getq() obtains the next available message from the

top of the queue pointed to by q. It should be called in a

while loop that is exited only when there are no more mes-

sages or flow control prevents further processing. If an attempt was made to write to the queue while it was

blocked by flow control, getq() back-enables (restarts) the

service routine once it falls below the low water mark.

RETURN VALUES

If there is a message to retrieve, getq() returns a pointer

to it. If no message is queued, getq() returns a NULL

pointer.

CONTEXT

The getq() function can be called from user, interrupt, or

kernel context.

EXAMPLES

See dupb(9F).

SEE ALSO

srv(9E), bcanput(9F), canput(9F), dupb(9F), putbq(9F), putq(9F), qenable(9F)

SunOS 5.11 Last change: 16 Jan 2006 1

Kernel Functions for Drivers getq(9F)

Writing Device Drivers STREAMS Programming Guide

SunOS 5.11 Last change: 16 Jan 2006 2




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™