Windows PowerShell command on Get-command getmajor
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man getmajor

Kernel Functions for Drivers getmajor(9F)

NAME

getmajor - get major device number

SYNOPSIS

#include

#include

#include

major_t getmajor(dev_t dev);

INTERFACE LEVEL

Architecture independent level 1 (DDI/DKI).

PARAMETERS

dev Device number.

DESCRIPTION

The getmajor() function extracts the major number from a

device number.

RETURN VALUES

The major number.

CONTEXT

The getmajor() function can be called from user, interrupt,

or kernel context.

EXAMPLES

Example 1 Using getmajor()

The following example shows both the getmajor() and

getminor(9F) functions used in a debug cmn_err(9F) statement

to return the major and minor numbers for the device sup-

ported by the driver.

dev_t dev;

#ifdef DEBUG

cmn_err(CE_NOTE,"Driver Started. Major# = %d,

Minor# = %d", getmajor(dev), getminor(dev));

#endif

SEE ALSO

cmn_err(9F), getminor(9F), makedevice(9F)

SunOS 5.11 Last change: 16 Jan 2006 1

Kernel Functions for Drivers getmajor(9F)

Writing Device Drivers WARNINGS No validity checking is performed. If dev is invalid, an invalid number is returned.

SunOS 5.11 Last change: 16 Jan 2006 2




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™