Kernel Functions for Drivers geterror(9F)
NAME
geterror - return I/O error
SYNOPSIS
#include
#include
#include
int geterror(struct buf *bp);
INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI).
PARAMETERS
bp Pointer to a buf(9S) structure.DESCRIPTION
The geterror() function returns the error number from the
error field of the buffer header structure.RETURN VALUES
An error number indicating the error condition of the I/O
request is returned. If the I/O request completes success-
fully, 0 is returned.CONTEXT
The geterror() function can be called from user, interrupt,
or kernel context.SEE ALSO
buf(9S) Writing Device DriversSunOS 5.11 Last change: 16 Jan 2006 1