Windows PowerShell command on Get-command freemsg
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man freemsg

Kernel Functions for Drivers freemsg(9F)

NAME

freemsg - free all message blocks in a message

SYNOPSIS

#include

void freemsg(mblk_t *mp);

INTERFACE LEVEL

Architecture independent level 1 (DDI/DKI).

PARAMETERS

mp Pointer to the message blocks to be deallocated.

mblk_t is an instance of the msgb(9S) structure. If mp

is NULL, freemsg() immediately returns.

DESCRIPTION

The freemsg() function calls freeb(9F) to free all message

and data blocks associated with the message pointed to by mp.

CONTEXT

The freemsg() function can be called from user, interrupt,

or kernel context.

EXAMPLES

Example 1 Using freemsg()

See copymsg(9F).

SEE ALSO

copymsg(9F), freeb(9F), msgb(9S) Writing Device Drivers STREAMS Programming Guide NOTES

The behavior of freemsg() when passed a NULL pointer is

Solaris-specific.

SunOS 5.11 Last change: 16 Jan 2006 1




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™