Windows PowerShell command on Get-command e1000
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man e1000

Devices e1000g(7D)

NAME

e1000g, e1000 - Intel PRO/1000 Gigabit family of network

interface controllers

SYNOPSIS

/dev/e1000g

DESCRIPTION

The e1000g Gigabit Ethernet driver is a multi-threaded,

loadable, clonable, GLD-based STREAMS driver supporting the

Data Link Provider Interface, dlpi(7P), over Intel PRO/1000 family of Gigabit controllers. This driver supports multiple Intel Gigabit controllers installed within the system. The

e1000g driver provides basic support including chip initial-

ization, frame transmit and receive, multicast support, and error recovery and reporting. APPLICATION PROGRAMMING INTERFACE

The cloning, character-special device /dev/e1000g is used to

access all Intel Gigabit devices installed within the sys-

tem.

The e1000g driver is managed by the dladm(1M) command line

utility, which allows VLANs to be defined on top of e1000g

instances and for e1000g instances to be aggregated. See

dladm(1M) for more details.

You must send an explicit DL_ATTACH_REQ message to associate

the opened stream with a particular device (PPA). The PPA ID

is interpreted as an unsigned integer data type and indi-

cates the corresponding device instance (unit) number. The

driver returns an error (DL_ERROR_ACK) if the PPA field

value does not correspond to a valid device instance number.

The values returned by the driver in the DL_INFO_ACK primi-

tive in response to the DL_INFO_REQ are as follows:

o Maximum SDU (with jumbo frame) is as high as 16298. o Minimum SDU is 0. The driver pads to the mandatory

60-octet minimum packet size.

o The dlsap address length is 8.

o MAC type is DL_ETHER.

o The sap length value is -2, meaning the physical

address component is followed immediately by a 2-

SunOS 5.11 Last change: 2 Apr 2010 1

Devices e1000g(7D)

byte sap component within the DLSAP address.

o The broadcast address value is Ethernet/IEEE broad-

cast address (FF:FF:FF:FF:FF:FF). CONFIGURATION

The e1000g driver does not support the use of shared RAM on

the board.

To configure the e1000g driver:

o Use prtconf -v | grep pci8086,[12][01][01][0-F] to

obtain the instance number of the driver.

o Use ifconfig e1000ginstance plumb to plumb the con-

troller.

o Use ifconfig e1000ginstance inet ip_address netmask

+ broadcast + -trailers up to bring up the inter-

face. o Use the ping(1M) command to contact interfaces on the network to verify that the configuration is operational. Configuration File Options

The following e1000g.conf configuration options are sup-

ported: AutoNegAdvertised

This is a bitmap for the speeds advertised during auto-

negotiation. Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0

Setting| N/A | N/A | 1000F | N/A | 100F | 100H | 10F | 10H

The adapter only auto-negotiates to a speed that is

advertised. For example: AutoNegAdvertised = 4 causes an

adapter to only advertise auto-negotiation at 100 Mbps,

full duplex. No other link speeds are accepted or given

during auto-negotiation. AutoNegAdvertised=47 advertises

all speeds available, This is the same as using the default setting of 0.

0-255 Allowed values

0 Default

SunOS 5.11 Last change: 2 Apr 2010 2

Devices e1000g(7D)

ForceSpeedDuplex Specify the speed and duplex mode for each instance.

If you set ForceSpeedDuplex=7,4, the e1000g0 is set to

auto-negotiate and e1000g1 is set to 100 Mbps, full

duplex. Note that fiber optic ethernet adapters ignore this setting. Allowed values are: 1 10 Megabits per second, Half Duplex. 2 10 Megabits per second, Full Duplex. 3 100 Megabits per second, Half Duplex. 4 100 Megabits per second, Full Duplex.

7 Auto-negotiate speed and duplex. (Default).

MaxFrameSize Upper limit on the maximum MTU size the driver allows.

All Intel gigabit adapters (except the 82542-based Intel

PRO/1000 adapter) allow the configuration of jumbo frames. For a Intel PRO/1000 adapter that is later than 82571 (including 82571) the maximum MTU accepted by the MAC is 9216. For others, the maximum MTU accepted by the MAC is 16298. Use ifconfig(1M) to configure jumbo frames. Using ifconfig with the adapter instance and the mtu argument

(ifconfig e1000g0 mtu 9216) configures adapter e1000g0

for the maximum allowable jumbo frame size. Allowed values are: 0 Standard ethernet frames with a MTU equal to 1500. (Default). 1 Jumbo frames with a maximum MTU of 4010.

SunOS 5.11 Last change: 2 Apr 2010 3

Devices e1000g(7D)

2 Jumbo frames with a maximum MTU of 8106. 3 Jumbo frames with a maximum MTU of 16298. FlowControl

Flow control utilizes ethernet XON and unicast and mul-

ticast XOFF packets to allow ethernet equipment to slow down the stream of data between two ethernet devices. Allowed values are:

0 Disable. Packets can get dropped in high-throughput

situations, leading to reduced network performance. 1 Receive only. 2 Transmit only. 3 Receive and transmit. (Default).

4 Use adapter's EEPROM-programmed factory default

setting. TbiCompatibilityEnable

You must enable this feature on Intel 82543CG-based

copper adapters to operate correctly with TBI mode eth-

ernet hardware. Allowed values are: 0 Disable. 1 Enable. (Default). SetMasterSlave Controls the PHY master/slave setting. Manually forcing master or slave can reduce time needed to link with

SunOS 5.11 Last change: 2 Apr 2010 4

Devices e1000g(7D)

Planex 08TX and IO data switches. This setting should remain as the hardware default. Allowed values are: 0 Hardware default. (Default). 1 Force master. 2 Force slave. 3 Force auto. By default, the following configuration options are not

displayed in the e1000g.conf file. Although they are confi-

gurable, you should not change these options:

NumRxDescriptors Number of available receive descrip-

tors. Multiple receive descriptors increase receive performance, but decrease available memory.

80-4096 Allowed values.

2048 Default. (MTU < 4010). 1024 Default. (MTU >= 4010). NumTxDescriptors Number of transmit descriptors available to the driver. Multiple transmit descriptors increase transmit performance, but decrease available memory.

80-4096 Allowed values.

2048 Default. (MTU < 4010). 1024 Default. (MTU >= 4010).

SunOS 5.11 Last change: 2 Apr 2010 5

Devices e1000g(7D)

NumRxFreeList Number of pre-allocated buffers that

the driver can use for received

data. Pre-allocating buffers can

improve receive performance but decrease available memory.

60-4096 Allowed values.

4096 Default. (MTU < 4010). 2048 Default. (MTU >= 4010).

NumTxFreeList Number of pre-allocated buffers that

the driver can use for transmit

data. Pre-allocating buffers can

improve transmit performance but decrease available memory.

80-4096 Allowed values.

2304 Default. (MTU < 4010). 1152 Default. (MTU >= 4010). MaxNumReceivePackets Maximum number of receive packets that the driver can handle for each interrupt. CPU utilization can be lowered through more efficient interrupt management. If this value is increased, the time needed by the

CPU to process the individual inter-

rupts increases, thereby nullifying any performance gains realized by handling less interrupts.

0-1024 Allowed values.

32 Default.

SunOS 5.11 Last change: 2 Apr 2010 6

Devices e1000g(7D)

Configuration Options Using dladm(1M)

In addition to the e1000g.conf file, you can also use the

dladm(1M) command to configure the e1000g driver.

To view supported configuration parameters, do the following step:

# dladm show-linkprop e1000g0

In addition, the current settings of the parameters can be

found using dladm show-ether. Using dladm(1M), you can set

the link speed/duplex using the enabled capability parame-

ters supported by the e1000g device. Each parameter contains

a boolean value that determines if the device enables that

mode of operation. The adv_autoneg_cap parameter controls

auto-negotiation. When adv_autoneg_cap is set to 0, the

driver forces the mode of operation selected by the first

non-zero parameter in priority order as shown below:

en_1000fdx_cap 1000Mbps full duplex

en_100fdx_cap 100Mpbs full duplex

en_100hdx_cap 100Mpbs half duplex

en_10fdx_cap 10Mpbs full duplex

en_10hdx_cap 10Mpbs half duplex

Note -

The link mode of 1000Mbps half duplex is not supported. Forced link mode of 1000Mbps full duplex is not supported. Setting all the enabled link capabilities to 0 results in

the link being reset to auto-negotiation with full link

capabilities advertised. 1 10Mpbs half duplex 2 10Mpbs full duplex 3 100Mpbs half duplex 4 100Mpbs full duplex FILES

dev/e1000g Character special device.

SunOS 5.11 Last change: 2 Apr 2010 7

Devices e1000g(7D)

/kernel/drv/e1000g.conf Driver configuration file.

/kernel/drv/sparcv9/e1000g 64-bit driver binary (SPARC).

/kernel/drv/e1000g 32-bit driver binary (x86)

/kernel/drv/amd64/e1000g 64-bit driver binary. (x86).

ATTRIBUTES

See attributes(5) for descriptions of the following attri-

butes:

____________________________________________________________

| ATTRIBUTE TYPE | ATTRIBUTE VALUE |

|_____________________________|_____________________________|

| Architecture | SPARC, x86 |

|_____________________________|_____________________________|

SEE ALSO

dladm(1M), ifconfig(1M), kstat(1M), ping(1M), attributes(5), dlpi(7P) Intel PRO/1000 Gigabit Adapter Driver Installation Notes for Solaris Writing Device Drivers STREAMS Programming Guide Network Interfaces Guide

SunOS 5.11 Last change: 2 Apr 2010 8




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™